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Introduction
Welcome to AudBase, a powerful relational database program that helps you manage and 
store subject information, participate in clinical studies, and even create your own clinical 
study. 

Whether you are a clinician, researcher, administrator or data-entry worker, AudBase sim-
plifies the tasks of collecting clinical information, conducting comprehensive searches 
and sharing data in a secure environment.

AudBase also allows you to export data to word processing, spreadsheet or statistical pro-
grams, as well as use your data to generate reports, graphs, reminders and follow-up let-
ters. Here is a brief look at the program’s background and unique features, as well as an 
overview of the rest of your user manual. 

AudBase background
The AudBase program is built around a relational database kernel originally designed to 
support clinical surgical trials in the medical field. The AudBase kernel can be customized 
to meet the needs of different specialties. For more information, e-mail 
Tech_Support@SiennaSoftwareInc.com.

Since AudBase was developed for use as a clinical and a research tool, the term “subject” 
is used rather than “patient” both in the software’s interface and throughout this manual.

 With AudBase’s cross-platform capability, choose from Windows XP, 2000 or Macintosh 
OS X.

Assign privileges: Grant different users levels of access as needed. For example, give a 
temporary user, such as a summer student, access to a limited clinical study group.

Check validity of data entry: By creating a checklist, ensure that records have been com-
pletely entered. Create multiple checklists for studies with unique requirements.

Modify data-entry lists: As the administrator, add a new item for data entry, such as a 
new pathology diagnosis.

Modify informational dialogs: Add context-specific information to pop-up lists and 
other forms or dialogs to make data entry easier and more consistent.

Send internal e-mail: Communicate with other users of AudBase by sending internal e-
mail. For example, remind a database user to finish an incomplete record. 

Create reminders: Automate the creation of letters for participants in a clinical study.
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Write letters for mail merge: Create a document, such as a letter, and merge it with sub-
ject information for increased efficiency when communicating with a number of subjects. 

Customize the database: Customize and expand AudBase depending on your organiza-
tion’s needs. AudBase contains a database kernel that provides standard features, and can 
easily accommodate additional data points, for example, new quality of life/outcome 
instruments or different research data sets.

Share data: Work with the same AudBase data file as other users in a serial manner or 
set-up the program in a fully implemented client-server environment. 

Use data with other databases: Use files created in AudBase with Oracle or SQL-based 
systems.

Export data in a variety of formats: Use the AudBase data with a word processor, 
spreadsheet, or other type of database. AudBase can export a compatible format. Export 
all the data, or search and select to export a subset of the data. 

Export secure data: Use AudBase to participate in clinical studies, and feel confident in 
the security of your data thanks to the checksum mechanism and the public/private key 
encryption.

Enroll subjects in multiple trials: Due to AudBase’s flexibility, a subject can participate 
in more than one study at the same time.

About this manual
Before using the program, install AudBase. For more information, see Chapter 1, “Getting 
Started.” This manual will help you learn to successfully use AudBase. Produced in print, 
as Adobe Acrobat files (PDF), and on the Web, this information was designed to be a ref-
erence for new and experienced users of AudBase. 

To access the PDF version, browse to the AudBase program files on your computer and 
open the documentation folder. To access the Web version, click on Help > AudBase Help

AudBase is intuitive for anyone entering data. It is designed to minimize data errors. If 
you are not sure what a feature does, spend some time experimenting with it. The program 
is equipped with dialogs and prompts to warn users against possible damage to the data. 
Before starting with your own data, we recommend that you first experiment with the 
example data file. For more information, see the Tutorial. 
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Below you will find an overview of the manual chapter by chapter.

Chapter 1, Getting Started gives you instructions on how to set up the program and what 
to do the first time you open AudBase.

Chapter 2, Providers and Clinical groups explains these two concepts that are central to 
setting up AudBase and running multi-site clinical trials, and shows how to enter records 
for both.

Chapter 3, Data Entry shows you how to enter or modify information about subjects, treat-
ments and other study facets.

Chapter 4, Audiogram/Tympanogram details the AudBase feature that allows you to enter 
audiometric readings into the database, both manually and using a serial port for upload.

Chapter 5, Searching explains how to find data, which is integral to many other functions 
of the program. 

Chapter 6, Exporting and Reporting describes how to extract information from the data-
base for use in other programs. It also explains numerous built-in reports and how to use 
the built-in word processor. 

Chapter 7, Preferences details the program’s user-modifiable features.

Chapter 8, Administrator Functions covers several features available to the administrator, 
including importing and exporting shared data in the controlled, confidential manner 
required for clinical studies.

Chapter 9, AudBase Server is an overview of how to set up the program in a client-server 
environment.

Chapter 10, Database Design and Theory explains the program’s table structure and 
design background. This chapter also details searching strategies and set theory necessary 
to maximize the power of this relational database with an emphasis on data control and 
confidentiality.

Troubleshooting gives you tips on solving problems that may crop up.

The Appendices contain supplementary information for understanding the program. This 
includes detailed descriptions of all data fields, modifiable lists, and menu bar functions, 
as well as a list of all files that come with AudBase.
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Getting started
This chapter shows you how to install AudBase and open it for the first time. It also 
explains the different levels of access that help make the database secure and protect sub-
ject confidentiality. Also, to help you get started, this chapter will explain the basic menu 
structure of AudBase and discuss two key starting points for much of your work, the 
Home Window and the Subject List.

After reading this chapter you will be ready to go through the tutorial, or begin using the 
program to manage your subjects, search for information and participate in clinical trials.

Installing AudBase
Installing AudBase is quick and easy. Follow the directions below. If you wish to use Aud-
Base in a client-server environment to allow more than one user to access the program 
simultaneously, see Chapter 8, “AudBase Server” on page 160.

System requirements
To use AudBase, you need the following:

• Operating System: Microsoft XP, 2000 or Macintosh OS X.
• Pentium or PowerPC processors are highly recommended.
• Minimum of 128 MB of RAM installed.
• Up to 70 MB of available hard-disk space for AudBase installation.
• 70 MB of available hard-disk space for AudBase Server installation (if applicable).
• CD-ROM drive.

The steps outlined below will take you through the process of installing AudBase, first for 
Windows and then for Macintosh.

To install for Windows

1. Insert the AudBase CD in the CD-ROM drive.
2. Browse to your computer’s CD drive using Windows Explorer or My Computer.
3. Double-click Setup.exe 

An install dialog appears.
4. Click Yes indicating you want to install AudBase.

A wizard opens to guide you through the installation. 
5. After installation you will be asked to restart your computer. 

For a complete list of files installed with AudBase, see Appendix A, “Installation Files” on 
page 194. Once you have installed AudBase, you are ready to start using the program. 
Skip to“Opening AudBase” on page 3.
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To install for Macintosh

1. Insert the AudBase CD in the CD-ROM drive.
2. Double-click the AudBase Installer icon. 

The introductory AudBase install screen displays. 
3. Click Continue.

The AudBase installer dialog opens and guides you through the process.

To see a complete list of files installed with AudBase, see Appendix A, “Installation Files” 
on page 194.

Opening AudBase
Once you have installed AudBase, you are ready to launch the program. In AudBase, a 
functional database is comprised of two components, the structure file and the data file. 
The structure file stores information about the organization of the database. The data file 
stores the specific information you have entered into the database. The data file and struc-
ture file work in conjunction.

Note: The components are actually a collection of files. For a list of these files, see 
Appendix A, “Installation Files,” on page 194.

To start AudBase

To launch AudBase, find and click on the program icon.

• For Macintosh users, the icon will display on your desktop.
• For Windows users, the icon appears on the Start menu. 

When starting AudBase for the first time, several events occur:

• The program may build some internal resources. This will only take a few seconds.
• AudBase asks for a user name and password.
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Initial passwords for a structure file
For security purposes, you can only use AudBase by entering a valid password. The 
administrator assigns passwords for users. All new AudBase structure files come with the 
following default password that the administrator can use for the first login: 

Table 1.1: Initial AudBase password for a new structure file

Note: Passwords are case sensitive. For example, type capital “O” when entering Otolith2.

If you are creating a new data file you will be requested to create a new administrator pass-
word for it to ensure that no the default password is not used. Once you are comfortable 
working with the program, it is recommended that you change any initial administrator 
password and assign passwords for individual users. For more information on assigning 
passwords, see “Assigning passwords” on page 156.

Working with data files
Anytime you work with a data file in AudBase, the program will remember the location of 
this file. As long as the data file remains in the same location with the same name, the data 
file automatically opens when you log in.

Login name Password
Administrator Otolith2

How passwords work
Passwords are specific to a data file. Whenever you open a data file for the first time, the 
passwords are synchronized with the structure file. Unless you know a valid password for 
the data file, you will not be able to log back into a structure file after synchronizing. All new 
versions of the AudBase structure file can be opened for the first time with the default 
“Administrator” login. But once you select an existing data file, the passwords in this data 
file will override the default passwords in the structure file.

If you can’t remember a password for a data file and can’t log in, see “Trouble with pass-
words” on page 191.

Note: Only the administrator can synchronize a data file and a structure file. 

Using the tutorial and example data file
The first time you open AudBase after installation you will be automatically prompted to 
locate the data file. You will need to browse to the location of the data file you wish to 
use. To help you learn about the features of AudBase, a sample data file called Example 
Data is provided for use with the tutorial. We recommend that new users load the exam-
ple data file and consult the tutorial. 

For more information, see the tutorial manual included with AudBase. 
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Creating new data files
In order to start using AudBase for your organization’s purpose, you must first create a 
new data file. 

Note: Only the person logged in as the administrator can create a new data file.

To create a new data file

1. Double-click the AudBase icon.
The Password dialog appears.

2. Enter the user name administrator.
3. Enter the administrator password for 

the data file you were last using or, 
if this is a new installation, the 
default administrator password.

4. While holding down the Alt key 
(Windows) or Option key (Mac), 
click Connect to open AudBase.

5. On the Open data file dialog, select 
New… to open the Create a data file 
dialog.

6. Browse to a location where you 
wish to save the new file. 

7. In the Name field, type in a unique 
name for the new data file. 

8. Click Save.
Create file dialogs: Windows (above), 
and Macintosh
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Opening existing data files
AudBase remembers the location of the last data file used if the file’s name and location 
remain the same. If you wish to connect AudBase to a different data file, follow the proce-
dure below. 

Note: If you have moved or renamed an existing data file, the Open data file dialog will 
open automatically after you log in.

To locate an existing data file

1. Open the program by double-
clicking the AudBase icon. 

2. On the Password dialog, enter your 
User Name.

3. Enter your Password.
4. While holding down the Alt key 

(Windows) or the Option key (Macintosh), click Connection.
5. On the Open data file dialog, browse to the existing data file. 
6. Select Open.

Open dialogs: Windows (left), and Macintosh



ONE: GETTING STARTED· 7

Audbase.book  Page 7  Thursday, May 4, 2006  10:04 PM
Assigning the Participant ID
When creating a new data file, you will be asked to enter a Participant ID. This number is 
an important part of AudBase’s internal identification system. You should choose a unique 
number for each new data file you create. The Participant ID number must be between 0 
and 999. For more information about internal ID numbers, see “What makes up an internal 
ID number” on page 176.

As the administrator, you are now ready to create new 
providers and Clinical Groups. You can start data entry 
at this point, but it is highly recommended that you set 
up providers and Clinical Groups first. For more infor-
mation, see “Entering Provider data” on page 18 or 
“Viewing Clinical Group records” on page 28.

How privileges and access are controlled
Due to the sensitive nature of subject information and the different levels of complexity in 
the database, AudBase is equipped with a number of features to help define user access. 
You can establish different user classes that define levels of access by creating user names 
and passwords. These different levels exist to limit access to data and modifiable parts of 
the database. Even if the program is only being used by a single user, it is highly recom-
mended that the person not just log in as administrator, but also create a separate login as a 
provider. This is important because: 

• A separate login provides a more secure environment.
• An administrator cannot customize a subject list while other user classes can.

In addition to user classes, AudBase also allows you to control access to very specific 
parts of the database such as tables or navigation tabs. 

User classes
Four classes of users exist in the database: providers, group administrators, subadministra-
tors and the administrator The administrator has access to every function of the database 
including modifying forms and lists, deleting records, and assigning privileges. There is 
only one administrator.

In order for any user to have privileges, he or she must first have a Provider record, which 
is created by the administrator. If you do not have a Provider record, AudBase will not 
allow you to log in.
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In order to access subject records, a user must meet one of the requirements below:

• Be a designated provider for the subject (see “Entering subject records” on page 41).
• Have privileges to view a Clinical Group’s subjects (see “Viewing Clinical Group 

records” on page 28).
• Have ‘”All Subject” privileges to view all subject information (see “Entering Pro-

vider data” on page 18).

Below is a more detailed list of specific privileges available to each user class.

Provider 
The most common user classification in AudBase is that of provider. Prior to using Aud-
Base, you must be assigned a login and password by the administrator.

Note: “User” will appear in the text to denote anyone who can log in to the database in 
a generic fashion, while “provider” often infers privileges to view subject records.

A provider can:

• Access subject records for whom they are designated subject providers. For more 
information, see “Entering subject records” on page 41.

• Add subjects and related records, such as tumor records and treatment records.
• Change his or her own password. For more information see “Change password” on 

page 26.

A provider cannot:

• Delete a record (see “Deleting records” on page 155).
• Assign any privileges to other users.

Depending on the privileges assigned by the administrator or subadministrator, a provider 
can also: 

• View subject records belonging to a specific Clinical Group that they have permis-
sion to view.

Note: Groups are typically institutions, such as hospitals or groupings 
of subjects that share a commonality, for example, a study of cis-plati-
num/5FU/radiation. 

• Modify a previously saved record (see “Unlocking forms” on page 40).
• Modify or delete Reminder records.



ONE: GETTING STARTED· 9

Audbase.book  Page 9  Thursday, May 4, 2006  10:04 PM
Group administrator
A group administrator has all of the privileges assigned to a provider. In addition, a group 
administrator can: 

• View the Clinical Group records that they administrate.
• View all the subjects belonging to a Clinical Group.
• Add or remove a provider’s privileges to view the subjects belonging to a Clinical 

Group. 

A group administrator cannot modify another group administrator’s privileges.

Subadministrator
A subadministrator has all of the privileges assigned to a group administrator. In addition, 
a subadministrator can: 

• Grant access to all subject records to another user.
• Modify a group administrator’s privileges.
• Act as a group administrator for any group.
• Add Provider or Clinical Group records.
• Modify and customize lists used for data entry.

A subadministrator cannot: 

• Change a user’s login name. 
• Assign a login password.

Depending on the privileges assigned by the administrator, a subadministrator can also: 

• Delete subjects and related records.
• Modify a previously saved record (see “Unlocking forms” on page 40).
• Allow other users to modify a previously saved record.

The administrator
The administrator has all of the privileges assigned to a subadministrator. In addition the 
administrator can also: 

• Change passwords for any user.
• Grant login privileges and change a user’s login name.
• Modify a subadministrator’s privileges.
• Delete any record.
• View all subjects.
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User access
AudBase allows you to exercise great control over access to records within the database. 
You may want to restrict some users from accessing certain tables or records, to help guard 
against data entry errors or ensure subject confidentiality. The administrator can determine 
which users are allowed to view records, change records that have been saved, or create 
new records. The level of access can be specified for individual tables within the database.

The program allows you to set a default global “Write” access (the privilege to change 
saved records) using the Preferences form. This level of access will apply to all users, 
unless you override it for specific users. You can also override the global access setting for 
a group of users. For more information on assigning user access, see “Audiology 
(Admin)” on page 112 and “Record Access” on page 123.

AudBase menu structure
As you begin using the program, you will notice that the menu bar at the top of your 
screen changes depending upon which form or dialog is active. The standard menu bar 
displays when you first log on, and also appears anytime the Home Window is on your 
screen. The menu bar changes when the Subject List is active on your screen (the Data 
Manager item no longer appears, along with other changes). The menu bar also changes 
depending on which forms are open. The various menu options are explained throughout 
this user manual. For a complete list of menu bars and their menu items, see “Appendix D: 
Menu Bar Index” on page 237.

Users with administrator privileges can switch to a special administrator menu bar by 
selecting the Data Manager > Administrator Menu Bar option with the Home Window on 
their screen (see “Using the Administrator Menu Bar” on page 140).

Home Window
The Home Window is the first window to open when you log on to AudBase. It displays a 
logo and includes buttons that open the Subject List and New Subject forms.Users with 
administrator privileges can customize the logo in the Home Window with their own pic-
ture or graphic. For directions, see “Changing the Home Windows logo” on page 122. 

The Home Window and the Subject List are the most common starting points for many of 
AudBase’s features. When the Home Window is open, the menu bar at the top of your 
screen is devoted to:

• Database management (for example, File > Preferences, File > Edit Documents)
• Data access (for example, File > Provider, File > Clinical Groups)
• The current subject list (for example, Subjects > Search)
• Aggregate data handling (for example, Reports > Export Data)
• Data management (for example, Data Manager > Human Subjects Info) 
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Subject List
The Subject List form displays subject names, identifiers and provider information, and 
features alphabetized navigation tabs to make a large subject list more manageable.

To reach the Subject List from the Home Window, by doing one of the following:

• Click the Subject List button
•Select Subjects > Subject List.

The list of subjects displayed on the form depends on certain criteria you have set (see 
“Setting Subject List criteria” on page 11). The bar at the top of the window displays the 
number of subjects in the current list. Letter tabs appear only if a subject name on the cur-
rent list starts with that letter. Clicking on the list headings (Subject Name, Primary Identi-
fier and Primary Provider) will sort the list appropriately.

The “User Set” box on the lower right of the Subject List form is useful for selecting a 
subgroup of subjects for batch operations, such as updating last visit dates or printing sub-
ject information. You can place subjects in the “User Set” by dragging-and-dropping their 
names from the list window or holding down the Shift key while clicking on the name. 
You can remove subjects name from the “User Set” by dragging the names to the Trash or 
holding down the Shift key while clicking on the name.

Double-clicking on a subject name will open the Subject Studies form for that subject (see 
“Using the Subject Studies form” on page 45 ). To return to the Home Window from the 
Subject List form, do one of the following:

• Click on the Home Window logo at the bottom of the Subject List form.
• Close the Subject List form with the close box.

Setting Subject List criteria
The Subject List Criteria option helps you manage the Subject List form by letting you 
select a smaller group of subjects to appear on the list. You will always be able to access 
your own subjects. Viewing other subjects depends on your Clinical Group access privi-
leges (see “Viewing Clinical Group records” on page 28).

Note: The administrator does not have access to this function. The administrator sees 
all subjects all the time.
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To change Subject List Criteria

1. Select Subjects > Subject List Criteria.
2. From List Criteria, select one of two options:

• “All allowed subjects” to include all subjects you have 
access to see. (For users with “All subject privileges,” 
the option will be labeled “All Subjects.”)

• “Selected subjects” to change criteria for the list of sub-
jects based on your access privileges for the Clinical 
Groups.

3. Click the Selection Criteria button to display your Clinical Groups.
4. From the Create List dialog, drag-and-drop Clinical Group names from the left to 

the right, or shift-click group names. Remove Clinical Groups by dragging them 
from the right to the Trash or by clicking the name while holding down the Shift 
key.

5. Click Update and the Subject List displays the names of subjects who meet your 
new criteria.

Note: These changes will apply only to this session. If you want to retain the changes as 
default settings, do so through the Preferences form. For more information see “Subject 
Info/Navigation” on page 136.

Updating the Subject List
When running AudBase in a multi-user environment, a number of users may be entering 
data at the same time. To make sure that all recently entered records are present for all 
users, you can force an update of the subject list.

Note: For more information on using AudBase in a multi-user environment, see “Aud-
Base Server” on page 160.

To update the Subject List

1. From the Subject List, hold down the 
Shift key while selecting Subjects > Sub-
ject List Criteria.

2. On the confirmation dialog, click Yes 
and any new data you entered will now 
appear in the subject list.
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Limit Subject List/Full Subject List
You can quickly limit the list of subjects displayed on the Subject List form to a few 
selected subjects. In a network environment where lists of data must be sent between the 
server and client machines, this level of control allows the user to make efficient use of 
network resources.

To limit the Subject List

1. From the Subject List form, select the subjects you want on the list by dragging-
and-dropping their names to the User Set box in the bottom right corner of the 
form.

2. Select Subjects > Limit Subject List.
The Subject List form displays only those subjects you have selected. The current 
number of subjects appears in the top bar of the form.

You can restore the full list of subjects currently available for display by selecting 
Subjects > Full Subject List.

Limited Field Search
You can perform a quick search of several frequently used fields in the Subject table to 
create a selection of subjects for the Subject List form.

To perform a limited field search

1. Select Subjects > Limited Field 
Search. (You can also select Limited 
Field Search on the bottom of the 
Subject List form.)

2. On the right side of the form, select 
one of two options:

• “Current List” to limit the search 
to the current subject list.

• “Entire Database” to search the 
maximum number of subjects you have access to.

3. Select any or all of the four field names on the left side of the form (First Name, 
Last Name, Primary Provider, Primary ID).
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4. Enter a text string you want to search for in the text box.
5. Click OK and the Subject List form displays all subject records meeting the crite-

ria you have chosen.

Note: You can use the “@” character as a wildcard in any AudBase 
search. You can also search for embedded text (a portion of the text 
within a word) either by selecting the “Check for embedded text” option 
and entering the character string, or by placing the wildcard character 
at both ends of the string you are searching for.

Windows Menu
Depending on available memory, two different subject-related forms (for example, the 
Subject Studies form or any clinical study forms) can be open at the same time in addition 
to the main form, such as the Home Window or Subject List. Since multiple windows on a 
screen can obscure each other, the Windows menu can help you find any open forms.

The Windows menu will display the name of the current form and the name(s) of any sub-
jects associated with open subject forms. The form with the check mark is the one in front. 
Selecting another subject’s name will bring that form to the front.

Internal Mail
AudBase allows multiple users to access the same database file, either one-by-one or in a 
client-server environment. The internal mail feature lets you communicate with other 
users working on the same data file. For example, a data manager could use internal mail 
to communicate with clinicians about incomplete records. 

You can compose and send mail to other AudBase users, either internally or through their 
e-mail address.

To compose mail

1. Select File > Internal Mail.
2. Click Compose Mail and the New Mail dialog displays.
3. To choose the recipient of your message, click Addresses.
4. Select the desired recipient’s name from the Full List of 

Addresses and add it to the Address Mail To: box by 
dragging the name or clicking on a name while holding 
down the Shift key. You can also address mail to more 
than one address by repeating this step.
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5. Click Update.
6. From New Mail, type a message in the note field.
7. At this point, you can send the mail to other AudBase users either internally or 

externally by way of e-mail.
• To send mail internally, click Send Internal.
• To send mail externally, click Send E-mail.

If an Internet e-mail address is not available for an AudBase user in your address list, the 
message will be delivered by internal mail instead.

To check internal mail

To check for new internal mail, do one of the following:

• Start AudBase and log in. If someone has sent you mail, the “You have mail” dialog 
appears.

• Select File > Internal Mail and the Internal Mail dialog displays.

The internal mail messages display by the sender’s name and by the date sent. To open a 
message, double-click on sender’s name and the message opens.
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Providers and Clinical Groups
Providers and Clinical Groups are important in AudBase. A Clinical Group is the central 
organizing concept in setting up and running multi-site clinical studies using the program. 
Assigning each subject to one or more providers and Clinical Groups helps structure 
information entered into the database, and makes it easier to retrieve the same information 
through searches. The concepts of provider and Clinical Group also help define levels of 
access to data and the security measures used to protect confidential subject data. 

The terms can be confusing. In order to gain access to AudBase, a user must be assigned a 
provider record in the database. But not all users of the program will be subject providers 
in the classic sense of the word. So in terms of the database itself, “provider” and “user” 
are equivalent terms.

A Clinical Group can be an institution, such as a hospital, or it can simply be a study. For 
example, a Clinical Group in AudBase could be a grouping of subjects who share some-
thing in common that researchers wish to study, such as use of cis-platinum/5FUY/radia-
tion to treat tumors or involvement in a p53 gene therapy trial.

This chapter group of topics will take you through the features of the two main data entry 
forms used to create records in AudBase for providers and Clinical Groups, the Provider 
Information form and Clinical Group Information form. For more information about run-
ning a clinical trial, see the see the AudBase Clinical Trials manual.

Entering Provider data
The Provider Information form is used to enter a record for all AudBase users, whether 
they are actual subject providers or not.

Regular providers can use the form to update their personal information, change their 
password and enter an e-mail address and server information needed to use AudBase’s e-
mail functions. They can view their own provider record by selecting File > Provider Info 
from the Home Window or Subject List menu bar.

The administrator and subadministrators can use the form to update demographic and e-
mail information for other providers. The administrator uses this form to assign subadmin-
istrator status to certain users, and to change login names and passwords.

For administrators or subadministrators to open provider records:

• With the Home Window or Subject List form active, click File > Provider Info.
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The Provider List form appears. It displays all providers and has alphabet tabs for faster 
navigation. The form has buttons to add, modify or delete providers. Subadministrators 
will find their own provider record at the top of the list for easy identification. The admin-
istrator does not have a provider record.

Provider menu items for the administrator
When the Provider List is open, the menu bar includes three 
items for administrators only: Administrator Checklist, 
Administrator E-mail, and Administrator Password. This 
section briefly describes each.

Assigning an Administrator Checklist
The Administrator Checklist menu allows the administrator 
to assign him or herself a data entry Checklist. Normally, Checklists are assigned to a sin-
gle user through their Provider record, but the administrator does not have a Provider 
record.

To assign a Checklist to the administrator

1. With the Provider List on your screen, click Provider > Administrator Checklist to 
see all the Checklists assigned to Clinical Groups.

2. Choose the group whose Checklist you would like to assign from the list on the 
left, and drag it to the list on the right. If a Checklist was previously in the list on 
the right it will be replaced.

3. Click Update.

Note: When running AudBase in a multi-user environment, other users may change the 
Saved Searches that comprise a Checklist. You can ensure that you are using the most 
up-to-date Checklist definition by holding down the Shift key when selecting the Pro-
vider > Administrator Checklist menu item. In a similar way, you can “refresh” Check-
list definitions by holding down the Shift key while selecting Provider Checklist on the 
Provider Information form. For more information about using AudBase in a multi-user 
environment, see Chapter 8, “AudBase Server,” on page 160.
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Setting up administrator e-mail
An administrator can enter his or her e-mail address and server information using the 
Administrator menu item under Provider. AudBase uses the current user’s e-mail address 
for “Internal Mail” messages that can be sent either via an e-mail system accessed by 
SMTP protocols or handled completely within the database (see “Internal Mail” on 
page 14). You may also specify the default subject line of AudBase e-mail messages here. 
All e-mails sent by users of the database are identified with this subject line.

Note: When a user other than the administrator sends a message via SMTP e-mail, the 
e-mail information on his or her provider form is used.

The e-mail system in AudBase allows users to do the following, both within the database 
and externally via SMTP:

• Send messages.
• Send exported data in the form of attachments.
• Receive exported data in the form of attachments.

Users cannot receive or view external e-
mail messages within the database since 
it is assumed that the user has an e-mail 
program or Web browser that they use 
on a regular basis. 

To send e-mail as well as send and 
receive exported data, the administrator 
must enter his or her outgoing mail 
server and incoming mail server 
addresses here.

 For more information about data 
exchange via e-mail see “Study Export” on page 34 and “Study Import” on page 36.

Changing administrator password
This item on the Clinical Group menu bar allows the administrator to change his or her 
password. To make the change:

• With the Provider List form open, select Provider > Administrator Password.

This will open a Request dialog for updating the administrator’s password.
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Using the Provider form
The administrator or a subadministrator 
can open an existing provider record by 
double-clicking on a provider name in the 
Provider List, or by clicking a name and 
selecting Modify. This opens a Provider 
Information form. Clicking New opens a 
New Provider form.
Both provider forms have two tabs, 
Demographics/Prefs and Login/E-mail. A 
new provider record requires a first name 
and a last name. The administrator may 
have specified other checklist items (see 
“Creating Checklists” on page 131). 
Enter data by using standard text entry 
and pop-up menus.

The rest of this chapter will explain the features of the provider forms, beginning with the 
Demographics/Prefs tab.

Note: To change an existing Provider record, you must unlock the form by 
clicking on the black closed lock. For more information, see “Unlocking 
forms” on page 40. 

Demographics/Prefs
The first tab of the Provider Information form is for entering basic demographic informa-
tion as well as information about Clinical Groups and access privileges.

Creating Personal Provider and Personal Clinical Group 
Lists
In multiple user systems, the entire list of providers or Clini-
cal Groups can be quite large. When modifying subject pro-
viders or subject Clinical Groups on the Add Subject 
Records form, you select from a list (see “Entering subject 
records” on page 41). If you create a personal list, then it is 
presented in preference to the entire list, which is always available. This feature is 
optional and provided for your convenience. With the Provider Information form open, 
clicking the Personal Provider List or Personal Group list opens a Create List form. You 
can add names to the personal list by dragging them to the Personal List or shift-clicking 
on the names. Remove names by dragging them to the Trash on the Create List form, or by 
shift-clicking.
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Full Group Access Privileges list
This informational list on the Provider Information form 
displays the Clinical Groups to which this provider has 
subject record access. This list can be modified by a 
group administrator, a subadministrator or the adminis-
trator through the Clinical Group form (see “Setting pro-
vider access to Clinical Group subjects” on page 30).

All Subject” Privileges button
This button on the Provider Information form is only accessible to a subadministrator or 
the administrator. This gives a provider the privilege to view the record of every subject in 
the database. The button’s text displays the status of this privilege. If granted this privi-
lege, a provider can choose to use it through the Subject List Criteria form (see “Setting 
Subject List criteria” on page 11).

Anonymous function
For the purposes of security and privacy, the Anonymous function may be used. This fea-
ture allows administrators to restrict Provider access to the personal information in the 
database. For instance, once this feature is activated, that user is denied identifying subject 
information such as name, telephone number, and address.

To turn on the Anonymous function

1. Select File > Provider Info from the Home Window.
2. Select the Provider whose database access 

you wish to modify.
3. Click Modify. A form with the Provider 

Information appears.
4. Unlock the record by clicking on the black 

closed lock on the form. 
5. Click on the Anonymous Subjects button. "Yes" turns the 

Anonymous function on.
6. Click on OK.

The Anonymous function can also be activated from Preferences (See 
“Anonymous function” on page 22.).
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Setting table record privileges
This feature on the Provider Information form allows 
the administrator to set detailed access privileges for an 
individual provider, deciding whether he or she can 
view, change or create new records for each table in the 
database. It also allows individual providers to view their privileges, but not change them.

Clicking Table Record Privileges on the form opens a dialog that lists all tables to which 
the provider has access, based on the defaults set by the administrator. You modify these 
privileges using the Table Access Privileges dialog. To the left of the list of tables are 
three columns, displaying either a “Y” (meaning “Yes, you do have this privilege”) or a 
blank space (no privilege). The three columns are:

• View record: Allows the provider to see a record from this table.
• Write record: Allows the provider to change a record from this table.
• New record: Allows the provider to create a new record in this table.

This dialog also allows you to set export and printing privileges for the tables a user has 
access to view.

To change table record privileges

1. Open the Provider Information form for the individual you wish to set privileges 
for.

2. Unlock the record by clicking on the black closed lock on the form.
3. Click Table Record Privileges.
4. Select the table you wish to set privileges for 

from the column on the right, and then click 
in the respective columns on the left (“Y” 
for yes, blank space for no).
Holding down the Shift key while you click 
allows you to change an entire column.

5. Select from the pop-up list if you wish to 
define the provider’s level of write access 
for the allowed tables (in other words, to 
override the default global settings for all 
users of the database as defined on the Preferences form). The choices are:

• Default Access (the level of write access set for all users on the Preferences 
form).

• Limited Time Access (how many days after a record is 
saved the provider can change it).

• Full Access (no restrictions on changing records).
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6. Set export and printing privileges for tables the user has privileges to view using 
the checkboxes at the top of the dialog.

7. Click Update.
8. Click OK to save the provider record.

Note: If you remove privileges to view a record for a given table, the privilege to write 
records to that table automatically disappears. You can restore viewing privileges, but 
will have to manually reset write privileges for the same table. By the same token, if you 
grant write privileges for a table, viewing privileges are automatically added.

The administrator can set table record privileges for more than one provider at a time 
using the Preferences form. For information, see “Setting Subject Studies access privi-
leges” on page 126. The administrator or a subadministrator can also prepare a report on 
all user access privileges. See “Creating a User Privileges Report” on page 151.

Modifying Subject Studies Access
You can modify the appearance of the Subject Studies form (see “Using the Subject Stud-
ies form” on page 45) and access to its different parts in three different ways:

• In some cases, providers can decide which of the form’s navigational tabs they wish 
to view (hide tabs that they never use, for example).

• The administrator or subadministrators can decide which of the tabs a provider must 
view (cannot remove from the form).

• The administrator or subadministrators can hide or show any of the tabs for any 
user.

The administrator makes these changes for individual providers using the Provider Infor-
mation form, or makes changes for a group of providers using the Preferences form (see 
“Setting Subject Studies access privileges” on page 126). An individual provider can 
modify the appearance of his or her Subject List, also using the Preferences form (see 
“Subject Info/Navigation” on page 136).

To set privileges for the Subject Studies form (administrator or subadminis-
trators)

1. Open an individual Provider record from the Provider List (File > Provider Info). 
Unlock the record.

2. Click Subject Studies Access to display the tabs on the Subject Studies form.In 
the Tab Modifiable by User column, click “Y” (“Yes”) to remove this Provider’s 
ability to hide the tab on the Subject Studies form.
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3. In the Tab Accessible to User column, click 
“Y” (“Yes”) to remove this Provider’s abil-
ity to see the tab on the Subject Studies 
form.

4. Click Update, and then click OK on the Pro-
vider form to save the changes.

Note: If the administrator removes a Provider’s 
access to a tab on the Subject Studies form, it will 
affect his or her ability to search the database. This 
is because you have limited the provider’s access to 
the tables in the database that are connected to the 
respective tab. However, hiding the tab from view does not affect a Provider’s ability to 
search within the tables.

Assigning a Provider Checklist
AudBase allows the administrator to define a Clinical Group’s checklist as the default 
“master checklist” for the database (see “Master Checklist for data entry” on page 134). 
This is especially useful in clinical studies to ensure that any record being saved by a par-
ticipant meets the study criteria. The Provider Checklist feature allows the administrator 
to override the master checklist for individual providers.

To assign a Provider Checklist

1. Open and unlock the Provider Information form.
2. Click Provider Checklist and a 

form includes a full list of Clini-
cal Groups on the left, with 
alphabet tabs for quicker navi-
gation, and a box on the right 
that shows the current checklist 
selected for this provider.

3. From the list of Clinical Groups 
on the left, choose the group 
whose checklist you wish to 
assign to this provider, and drag 
or use shift-click to move it to 
the User Checklist Clinical 
Group box on the right. If a 
checklist is already assigned, a new checklist will replace the old one. 

4. Click Update and then click OK to save the provider record.

Note that each provider can only be assigned a single checklist. Clicking “Allow checklist 
override” enables the provider to save a record even if it does not meet all checklist crite-
ria.
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Format On button
The administrator can set up your version of AudBase to automatically cap-
italize some letters in the name, address, city, and country text fields. This 
occurs when you enter information and then tab or click out of the field. To 
override this feature, click the Format On button at the bottom left of the form. It turns to 
a No Format button. You can turn the auto-format back on when you move to a different 
text entry field. You can also set a default format as a Preference item (see “Format On/No 
Format” on page 108).

State List button
The form has a built-in function that helps you pick out the standard two-letter abbrevia-
tion for a U.S. state, or other administrative subdivision. This feature can be enabled by 
default from the Preferences form. You can override the State List function by clicking 
cancel when the list of state names appears, or by clicking the State List button, which 
turns to ‘No State.’ For more about using the Preferences form to enable the State List 
function, as well as modifying any listing of states, provinces or other administrative sub-
divisions, see “State List” on page 108 and “Creating a non-USA State List” on page 117). 

Entering Provider login and e-mail information
The second tab of the provider form allows you to enter, view or update information about 
provider login, subadministrator status and e-mail.

Login Name
An individual provider is not able to change the Login Name entry field on his or her 
form. Only the administrator can change the login name or enter it for the first time. The 
login name does not have to have any relationship to the provider’s actual name. 

Change password
You can change your password for logging into AudBase by clicking this button and typ-
ing a new password into the request form that appears. The administrator can change any 
provider’s password as well.

Sub Admin button
This reflects the provider’s current subadministrator status by displaying “Yes” or “No.” 
The button is disabled for all users except the administrator.
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Provider E-mail address
Enter provider e-mail preferences here. The provider’s e-mail address is used for “Internal 
Mail” messages, which can be sent either via an e-mail system accessed by SMTP proto-
cols or handled completely within the database (see “Internal Mail” on page 14 and “Set-
ting up administrator e-mail” on page 20).

E-mail Server(s)
In order to send e-mail as well as send 
and receive exported data, you need to 
enter the outgoing mail server and 
incoming mail server addresses. There is 
currently no provision for receiving and 
viewing personal e-mail within the data-
base since it is assumed that the provider receiving the e-mail has an e-mail program such 
as Outlook Express or Eudora, or a Web browser that they use for this type of mail. In 
AudBase, you can import and export data for the purposes of sharing among individuals 
or institutions using e-mail attachments For more information about data exchange via e-
mail, see “Study Export” on page 34 and “Study Import” on page 36.

Adding and removing a group of subjects
AudBase also allows the administrator and subadministrators to add a group of subjects to 
a Provider record, or remove a group, using a menu item attached to the Provider record. 
This can also be done individually (see “Assigning Providers and Clinical Groups” on 
page 43).

To add a group of subjects to a provider

1. From the Provider List, double-click on a 
provider’s name to open the Provider Infor-
mation form.

2. Select Provider > Add Subjects to Provider 
to open a Search for Subjects form.

3. Search for the set of subjects you wish to add 
and drag it to the Drop Selected Subject Set 
to assign all subjects in the set to the pro-
vider.
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To remove a group of subjects from a provider

1. From the Provider List, double-click on a provider’s name.
The Provider Information form opens.

2. Select Provider > Remove Subjects from Provider.
A Search for Subjects form opens.

3. Search for the set of subjects you wish to remove and drag it to the Drop Selected 
Subject Set box on the form.
All subjects in the set are removed from the provider.

Note: For more information on how to search for a set of subjects, see Chapter 4, 
“Searching,” on page 70.

Viewing Clinical Group records
The Clinical Group Information form allows administrators, subadministrators and group 
administrators to view and update Clinical Group records. The form is also an important 
hub used to set up and carry out many of the key functions needed to operate a multi-site 
clinical study, including: 

• Creating and tracking Study Participant IDs for multi-site trials.
• Assigning a Clinical Group Checklist, Sequential Search and Grouped Export.
• Generating public and private encryption keys needed to import and export 

encrypted data.

This section will describe the features of the Clinical Group Information form. For a com-
plete overview of the steps needed to set up a multi-site clinical trial, see the AudBase 
clinical trials manual.

To view Clinical Group records

1. Select File > Clinical Group Info.
For administrators or subadminis-
trators, the Clinical Group List 
form appears, with a list of all Clin-
ical Groups and buttons to add, 
modify or delete groups. Group 
administrators will be presented 
with the list of Clinical Groups 
they administrate, and providers 
will see groups of which they are 
members.

2. Open the Clinical Group Information form by double-clicking on a group name in 
the list, or selecting the name and clicking Modify. Clicking New opens a New 
Clinical Group form.
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A new Clinical Group record requires a full name and a List Name. The List Name needs 
to be unique.

The List Name appears in the Subject List and is also used to automate encryption and e-
mail exporting/importing features. The administrator may have specified other checklist 
items (see “Creating Checklists” on page 131).

Several items on the Clinical Group Information form deserve special mention:

Setting Clinical Group identifier format
This field on the Clinical Group form allows you to create a default format for a Clinical 
Group’s identifiers. This format is applied to entries made on a subject form.

You can specify a default format by using one of the three special characters:

• The “$” represents any numerical value
• The “@” represents any letter
• The “?” represents a letter or a number
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Other characters or spaces are considered constants and do not need to be entered by the 
data entry personnel. For example, UWMC uses the following format for chart numbers:

U 1-23-45-67

Here is how the default format appears for UWMC:

U $-$$-$$-$$ 

In this format, the space, the hyphens and the letter “U” are all constants. The data entry 
person need only enter the variable number portion of the identifier (for example 
1234567) and the number will be automatically formatted.

Setting provider access to Clinical Group subjects
Clicking Changes opens a Create List dialog box. 
You can add or remove names by dragging-and-
dropping or shift-clicking. If a provider is 
included in this list, he or she will have access to 
all subjects who belong to this Clinical Group. 
Remove names by dragging them to the trash on the form, or shift-clicking.

Note: A group administrator can remove any provider except for another group admin-
istrator. 

Designating group administrators
On the Clinical Group form, you can designate the provider as a group administrator by 
clicking the open space to the left of a provider name (“GA’” appears). Only a subadmin-
istrator or the administrator can confer this privilege.

Assigning a Clinical Group Checklist, 
Search and Export
You can assign a Clinical Group Checklist, a Clinical Group 
Search and a Clinical Group Export using these buttons. This 
is normally done by the study coordinator when first creating a 
Clinical Group record for the study. Study participants can 
assign all three items automatically (see “Importing study tools” on page 32).
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To assign a Clinical Group Checklist

1. Create a Checklist for the group (see “Creating Checklists” on page 131).
2. On the Clinical Group 

Information form, click 
Clinical Group Checklist.

3. In the left-hand list of the 
Clinical Group checklist, 
click on the Checklist you 
wish to assign to the Clini-
cal Group.
You can view the searches 
used to define the Check-
list in the right-hand list by 
using the arrows or plus 
signs to open tables that contain the searches.

Note: To review the contents of an individual search, double-click on 
the name of the search, in this example “Female.” The search will 
open. You cannot edit the search here, just review it. 

4. Click Update Checklist Selection and the text on the Clinical Group Checklist 
button will change to italics to signal that a Checklist has been assigned.

A Clinical Group’s checklist can be used as the Master Checklist for the database (see 
“Master Checklist for data entry” on page 134).

You can assign Sequential Searches and Grouped Exports to Clinical Groups using the 
same procedure, starting with the Clinical Group Search and Clinical Group Export but-
tons on the form. These are used for selecting complete or partial datasets for export to a 
coordinating institution in a multi-center clinical study.

For further information, see “Selecting data for export” on page 88, “Creating Grouped 
Exports” on page 121 and “To delete a Saved Special Relation Search, double-click on the 
sublist item to open the Saved Search form, then click Delete.” on page 130).

Assigning a Group Type
You can assign a Group Type to your Clinical Group using a modifiable pop-up list (see 
“Modifying lists” on page 109). Clinical Groups may be created without a specific Group 
Type, by choosing N.D. (no data) from the list. However, dividing your Clinical Groups 
into specific types will allow you to create more detailed searches (see “Searching” on 
page 70).
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Clinical Group is a study checkbox
Selecting this checkbox on the Clinical Group form will allow the substitution of Study 
Participant IDs in exported data and the automation of the encryption process. In addition, 
selecting this checkbox would make it easier to search for all subjects in clinical studies. 
For more information, see the AudBase Clinical Trials manual.

Exporting study tools
The study coordinator can export the Clinical Group Checklist, Search and Export using a 
single menu item. AudBase creates a special TRANSFER-type document with a file 
extension of OT3, which bundles all three items into one file and encrypts them using the 
coordinator’s private key if data encryption has been set up for the trial. Participants who 
have received the public key from the coordinator and entered it on the third tab of the 
Clinical Group form may then import the Checklist, Search and Export definitions into 
their version of the database using the Import Study Tools item. The imported definitions 
will be automatically attached to the Clinical Group record. For more information, see the 
AudBase Clinical Trials manual.

To export the bundled Clinical Group Checklist, Search 
and Export

1. Make sure you have created all three items; the buttons 
on your Clinical Group record for this study should all 
be italicized. Also make sure you have saved the Clini-
cal Group record.

2. On the Clinical Group menu bar, click Clinical Group > Export Study Tools.
A Save As dialog appears, allowing you to browse to a location on your computer 
to save the OT3 file.

3. Choose a name for the file, and click Save.
The file is now ready for sharing with trial participants.

Importing study tools
Participants who have received the public key from the coordinator and entered it in the 
Clinical Group form can import encrypted Checklist, Search and Export definitions into 
their version of AudBase using a single menu item. (An unencrypted study tools file does 
not require a public key to be imported.) You should have received the OT3 file from the 
study coordinator, and placed it in a location that you can browse to during the process of 
importing the file.

To import the bundled Clinical Group Checklist, Search and Export

1. While logged on as administrator, open the Clinical Group record for this study 
and make sure it is unlocked.

2. On the Clinical Group menu bar, click Clinical Group > Import Study Tools.
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3. From the Open dialog, browse to the location of the OT3 file sent by the study 
coordinator and click Open to import and decrypt the group Checklist, Search and 
Export definitions.

4. Note: If you are sharing the OT3 file between platforms (for example, Windows 
to Mac), the normal Open dialog may not show the file. In this case, hold down 
the shift key while selecting the Import Study Tools menu item to force the dia-
log to show this file.You can verify the study tools have been imported by making 
sure the text on all three of the buttons under Checklist/Grouped Export on the 
form has turned to italics.

Assigning subject records to a Clinical 
Group
You can assign a group of subjects to a Clinical Group 
record using a special menu item. This is among the 
final steps in setting up a clinical trial using AudBase. 
You can also add subjects individually. For more infor-
mation, see “Assigning Providers and Clinical Groups” 
on page 43.

To add subjects to a Clinical Group

1. Open the Clinical Group record for the study by double-clicking on the name in 
the Clinical Group List.

2. From the menu bar, select Clinical Group > Add Subjects to Group to open a 
Search for Subjects form.

3. Search for the set of subjects you wish to add and drag it to the Drop Selected 
Subject Set box on the form (see Chapter 4, “Searching,” on page 70).
All subjects in the set will be assigned to the Clinical Group.

To remove a group of subjects from a Clinical Group

1. With the Clinical Group form open, select Clinical Group > Remove Subjects 
from Group to open a Search for Subjects form.

2. Search for the set of subjects you wish to remove and drag it to the Drop Selected 
Subject Set box on the form.
All subjects in the set are removed from this Clinical Group.



34 ·  AUDBASE

Audbase.book  Page 34  Thursday, May 4, 2006  10:04 PM
Study Export
The second and third tabs of the Clinical Group form include information necessary to 
export and import encrypted data in a multi-site study. The administrator and subadminis-
trators can view, copy and change all of the fields on these tabs. Group administrators can-
not access any of this information.

Study Participant ID
Each participating site should be assigned its own ID (range 0 - 999) for the purposes of 
the study (see “Assigning the Participant ID” on page 7). If the Study Participant ID field 
on the Clinical Group form is left blank, exported records will have internal ID values 
based on the Participant ID for the exporting data file. For more information, see the Aud-
Base Clinical Trials manual.

Setting up encryption
The process of encryption/decryption of data begins on the Clinical Group form. Follow 
these steps to generate a public/private key pair.

To generate public/private key pairs

1. On the second tab of the Clinical Group form (Study Export), make sure you have 
entered a Study Participant ID to enable the Generate Keys button.

2. Click Generate Keys to create a public/private 1024-bit encryption key pair.

3. Do one of the following:
• Click Save Public Key to Disk to generate a text file that you can use to share 

the public key with whoever will be importing your data.
• Highlight the public key, copy it, and then paste it into an e-mail message or 

other word processing program for sharing.
4. Click OK to save the keys in the Clinical Group form.

If you try to modify previously created keys you will be warned before saving the record 
since an inadvertent change will destroy the utility of the paired keys.
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Setting up decryption
The third tab of the Clinical Group form allows you to set up decryption of shared data. 
On this tab:

• The study coordinator can enter the names and Study Participant IDs of all those 
involved in the study, as well as enter or modify participants’ public keys to allow 
decryption of their data.

• Participants can enter the coordinator’s public key to enable them to decrypt study 
tools or other data sent from the central collection site.

Study participants should generate their own key pair and send the public (decryption) key 
to the study coordinator. The coordinator can then import the participant’s public key 
using the following procedure.

To add Study Participant IDs and public decryption keys

1. On the third tab of the 
Clinical Group form, 
click Add Participant 
to begin the process of 
entering the partici-
pant’s name, ID num-
ber and public key.

2. Enter the ID and click 
OK.

3. Click Modify Partici-
pant Info.

4. Enter a name in the dialog and click OK.
5. Click Modify Public Key and confirm that you want to modify the public key for 

this participant.
6. Click OK.
7. Copy the public key that this participant has sent 

to you, paste it into the Public Key dialog, and 
click OK
The Key Status column at right will show the 
italicized word “Yes” to indicate that you have 
stored the participants’s key.

Clicking Save Public Key to Disk allows you to create a text file with the selected partici-
pant’s public key. The file can then be distributed on disk or opened in a word processing 
program for copying and pasting. You can also remove a participant from the list by click-
ing Delete Participant ID.
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Generate Key button
Selecting this button will generate a public/private 1024-bit key pair for encryption pur-
poses. The keys are in a special “text” format that can be copied and pasted in a document 
or e-mail. Any modifications of previously created keys will result in a warning to the user 
before saving the record since an inadvertent change will destroy the utility of the paired 
keys.

Save public key to disk
Selecting this button will create a file with the public key in it. The file can then be distrib-
uted on disk or opened in a word processing program for copying and pasting. 

Setting up e-mail export

E-mail address
The e-mail address of a central data collection site should be entered here. If you choose to 
export data via e-mail it will be sent to this address.

Maximum attachment size
Some e-mail systems limit the size of e-mail enclosures (attached documents). The default 
value is 128 Kb. If an export document exceeds the specified size the document will be 
split into multiple enclosures and reassembled when it is imported.

Single attachments only checkbox
Some e-mail systems limit the number of e-mail enclosures (attached documents) per e-
mail. Selecting this option causes export document(s) to be sent out as a series of separate 
e-mails. This is rarely needed and increases the time needed for the export. Do not choose 
this option unless you are certain you need to.

Study Import
The third tab of the Clinical Group form allows study coordinators to add or modify Study 
Participant IDs and modify and save the public key used to import encrypted study data. 
For more information on the use of these features, see the AudBase Clinical Trials man-
ual.

Add Participant ID
Each participating site should be assigned its own Study Participant ID (range 0 - 999) for 
the study (see “Assigning the Participant ID” on page 7
). To record the information for a participating site, start by entering an ID number Modify 
Participant Info

You can enter the participant info for the selected ID number after clicking on this button.
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Modify Public Key
Study participants should generate their own key pair and send the public (decryption) key 
to the study coordinator (see “Generate Key button” on page 36). The study coordinator 
can then import the participant’s public key by selecting an ID number, clicking on the 
Modify Public Key button and pasting the key into the displayed dialog box. If a key is 
stored for this participant it is signified by a Yes.

Delete Participant ID
Clicking this button will delete the selected participant’s ID.

Save Public Key To Disk
Selecting this button will create a file with the selected participant’s public key in it. The 
file can then be distributed on disk or opened in a word processing program for copying 
and pasting.
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Data Entry
AudBase is designed to streamline the task of entering data about subjects, providers, 
Clinical Groups, treatments and other information important in research studies. The data 
entry forms are easy to access and designed to minimize typing. The frequent use of pop-
up lists also helps make sure that the data you enter will be consistent, making it easier to 
retrieve in later searches. 

This chapter will show you how to use the various data entry forms, starting with how to 
unlock a form.

Unlocking forms
When you call up a previously saved data-entry form, it starts out “locked” in Read Only 
mode. This allows more than one person to access a record at the same time, and also 
prevents changes to the record. Even in a single-user environment, it is important to load 
records by default in Read Only mode because the typical record should not be changed 
after it has been saved. This is crucial for data integrity in any long-term clinical study.

To make changes to a form and its underlying database records, you must unlock the form 
(switching to Read Write mode). The “locked” or “unlocked” status of a form is displayed 
in the Lock/Unlock icon. The icon, located at the top of the form, has three modes:

• Black, closed lock: The form is locked, but can be unlocked by clicking the icon.
• Black, open lock: The form is unlocked.
• Red, closed lock: The form is locked, and you cannot unlock it.If you try to unlock 

a form and another person has already unlocked the form, you’ll see an alert dialog 
but will be able to continue to look at the form in locked mode..I

The administrator can always “unlock” a record and can grant other users this privilege 
(see “Audiology (Admin)” on page 112).
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Entering subject records
To add new subjects to AudBase, use the Add Subject Records form. The form features 
automated formatting and pop-up lists to simplify data entry, and allows you to add a sub-
ject with a limited amount of initial data. After entering information about demographics, 
click on the Notes/Referrals tab to add additional details.

To open the Add Subject Records 
form, do one of the following:

• From the Home Window, 
click on the New Subject 
button.

• From the Subject List form, 
click on the New Subject 
button.

• From the menu, select Sub-
jects > New Subject.

The Add Subject Records form dis-
plays, ready for data entry. 

Filling out all fields in the subject 
record, as in the figure above, may 
be more than someone seeing a subject for the first time is interested in doing. The mini-
mum information needed for a new subject is the first and last name. All other information 
can be deferred, depending on the checklist assigned by the administrator (see “Special 
note on Checklists” on page 42). If another subject in the database shares the first and last 
name, a list of potential duplicate records appears.

The Add Subject Records form uses standard text entry boxes and pop-up menus to allow 
you to enter demographic information about subjects. 

Several other items deserve special mention:

Format On button
An administrator can set up your version of AudBase to automatically 
capitalize some letters in the name, address, city, and country text fields. 
This occurs when you enter information on the subject or provider forms 
and then tab or click out of the field. To override this feature, click the 
Format On button at the bottom left of the form. It turns to a No Format button. You can 
turn the auto-format back on when you move to a different text entry field. You can also 
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set the default button selection using the Preferences form (see “Entry Formats” on 
page 108).

State List button
The Add Subject 
Records and Provider 
information forms have 
a built-in function that 
helps you pick out the 
standard two-letter 
abbreviation for a U.S. 
state. If the database is 
outside the United 
States, you can use 
local area abbrevia-
tions instead (see“Cre-
ating a non-USA State List” on page 117). When you type a single letter, such as M, then 
tab out of the field, a list of states (or other regions) will appear. Select the correct state and 
the abbreviation appears. You can override the State List function by clicking cancel when 
the list of state names appears, or by clicking the State List button, which turns to “No 
State.” You can set the default button selection using the Preferences form(see “Entry For-
mats” on page 108)

Special note on Checklists
In AudBase, “Checklists” are designed to 

make sure users enter the correct data into 
forms. This is especially important in clinical 
studies.

If you try to save a new or updated record 
that does not have the minimum amount of 
data as defined by the administrator or subad-
ministrator, a window appears displaying the 
checklist errors.

In this example, you must enter the sub-
ject’s middle initial on the Add Subject 
Records form. If you try to save without enter-
ing this information, a checklist appears reminding you to enter missing items.

You can look at the criteria for a form before saving by selecting the appropriate menu item (for 
example, Subject > Data Checklist from the Subject form, or Tumor > Data Checklist from the 
Tumor form).

The administrator has the option to enforce a Checklist when the record is saved (Recheck is 
the only option) or allow a user to save the record anyway (Accept is also an option). 
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Entering Selected Identifier
This field on the Add Subject Records form is open for entry if a Clinical Group name is 
highlighted. A subject can have a different identifier or study ID for each Clinical Group. 
The field can be auto-formatted for each Clinical Group (see “Setting Clinical Group iden-
tifier format” on page 29). You can override or turn off the formatting at any time using 
the Format On button.

Entering Universal ID
The Entering Universal ID field on the Add Subject Records form should be reserved for a 
unique ID that can identify duplicate subjects entered by multiple sites in a multi-center 
trial. Note that using a Social Security number for this ID in the United States can be sub-
ject to legal limitations. This field can be automatically formatted by the administrator 
(see “Setting Universal ID format” on page 118).

Assigning Providers and Clinical Groups
The bottom of the Add Subject Records form has two boxes where you can assign the sub-
ject to Providers and Clinical Groups. To make data entry easier, you can assign default 
Provider(s) and Clinical Group(s) to a new record automatically so they appear whenever 
you add a subject to the database. 

For more information, see “Subject Info/Navigation” on page 136 . 

To assign Providers or Clinical Groups

1. Click on Changes above either the Pro-
viders or Institutions/Studies boxes.
A Create List form appears. The subject 
can belong to multiple Providers or Clin-
ical Groups.

2. Add or remove Providers and Clinical 
Groups by dragging items from the left 
to the right boxes, or shift-clicking. To 
delete names from the list, drag them to 
the Trash, shift-click on them or press 
Clear All.



44 · AUDBASE

Audbase.book  Page 44  Thursday, May 4, 2006  10:04 PM
3. Click Update.
The Providers or Institutions/Studies lists on the Subject form will reflect your 
changes.

Note: If no Providers or Clinical Groups are specified you will be given 
a chance to add them before saving the subject record. Unless you have 
privileges to access all subjects, you will not be able to see a subject 
record without assigning Providers and Clinical Groups(see “How priv-
ileges and access are controlled” on page 7).

Designating primary Providers and Clinical Groups
You can designate a primary Provider or Clinical Group on the subject form. Both will 
appear on the Subject List form.

• To designate a primary Provider or Clinical 
Group, click in the open space to the left of 
the name: a number “1” will be attached.

• To remove the primary status of a Provider or 
Clinical Group without designating a replace-
ment, click on the number “1” while holding 
down the Shift key.

You can assign a new record automatically to a default primary Provider and Clinical 
Group (see “Subject Info/Navigation” on page 136).

Note: Before you can save a new record, you will be asked if you wish to designate a pri-
mary Provider or Clinical Group if more than one are listed. If a new subject record has 
only one Provider or Clinical Group listed, they will be designated by default upon sav-
ing the record. 

Referring caregivers
If you wish to assign a referring caregiver to a subject, use the Notes/Referrals tab. You 
can also use this list to generate letters or other documents for the referring caregiver.

To add a referring caregiver

1. You can access the Notes/Referrals tab from two places:
• If you are adding a new subject, find the tab on the Add New Subject form.
• If the subject exists, find the tab on the Subject Info form.

2. Click the Referring Provider List button.
A Create List form opens.

3. Drag names from the Full List of Providers box on the left to the Referring Pro-
viders list on the right, or shift-click on the names.

4. Click Update.
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Referring caregivers should have a provider record filled out with their name and address. 
The ability to customize your own personal list of providers for forms such as the list-cre-
ation form helps you more easily select commonly needed caregivers (see “Creating Per-
sonal Provider and Personal Clinical Group Lists” on page 21).

Saving records
Once you are finished entering data about a new subject, you can save the record and pre-
pare to add another subject by clicking Save. The information you entered is saved to the 
database, but the form stays open, ready for new data entry. When you are done with your 
last subject, click Finished. If you have not saved your last record, you will be prompted to 
do so. You can also save a subject record and immediately open the Subject Studies form 
for that subject by selecting Save/Goto Studies.

Using the Subject Studies form
The Subject Studies form is a central “hub” you can use to navigate to all subject studies 
on such things as tumors, treatment methods, social habits, plus others. Double-clicking 
on a subject’s name in the Subject List form will open the Subject Studies form.

The form is divided into multiple tabs. 
If the navigation tab has more selec-
tions than will fit at one time on the 
form, use the arrow tabs to uncover all 
the selections.

One tab selection, Demographics, 
open the appropriate forms directly. 
The other tab selections deal with mul-
tiple related-records that appear in 
lists.

Clicking on the Audiogram tab dis-
plays a list of all audiogram records for 
that subject. 

When the audiogram list is blank, or if 
you select a audiogram name on the 
list, the New Audiogram button is 
enabled. Double-clicking on the audio-
gram will open the audiogram record.

Audiogram forms actually display data from three tables: [Audiogram], [Tympanogram 
and [SAT_SRT_WordRecognition]. Selecting the Tympanogram or SAT\SRT\WR naviga-
tion tab will display the list of available records in those tables which can then be opened 
directly..



46 · AUDBASE

Audbase.book  Page 46  Thursday, May 4, 2006  10:04 PM
Viewing existing subject records
Clicking on the Demographics tab in 
the Subject Studies form will open 
the Subject Info form. This form is 
essentially the saved version of the 
Add Subject Records form.

The Subject Info form consists of 
two tabs, Demographics and UID/
Notes/Referrals. It looks almost 
identical to the Add Subject Records 
form. There are only two visible dif-
ferences:

• The Subject Info form has OK 
and Cancel buttons instead of 
the Add Subject Records 
form’s Save and Finished but-
tons.

• The Subject Info form does not have the Save\Goto Studies button.

If you have privileges for a subject’s record you can change or add information to a subject 
by first unlocking the record. 

Working with reminders
Using AudBase’s reminder feature can help you keep track of timely information regard-
ing a subject. A reminder quickly lets you view due dates for subjects by saving these 
items in the database for easy access. For example, you may wish to schedule a reminder 
that shows the date of a subject’s next appointment.

Adding reminders
You can set reminders for a group of subjects or for an individual subject. 

To add a reminder for a number of subjects

1. Open the Subject List.
2. Select the subjects you wish to add 

reminders for by dragging each name 
to the User Set box. You can also add 
names to the User Set by single-
clicking while holding down the 
Shift key. 
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3. Select Subjects > Add Reminder.
A dialog displays telling you that a reminder will be added for each subject you 
selected.

4. Click OK
The New Reminder form displays.

5. Enter a date when the reminder is due.
6. Select the type of reminder.
7. Enter any details or instructions in the Note field. 
8. Click OK. 

Note: After you save a reminder for the first time, you cannot change the reminder type. 
In order to modify or delete a reminder, a user must be given permission by the adminis-
trator (see “Setting user reminder privileges” on page 115). To change the items in the 
Type pop-up list, see “Modifying lists” on page 109).

To add a reminder for an individual subject

1. From the Subject List, double-click 
on the name of a subject.
The Subject Studies form opens.

2. Select Subject > Add Reminder.
The New Reminder form displays.

3. Enter a date when the reminder is 
due. 

4. Enter the type of reminder.
5. Enter any details or instructions in the 

Note field. 
6. Click OK.
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Reviewing reminders
At times, you may want to review reminders for all the subjects in the database or a single 
subject.

To review reminders for all subjects

1. From the Home Window or Subject 
List, select Subjects > Review Remind-
ers. 
The Select Reminders dialog appears.

2. Select how you wish to review the 
reminders, Display for on screen, or 
Print.

3. Specify a start date and an end date to 
search in. 

4. From the first pop-up list, choose a List to Use.
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Audiogram and Tympanogram
The Audiogram feature is designed for rapid and consistent data entry both manually and 
using a serial port to upload audiometer readings. You can enter a complete set of clinical 
data and present it in a variety of ways, as well as customize the data entry form to your 
preferences. The Audiogram feature performs calculations such as Pure Tone Average 
(PTA) and AMA Handicap values; it also allows you to compare a subject’s results with 
known groups (for example, HTLA confidence limits).

This section will describe how to fill out a new audiogram record based on the standard 
pure tone test, enter findings from other test procedures, and view or print the results in 
different ways.

To create a new audiogram

1. Open the Subject Studies form by double-clicking on a name in the Subject List.
2. Click on the Audiogram tab.
3. Click New Audiogram.

The Audiogram form appears.

The form follows the graphing format of a standard audiogram. It features several naviga-
tional tabs for entering pure tone averages, acoustic reflexes, SRT/SAT and word recogni-
tion testing data, tympanograms, and notes. 



FOUR: AUDIOGRAM· 51

Audbase.book  Page 51  Thursday, May 4, 2006  10:04 PM
Entering basic test information
When you open an Audiogram form, it displays the Pure Tone Average 
(PTA) navigational tab. This is where you record information such as 
date, examiner, device, testing methods, testing location, and reliabil-
ity—it is also where the PTA results are auto-calculated.

All of the fields in the lower right use pop-up lists to speed data entry. 
You can set default entries for these fields, and they will automatically 
appear each time you open a new audiogram (see “Audiology (1)” on 
page 110. ). Additionally, you can modify the pop-up lists to suit your 
needs (see “Modifying lists” on page 109.). The Examiner field and the Test Method fields 
can have multiple entries.  Note also that the Transducer pop-up and field has two ver-
sions: regular frequency range and special (e.g. high frequency) range.

Filling in audiogram fields manually
Manually recording pure tone testing results is a simple process of clicking on the appro-
priate icon in the palette of standard clinical symbols and then using the icons to fill in the 
graph. 

The following procedure will explain the basic steps for filling out the audiogram manu-
ally. Variations such as entering masking values and recording comments will be 
described afterward. (For instructions on how to upload audiogram data directly from a 
serial port see “Working with an audiometer or tympanometer” on page 64..) 

 To record audiometric data

1. From the palette on the right side of the Audiogram form, 
click on the icon that corresponds to the ear being tested 
and the type of test.

2. Move the cursor over the graph, and click on the hearing 
level for the first test frequency.
An icon appears on the graph. 

3. Continue filling out the graph for each frequency based 
on the testing of that ear.
Note that AudBase automatically connects the icons with 

The Audiogram form involves a significant amount of data. To protect your-
self from data loss (for instance, as the result of a computer crash), you can 
turn on an auto-save feature. When this feature is turned on, the Audiogram 
form is automatically saved every thirty seconds. (For instructions on activat-
ing this feature see “Audiology (3)” on page 111..

Auto-save Feature
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lines. You can show or hide the lines depending on your preferences. (See “Dis-
play options” on page 56..)

4. Click on the icon for the second test ear, and repeat the process of filling out the 
graph.

The palette uses special symbols for Sound Field and Comfort Level testing. All unaided 
soundfield types are available in the pop-up on the left.  You can select the type of aid used 
in the Sound Field from the pop-up list to the right of the palette. The icon changes to 
reflect the nature of the aid, for instance AR stands for Aided, right and CB stands for 
Cochlear Implant, bilateral. All combinations of Aided, Hybrid and Cochlear Implant are 
available in the pop-up on the right.  Clicking the No Response box under the palette and 
selecting the appropriate icon records a value using the conventional No Response sym-
bols.  Comments can also be attached to an icon (see below).

You can reposition pure tone icons vertically by 
clicking on a different hearing level. You can delete 
an icon by clicking on it again (as long as that icon 
is highlighted in the palette).

Note on repositioning misplaced icons
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Bone conduction tests
The default icons for unmasked bone conduction tests 
allow you to specify both right and left side mastoid 
testing. You can select specified mastoid testing, 
unspecified mastoid testing, or forehead testing from 
the pop-up list to the right of the palette. The icon 
changes to reflect the nature of the test. 

Note: If you specify right and left values and later decide to use an unspecified value for 
a given frequency, the original right and left values are automatically erased to protect 
against invalid data. 

Masking values
Once you have filled in a masked value on the audiogram, you can record effective mask-
ing values for the non-test ear using the table below the graph on the PTA tab. The table is 
divided into columns that roughly line up with the frequency lines on the graph, and has 
rows for air and bone conduction testing.

To enter masking values

1. On the PTA tab of the Audiogram form, fill in the graph 
with the appropriate icons.

2. In the masking values table below, find the field that cor-
responds to the masked test result on the graph. The cur-
sor changes to an I-bar when it passes over a box that 
corresponds with a valid frequency, test type, and ear.

3. Enter a value in the field.
If you enter an invalid number and then leave the cell, an 
alert appears reminding you that values must be within 
the valid range.

Note: Masking value details are automatically converted to a 
detailed text format which is displayed on the Notes tab of the form. The display field 
allows you to copy and paste information into your Notes field so you can use it later as 
search terms in the database (see “Searching” on page 70.). 

An example entry is shown below, indicating a Pure Tone Masking Value of 30 dB for 
the right ear at 500 Hertz:

[Pure Tone Masking Values]: PureTone_AMR_00500 30 dB; or

[Pure Tone Masking Values]: PureTone_AMR_SpF03 30 dB;

“AMR” stands for air masked, right; another example would be “BUL” for bone 
unmasked, left. The ability to choose different frequency ranges (e.g. for a high fre-
quency audiogram) is reflected in the complete field name: 500 Hertz  or Special Fre-
quency number three (SpF03).
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Entering comments
To attach a comment to an icon on the graph, click the Com-
ment box under the palette before placing an icon. The pop-
up list next to the box gives you three options. Selecting 
“Comment” attaches a “C” to the icon, indicating you have 
included a comment on the Notes tab of the form. Two fre-
quent comments are “Pressure” and “Vibrotactile.” These 
comments are included directly in the pop-up lists and, if 
selected, the appropriate letter will be attached to the icon. 

Tab Entry Form
AudBase allows you to select a tab entry form instead of the graphics form.  You can 
choose the form you want to use for new audiograms in Preferences (see “Audiology (1)” 
on page 110. ).    

When entering values directly into the tab entry form two modifications can be performed.  
To convert a threshold to a No Response value tab out of the field and then shift-click on 
the field.  The displayed threshold will change to a red color signifying a No Response 
threshold.  Bone transducer type can be specified for a bone field by selecting from the 
Bone Transducer pop-up when the entry cursor is in the appropriate field.  If an unspeci-
fied bone type is chosen, the entered value will be placed in the complementary field for 
the opposite ear as well.
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Two preference items can be specified by the user for the tab entry form (see “Audiology 
(2)” on page 111. ).  Round pure tone entries to the nearest 5 dB will round all entry values 
appropriately.  This option should be turned off for entering smaller dB increments.  This 
setting does not affect values downloaded from an audiometer.  Display NR values as 
‘NR’ text will display NR values appropriately on locked forms and printed tabular forms.

Pure Tone Average
AudBase automatically calculates pure tone averages (PTAs) for monaural and sound field 
testing, displaying them at the bottom of the PTA tab. The default averages are based on 
three frequencies: 500, 1000, and 2000 Hertz. AudBase allows you to request calculations 
for two-frequency averages. This can be valuable, for example, if you wish to record a 
PTA for a subject whose test includes No Response values. To use a two-frequency calcu-
lation, click in the dBHL box next to the appropriate ear and test type, and choose your 
frequencies from the pop-up list. If you choose to record both masked and unmasked val-
ues, the program preferentially uses the masked values in calculating a PTA.

Setting Frequency Range
The default Audiogram form covers the standard frequency range from 125 Hz to 12000 
Hz. If your audiometer is capable of testing special frequencies (8000 Hz to 20000 Hz for 
example), you can select the frequencies for entering your special frequency audiogram by 
clicking Frequency Range. The entry form will change appropriately.

The special frequency data values are stored in the pure tone air conduction fields.  
Because the special frequency values differ between audiometers, the data fields used to 
store the special frequency data are identified generically (for example, 
PureTone_AUR_SpF01 is the first special frequency field in the audiogram). The corre-
sponding key to the frequency values is automatically specified when you select the Fre-
quency Range button and stored in the SpecFrequencyAudiogram_FieldHz field.
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Display options
You have broad control over the display of each audiogram, both on-screen and in print. 
For example, you can choose to show all or part of the test results, vary icon style, and 
include an HTLA confidence level for comparisons or the Speech Banana.

The following is a quick summary of the various options in the Drawing menu that 
appears on your screen with an audiogram. You can also set default display options using 
the Preferences form (see “Audiology (1)” on page 110.).

•· Line Drawing: Show or hide lines connecting air, bone, or sound field test values 
by clicking the appropriate menu item. Clicking the “Include No Response” or 
“Include P/V comments” will connect the corresponding icons, which normally 
interrupt the line.

•· Masking Status: Show or hide masked or unmasked values. Clicking “Masked Pre-
ferred” suppresses unmasked values when a masked value is available.

•· Side, Type, Soundfield Subtypes and Modifiers: Show or hide the various items 
depending on your selection. Display of soundfield subtypes can be controlled indi-
vidually under the Soundfield Subtypes submenu or they can be controlled as a 
group under the Type submenu (SndFld, unaided and SndFld, aided). 

•· Icon Style: Allows you to choose thin or thick icons, for on-screen appearance and 
for printing.

•· HTLA background: Gives you 10 options for display of HTLA confidence limits 
as a background to your subject entries on the graph. This option only works if you 
have entered a gender and age for the subject in the Subject Info form.

•· Speech Banana: Show or hide the Speech Banana on the audiograms.

Note: Drawing options are saved with the audiogram. If you want to print or display an 
audiogram record with options different from the saved ones, you can change the set-
tings temporarily while the record remains locked. The changes will not be saved unless 
the record is unlocked and then resaved.
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SRT/SAT tests
Speech reception and awareness thresholds can be entered on the SRT/SAT tab of the 
Audiogram form. You can either enter data directly in 1-dBHL increments or use a pop-up 
list to enter data in 5-dBHL increments depending on how you set your preferences (see 
“Audiology (1)” on page 110.). Each column within the threshold tables contains a field 
for dBHL values and a field for masking values. 

The entry control pop-up on the left side of the form allows you to select entry fields for 
“SRT, no babble”, “SRT, babble” and “SAT”.  To enter dBHL values, click in the appropri-
ate box and enter the dBHL value. If you enter an invalid number in the dBHL field and 
then leave the cell, an alert appears reminding you that values must be within the valid 
range. Enter CNT for “could not test”. If the condition was not done, leave the dBHL field 
blank.

To enter masking values, click in the small white box to the left of the dBHL value field 
and fill in the dialog that appears. An asterisk (*) appears in the box to indicate the pres-
ence of a masked value. Note that detailed information on the masking values is automati-
cally displayed on the Notes tab of the form, in a text field that allows you to copy and 
paste information into the Notes field. The Notes field allows you to record and store text 
that you can use later as search terms in the database (see “Searching” on page 70.).

You can enter stimulus information by clicking on the Spondee Stimulus button on the 
bottom of the form. The Select Spondee Stimuli form appears.
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Click on the tested stimuli in the box on the left, drag it into the box on the right, and drop 
it in the appropriate test condition. If you drop it on a parent item such as “SRT” the tested 
stimuli is added to all the dependent tests. If you drop the stimuli into the wrong condition, 
drag the stimuli to the trash icon or to the appropriate condition. LV stands for “live” and 
REC stands for “recorded.” (To modify the stimulus list, see “Modifying lists” on 
page 109..) Click on OK.

Note: You can specify default settings for the Select Spondee Stimuli form (see “Audiol-
ogy (2)” on page 111. ). You can override default settings by clicking on any default 
stimulus conditions that appear in the box on the right and dragging them to the trash 
icon.

The Spondee Stimuli button appears in italics to indicate that there are stimuli entered. If 
you specify default settings for the Select Spondee Stimuli form, the button will appear in 
italics whenever you open a new Audiogram.

Word Recognition tests
The Word Rec tab of the Audio-
gram form records and graphs 
Word Recognition testing data as 
you enter it. Percent correct values 
can be typed into the fields for 
monaural, binaural (aided and 
unaided), and sound field tests 
(aided and unaided). You can 
switch between binaural under 
phones (Bi), soundfield binaural 
aided (S), and soundfield unaided (S) tests by clicking on the pop-up list in the center col-
umn of the table.  The entry control pop-up on the left side of the form allows you to select 
entry fields for “No babble” and “Babble”.  
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If you enter an invalid number in 
either the percent correct field or 
the dBHL field and then leave the 
cell, an alert appears reminding 
you that values must be within 
the valid range. Enter CNT for 
“could not test”. If the condition 
was not done, leave the dBHL 
field blank.  A percent correct 
calculator can be opened by shift-
clicking on a percentage field 
which the cursor is not currently 
in.  The calculated value will be 
entered into the field when the 
calculator is closed.  

As you enter each value, AudBase adds points to the graph on the right side of the form, 
allowing the clinician to quickly discern such things as rollover phenomenon. You can 
control which graph appears by clicking on the header above each value field. For 
instance, the small graph shown above is the monaural, right graph. These graphs can be 
printed later (See “Printing audiograms” on page 66.). 

To enter masking values, click in the small white box to the left of the percentage field and 
fill in the dialog that appears. An asterisk (*) appears in the box to indicate the presence of 
a masked value. Note that masking values details are automatically displayed on the Notes 
tab of the form in a text field that allows you to copy and paste information into the Notes 
field. The Notes field allows you to record and store text that you can use later as search 
terms in the database (see “Searching” on page 70.).

You can enter test type information by clicking on Word Rec Type above the table. The 
Select Word Rec Types form appears.
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Click on the Word Recognition Type in the box on the left, drag it into the box on the right, 
and drop it in the appropriate test condition. If you drop it on a parent item such as “SRT” 
the tested stimuli is added to all the dependent tests. If you drop the stimuli into the wrong 
condition, drag the stimuli to the trash icon or to the appropriate condition. LV stands for 
“live” and REC stands for “recorded.” (To modify the Word Recognition Type list, see 
“Modifying lists” on page 109..) Click on OK.

Note: You can specify default settings for the Select Word Rec Types form (see “Audiol-
ogy (2)” on page 111. ). You can override default settings by clicking on any default 
Word Recognition Type conditions that appear in the box on the right and dragging 
them to the trash icon.

The Word Rec Type button appears in italics to indicate that there is an associated record. 
If you specify default settings for the Word Rec Types form, the button will appear in ital-
ics whenever you open a new Audiogram.

If a related SAT\SRT\Word Recognition record has been previously created, you can con-
nect that tympanogram to your audiogram record.

To select a related SAT\SRT\Word Recognition record

1. Click on the Select 
Related 
SAT\SRT\Word Rec-
ognition button to 
choose between 
available records.
The list of tympano-
grams associated 
with the subject 
appears as a Related 
record.

2. Select the tympano-
gram related to this 
audiogram and click on OK. If there are no tympanograms listed, or the subject's 
most recent one is missing, you need to update the appropriate records for this 
subject. (See “Tympanogram” on page 61.).

The tympanogram information appears. AudBase automatically enters the Tympanogram 
Date.

Note: An audiogram record may only be related to a single SAT\SRT\Word Recognition 
record. However, a SAT\SRT\Word Recognition record may be related (using the 
SAT\SRT\WR tab on the Subject Studies form) to multiple audiogram records.
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Tympanogram
The Tymps tab lets you display and modify tympanograms. Tympanogram waveforms can 
be downloaded directly into the computer using a serial port device (see “Working with an 
audiometer or tympanometer” on page 64.). You can also type in key tympanogram values 
into the Tympanometry table. However, in this case, there are not enough data points to 
generate a graph.

Note: If you use the serial port to download graph data and the graph type is not cur-
rently being displayed you will receive a warning indicating that the computer has 
received the data but does not have a way to display it.

Use the pop-up lists below each graph to select the desired tympanometry test and select 
which ear to view (Right, Left, or Both). The tympanometry test displayed by default for 
new records can be specified as a user preference (see “Audiology (2)” on page 111. ).  If 
both ears are displayed on a single graph, the left ear is shown in blue and the right ear is 
shown in red. Additionally, if needed, the axis will automatically re-scale to fit both ears 
on the same graph.AudBase stores the data for all of the tympanometry tests entered on 
this form in a single record.

If a tympanometer is connected for download, the Tympanometry table will be automati-
cally completed by AudBase once the graph is displayed. You may override the values in 
the table. However, overriding the values in the table will permanently change the data set. 
In other words, you will lose some of the original downloaded data as it is replaced by 
your manual values.

Note: Clicking on Erase Displayed Tymp will erase the graph and the downloaded data 
that created that graph. Users who have privileges to unlock and modify saved records 
can use the Erase Displayed Tymp function after a record has been saved.
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If a related tympanogram record has been previously created, you can connect that tympa-
nogram to your audiogram record.

To select a related tympanogram

1. Click on the Select Related Tympanogram but-
ton to choose between available records.
The list of tympanograms associated with the 
subject appears as a Related record.

2. Select the tympanogram related to this audio-
gram and click on OK. If there are no tympano-
grams listed, or the subject's most recent one is 
missing, you need to update the appropriate records for this subject. (See “Tympa-
nogram” on page 61.).

The tympanogram information appears. AudBase automatically enters the Tympanogram 
Date.

Note: An audiogram record may only be related to a single tympanogram record. How-
ever, a tympanogram record may be related (using the Tympanogram tab on the Subject 
Studies form) to multiple audiogram records.

Reflex/Reflex Decay tests
The Reflexes tab of the Audiogram form lets you add further values to the graph based on 
acoustic reflex testing. Rather than using the palette to place icons, you enter values in the 
Acoustic Reflexes table below the graph, which then appear on the graph. The pure tone 
testing results remain on the graph to allow quick comparison.

The table allows you to enter dB values for 500, 1000, 2000 and 4000 Hertz tones as well 
as noise for AD and AS ear stimulus both contralateral and ipsilateral ear measurement. 
All entry is by pop-up list, and you can specify No Response values. 

To record reflex test results

1. Locate the Acoustic Reflexes table 
on the bottom of the Reflexes tab 
of the Audiogram form.

2. Select the dB value from the pop-
up list that corresponds to the 
appropriate measurement value 
field.
When appropriate, icons appear on 
the graph corresponding to the 
value you have entered. Selectable values inclue CNT “Could Not Test” and UdB 
“Unspecified”.  The UdB value is available to maintain compatibility with tympa-
nometers which screen for reflexes, but do not specify the dB level.
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3. Indicate No Response values by first entering the highest test value 
in the dB field and then clicking in the Absent field to its right. 
The “@” symbol appears in the field, and a downward arrow is 
attached to the icon on the graph.

4. Enter reflex decay results by selecting from the pop-up lists in the corresponding 
table. You can also select C(ontralateral) and I(psilateral) stimuli.

Notes
The Notes field on the Notes tab allows you to 
record and store text that you can use later as search 
terms in the database (see “Searching” on page 70.) 
and for printing on the appropriate forms. You can 
either type directly in the field or enter comments 
from the pop-up Standard Comment List. The pop-
up list includes standard comments and special text 
items designated by brackets.  The standard com-
ments can be up to 255 characters long and the list of 
standard comments can be modified (see “Modify-
ing lists” on page 109.). Special text items include 
the spondee stimulus and word recognition test information as well as a extended com-
ments which can be up to 32,000 characters in length.  Extended comments can be used to 
create a history and physical template with blanks to be filled in.  Extended comments are 
modified in preferences (see “Audiology (Admin)” on page 112.).

The Masking Info and Bone Transducer Info fields contain text that has been automati-
cally entered by AudBase. These fields are not recorded in a database field. However, you 
can copy and paste any information from them into the Notes field so that it can be used as 
a search term.
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Other Note page items
 For audiology practices with multiple facilities (locations) and/or multiple audiology 
booths (sublocations) these can be selected from the appropriate pop-up lists and printed 
on the forms (see Customizing Print Form Footers in “Audiology (Admin)” on page 112.).  
The individual lists can be modified (see “Modifying lists” on page 109.).

The Other Information list is a modifiable list which allows individual items to have dif-
ferent pop-up list values associated with them (see “Modifying lists” on page 109.). An 
item in the list can be dragged-and-dropped onto the Notes field where it will be added 
along with its associated pop-up value for printing purposes.

AMA Handicap
AMA Handicap can be calculated using the Special > Calculations > AMA Handicap 
menu item. The result will be placed in the Notes field on the Audiogram Notes tab, which 
is saved in the Notes data field.

Working with an audiometer or tympanometer
Users with a special cable can connect an audiometer to a serial port on their computer and 
download test values directly into AudBase. Three menu items pertain to this function:

• File > Serial Comm Protocol: Opens a Serial Port Settings form where you can set 
port, protocol, baud rate, and other parameters. You can also set up default values 
for these settings (see “Audiology (3)” on page 111.).

• Audiogram > Open Serial Port/Close Serial Port: This menu item opens and 
closes the serial port for connection to the audiometer or other instruments.  You can 
also set up the serial port to automatically open (see “Audiology (3)” on page 111.).

• Audiogram > Display Serial Port Info: This menu item opens a floating window-
which displays the serial port data stream.  This information can be useful for trou-
bleshooting serial port connections.
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• Special > Serial Port Device: This item allows you to choose the type of serial 
device you will be using.  You can also set up default values for these settings (see 
“Audiology (3)” on page 111.).

• Special > Audiometer Options: This menu item controls how the data being down-
loaded can be reinterpreted on the fly.  (1) When Sub(stitute) selected soundfield 
types or Sub(stitute) bone types are selected generic soundfield or bone field values 
being downloaded from the audiometer are converted to the types selected in the 
icon palate. Please note that all soundfield values being downloaded at the same 
time will be interpreted the same way.  Some audiometers can download ‘long’ 
records which include all the soundfield values collected during an audiogram.  If 
Soundfield Left and Right values are sent together they will all be interpreted the 
same way and the order they are sent in will affect the values which are saved (see 
the next menu item)  (2) Multi-input: clear all pure tones erases all previously 
entered pure tone values before interpreting a ‘long’ data record. In contrast to 
‘short’ records which typically download single pure tone values from an audiome-
ter, ‘long’ data records sent by some audiometers include all the pure tone values 
stored by the audiometer.  If this menu item is NOT selected any N.D. values sent by 
the audiometer will not overwrite previously saved values.  An example of how to 
use this feature would be when collecting all combinations of a subject with a hear-
ing aid and a cochlear implant with each turned on or off (AR, CL, ARCL).  Each 
test condition could be run for all the frequencies then downloaded using the ‘long’ 
record form and choosing the Sub(stitute) selected soundfield types menu item.  
Each would be added in turn to the accumulating audiometric data.  (3) If Sound-
field SAT\SRT\WR Entry is selected generic speech values being downloaded from 
the audiometer are converted to the type currently being displayed on the form.  (4) 
Fill next open WR position feeds speech values into the next open word recognition 
position.

Resetting audiograms
You can erase all or part of the values entered on the 
Audiogram form using the Audiogram > Reset Audio-
gram menu item. A dialog appears giving you four 
choices:

• Reset all entries
• Reset audiogram/PTAs
•  Reset reflexes
• Reset SRTs/Word Recs

Users who have privileges to unlock and modify saved records can use the Reset Audio-
gram function after a record has been saved.
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Deleting audiograms
The administrator, or a subadministrator who has been given the privilege, can delete 
audiogram records using the Audiogram > Delete Audiogram menu item. Other users can 
only delete an audiogram by clicking Cancel before saving the record.

Change Hearing Level Standard
The administrator can set the default value for new audiogram records using the Prefer-
ences form (see “Audiology (Admin)” on page 112.).  If the audiogram is unlocked the 
hearing level standard can be modified for this audiogram by selecting the Audiogram > 
Change Hearing Level Standard menu item. Other users can only delete an audiogram by 
clicking Cancel before saving the record.

Display Comparison Audiogram
If other audiograms exist for this subject they can be displayed in a floating window by 
using the Audiogram > Display Comparison Audiogram menu item.

Display Word Lists
Word Listscan be displayed in a floating window by using the Audiogram > Display Word 
List menu item. Word lists can be added by using the Preferences form (see “Audiology 
(Admin)” on page 112.).

Printing audiograms
You have several options for printing 
audiogram results. The printing forms are 
available by using the File > Audiology 
Print Forms menu item. The Audiology 
Print Style form appears.

Choose the desired print form from the list 
in the left box, and drag it to the right box. 
You may print multiple forms at the same 
time by dragging the desired forms, in 
order, into the box on the right. Once you 
have selected the desired print forms, click 
Update. To print the selected forms, go to 
File > Print Audiogram.

Note: You can set default preferences for the print forms. (see“Audiology (3)” on 
page 111.). You can print the default forms by using the File > Print Audiogram menu 
item. To override the default settings temporarily, go to File > Audiology Print Forms. 
Add additional forms by dragging them from the left box into the right box. Delete 
unwanted forms by dragging them into the trash. Click Update, then go to File > Print 
Audiogram. 
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AudBase also generates printouts of multiple audio-
gram records for a subject, which allows for side-by-
side comparison. To generate these printouts, from 
the Subject Studies form click Print Multiform. Prior 
to the standard print dialog appearing you will be 
able to select the audiograms you want in the com-
parison. If a Related Tympanogram has been 
selected, the tympanogram record will also be 
printed as appropriate.

Click on the Select Multiforms button to 
choose forms. An Audiology Print Style 
form appears.

Choose the desired print form from the list 
in the left box, and drag it to the right box. 
In addition to the special multi-audiogram 
forms you can select single audiogram 
forms which will be printed for each 
selected audiogram.  You may print multi-
ple forms at the same time by dragging the 
desired forms, in order, into the box on the 
right. Once you have selected the desired 
print forms, click Update. To print the 
selected forms, click the Print Multiforms button.

Note: You can set default preferences for the print forms. (see e“Audiology (3)” on 
page 111.). You can print the default forms by clicking on the Print Multiform button on 
the Subject Studies form. To override the default settings temporarily, click Select Multi-
forms on the Subject Studies form. Add additional forms by dragging them from the left 
box into the right box. Delete unwanted forms by dragging them into the trash. Click 
Update, then click on Print Multiform. 
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Searching
Some of the most commonly used features in AudBase begin with a search. Whether you 
are creating a report, exporting data, building a graph or printing a letter, you begin by 
searching for such things as subjects, providers or clinical data, and then putting the 
results together in different ways.

This chapter will show you some of the essentials of searching, using simple examples to 
help you visualize typical AudBase search methods. After you learn a few basic searching 
concepts, you’ll soon be using this powerful tool to simplify some of your most frequent 
tasks.  At the end of this chapter, we will look at two more complicated types of searches: 
Sequential and Special Relation. .

Searching in AudBase
A relational database such as AudBase is essentially a collection of tables, divided into 
records (rows) and fields (columns). Each field has a unique name and stores a particular 
type of data such as text or numbers.

Tables are related by shared fields. For example, the Subject table has fields for the subject 
ID number, first and last name and other demographic information. The Audiogram table 
has fields for examiner, audiogram date, etc. It also has a field for the subject ID number. 
The two tables share, and are related by, the subject ID number field.

The power of a relational database becomes clear when you search for relationships 
between very different pieces of information (for example, the relationship between hear-
ing loss and age or gender).

You search the database by defining “sets” of records that meet specific search criteria. 
For example you might search for only those subjects with audiograms which have air 
conduction thresholds > 40 dB. Or you might look for all audiograms with aided right ears 
in Caucasian males with Type C tympanograms.

AudBase functions that use 
search

Search for Subjects
Export Data
Graph Data
Report Data
Print Any Document
Print Referral Document
Assign Read/Write Access
Assign Subject Studies Access
Add Subjects to Provider
Add Subjects to Clinical Group
Assign Anonymous Status
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After you create a set, AudBase lets you easily combine sets in different ways to construct 
a complex search query that would be hard to build otherwise. You can also save com-
monly used searches, and build sequential searches that perform even a large number of 
individual searches all with one mouse click.

The three main steps in searching are opening the Search form, creating a new set with the 
New Query form, and then combining sets to achieve the most effective results. We’ll 
look at each of these steps in turn. At the end of this chapter, we will look at two more 
complicated types of searches: Sequential and Special Relation.

Opening the Search form
The search form is the starting point for building new searches, and also lets you quickly 
narrow your search results and combine the results of different searches with simple drag-
and-drop methods.

To open the Search form

• With the Home Window 
or the Subject List form 
open, click Subjects > 
Search.

Each box on the Search form 
represents a different table in 
AudBase. All display the high-
lighted Create New Set as the 
first item in their set list. To 
understand the examples you 
need to know the following 
about the tables we will be 
using. 

• Subjects can have multi-
ple audiograms (Audio-
gram table) and multiple 
tympanograms (Tympan-
ogram table)

• Tympanograms can be performed independent of audiograms, but an audiogram can 
be related to a specific tympanogram.

The subject list automatically includes the current set of subjects displayed in the Subject 
List form. All set names end with the number of records in the set. The new sets you cre-
ate will also appear in these table windows, and you’ll be able to drag them to other tables 
to find sets of records that are common to both tables. We will explain this more fully later 
in the chapter.
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Using the New Query form
The most common way to create new searches in AudBase is to use the New Query form. 
This form lets you easily build searches by choosing fields from related tables.

To open the New Query form

• From any table list, double-click on an existing set name or on the Create New Set 
item. 

The upper-right of the new query form shows the Master Table, the table you have decided 
to search. In this example we chose to double-click on a [Audiogram] item. The box at the 
top of the form is empty; this is where you will build your search.

A box on the left displays the data fields for the table to be searched. The fields are listed 
in the same order they are found in the table (see “Appendix B: Tables and Fields” on 
page 196). The icons to the left of each field name represent different data types, for 
example integer or text. Before you can build a search query, it will help to know more 
about the data fields list.
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A pop-up list above the field list controls the 
display of the data fields. To begin with, it 
reads “Master Table,” and shows the fields in 
their native order (the order in which they 
appear in the database). You can choose from 
two other options by clicking on the pop-up 
list:

• “Master table, sorted” displays the data 
fields for the master table in alphabeti-
cal order. 

• “Related tables” once again displays the mas-
ter table data fields in their native order, with 
the addition of nested sublists denoting rela-
tionships with related tables.

When you expand an attached sublist by clicking 
the plus sign or the arrow, a list of fields from any 
related table appear. 

The image below shows a New Query of the Audio-
gram table. The data fields are listed using the 
“Related tables” option. If you expand the 
Subject_ID field, a sublist opens displaying the data 
fields in the Subject table (the related table).

By including related table data fields, you can build 
a search query for the master table that includes 
information from the related tables. As in the example query above, you could build a 
search of the Audiogram table to find all male subjects (Gender=2) with right ear air 
thresholds greter than or equal to 40 dB at 125 Hz, 250 Hz and 500 Hz. The following 
steps will show you how to build a search query line..
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To construct a search query line

1. With the New Query form open, click on a data field.
The field appears in the left side of the query box.

2. Select a comparison operator, such as “is equal to,” from the right-hand box with 
a single click.
The operator appears next to the data field.

3. Click in the value field on the lower half of the form and enter a value.
4. Hit the Tab key (not necessary except to display the value without continuing on).

The value appears in the query box.
5. Do one of the following:

• Add another search query line by clicking Add Line.
• Insert a line anywhere in the query by selecting the line it will appear after 

and clicking Insert Line.
• Remove a single line by selecting the line and clicking Del(ete) Line.
• Completely clear the search query box by clicking Clear All.

6. When you have added all the lines required for your search, click Query to exe-
cute your search and return to the Search form.

The resulting set now appears in the list for the table you have just searched. The set 
shows a chronological number, such as 001, then the number of records in the set, shown 
in brackets.
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In searches that involve more than one query line on the New Query form, each line is 
evaluated separately and the result is combined with the previous lines depending upon 
the combining operator selected.

The three operators are AND (&), OR (|), and EXCEPT (#). The AND operator returns all 
records that meet the criteria in both lines of the query, OR finds records that meet the cri-
teria in one or the other line, and EXCEPT excludes certain records from the set returned 
in the previous line.

By using comparison operators such as “equal to” or “not equal to” in combination with 
the combining operators, you can achieve all possible search query combinations. How-
ever, the order of your query lines makes an important difference in your search results.

After you build a search query you can save it for future use by selecting the Save button 
(see “Saving and loading searches” on page 80 and “Executing Sequential Searches” on 
page 81).

The order of the lines in your New Query 
search can be critical to getting the results 
you want. This is because the three com-
bining operators, AND, OR and EXCEPT, 
work in different ways. Order is especially 
critical when using the OR operator. Con-
sider the following search:

Line 1:   [Patient]LastName contains 
'Smith'

Line 2:   [Patient]Gender = 1(1 = Female; 
2 = Male)

Line 3:   [Patient]Birthdate < 12/02/1955
Query line 1 by itself finds 20 records that 

meet the criteria.
Query line 2 by itself finds 50 records that 

meet the criteria.
Query line 3 by itself finds 70 records that 

meet the criteria.
Assume that all 20 of the Smiths are 

male, 10 of the Smiths were born before 
12/02/1955, and 25 of the females were 
born before 12/02/1955:

Line 1 OR Line 2 AND Line 3
The first comparison (Line 1 OR Line 2) 

yields 70 records (all 20 Smiths plus all 50 
females). Next, that result is compared with 
Line 3 using AND. This search returns the 
25 females, plus the 10 Smiths born before 
1955, for a total of 35 records.

Line 1 AND Line 2 OR Line 3
The first comparison (Line 1 AND Line 2) 

yields no records, because there are no 
records that meet both criteria (none of the 
Smiths are female). Next, that zero result is 
“OR’d” with Line 3. The search returns all 
of the Line 3 records (all patients born 
before 1955) because only one OR the 
other line needs to be true. So this query 
returns 70 records.

The lesson to remember from this is that 
an OR at the end of a search can only 
expand the number of records in the set. 
This tends to swamp out the careful selec-
tion of records that you have achieved 
using the previous query lines.

Follow these two rules of thumb:
If possible, place all OR’d query lines at 

the beginning of a search.
Don’t combine OR statements from more 

than one field in a search (see “Executing 
Sequential Searches” on page 81. 

For a more on the factors affecting rela-
tional database searching, see “Set theory 
and searching” on page 177. For a com-
plete list of values to search for in each 
data field, see Appendix B, “Tables and 
Fields” on page 196 and Appendix C, 
“Data lists and their stored field values” on 
page 231.

With search queries, order does make a difference
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Working with search sets
You can use the search sets you create in a number of different ways:

• Select a set of related 
records in a second table 
by dragging-and-dropping 
the set you created to the 
second table’s set list on 
the Search form. This cre-
ates a new set. For exam-
ple, you could drag a set 
from the Audiogram list 
that showed 14 tumors 
(Audiogram 001 [14]) to 
the Subject table list, and 
it might show 1 subjects (Subject 002 [5]). The number would be smaller 
because some of the subjects in the resulting set have multiple audiograms. 
When you drag and drop a set to a new table, you are essentially asking, “Out of 
all the records from the first table that I've found in my set, how many related 
records also appear in the second table?”

• Use the set in a further search query by double-clicking on it.
• Dispose of the set by dragging it to the Trash.
• Combine two sets to create a 

new set by dragging-and-drop-
ping them on the Set 1 and Set 2 
slots at the bottom of the Search 
form. You can only combine sets 
if they belong to the same table. 
You can combine in three ways: 
Union (equivalent to OR), Dif-
ference (equivalent to NOT) and 
Intersection (equivalent to 
AND). All three possible combi-
nations are illustrated on the Combine Sets dialog. It gives you options for cre-
ating a new set with the results or placing the results in Set 1 or Set 2.
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In addition to executing a search query, you can create new sets from the Search form by 
duplicating an existing set. To duplicate a set, double-click on the set name while holding 
down the Shift key. Shift-double-clicking on the Create New Set item makes a copy of the 
“maximum user set” for that table.

The following example shows how you could use the New Query form and the Search 
form to pick a small subset of subjects from the database.

In this case, you want to find the set of subjects with right and left air conduction thresh-
olds greater than 25 dB for 500 Hz (data from the Audiogram table) and who also have a 
Type C tympanograms (Tympanogram table).  NOTE: This example will not require the 
Type C tympanogram to be directly associated with the audiogram with the elevated air 
conduction threshold.

To perform the example search

1. Create the Audiogram set. Follow these steps:
• Open the Search form (Subjects > Search) and find the Audiogram list
• Double-click on its Create New Set to open the New Query form.
• Create the query lines

• Click query.
The resulting set, Audiogram 001 [14], appears in 
the Audiogram list. You have located 14 audio-
grams.

Note: The numbers used in this example, such as 
[14], are just a guide for you to follow while working with your data 
since these numbers may not match. 
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2. Drag this set to the Subject list.
A new set appears, Subject 002 [10]. You have now found the 10 subject records 
related to these audiograms.

3. Now create the Tympanogram set. Follow these steps:
• Double-click on its Create New Set to open the New Query form.
• Create the query lines looking for Type C curves for either ear

• Click query.
The resulting set, Tympanogram 001 [10], 
appears in the Tympanogram list. You have 
located 10 tympanograms.<

4. Drag this set to the Subject list.
A new set appears, Subject 003 [8]. You have now 
found the 8 subject records related to these tympano-
grams.
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5. Now combine the two sets with an intersection.

A new set appears, Subject 004 [4]. You have now found the 4 subject records 
with air thresholds greater than 25 and a Type C tympanogram.

6. Drag this set to the orange Drop Selected Subject Set 
box on the bottom of the Search form.
The Subject List form displays the names of the 4 
subjects who meet your search criteria.

By using the Search form and New Query form, you can per-
form much more specific and complex searches in AudBase. 
It is useful to refer to “Appendix B: Tables and Fields” on 
page 196 and “Appendix C: Data lists and their data field 
values” on page 231 to show you the possible values to use 
in defining the most effective searches.

Note that depending on the menu item you use to open the Search form, the label for the 
result box at the bottom of the Search form will change (see Table 4.1 below): 

Table 4.1: Search-related functions, menu commands and results box titles

Function Menu command Results box title
Search for Subjects Subjects > Search Drop selected subject set
Export Data Reports > Export Data Drop Export Set
Graph Data Reports > Graph Data Drop Graph Set
Report Data Reports > Report Data Drop Report Set
Print Any Document Reports > Print Any Document Drop Print Set
Print Referral Document Reports > Print Referral Document Drop selected subject set
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Saving and loading searches
A complex search query can consist of many lines that can be time-consuming to recon-
struct. AudBase allows you to save search queries and reuse them with just a few mouse 
clicks. 

Building a saved search is the same as creating a search set. Both use the New Query 
form. The difference is that after you have defined your search criteria, you save the 
search and it becomes part of a database record that you can access easily. In addition, you 
can save the same search to a file on your computer, and you or another user can then 
reload the saved search into another database (see “Search/SeqSearch-Checklist” on 
page 128). 

To save a search to a database record

1. Enter the criteria for the search you are building on the New Query form.
2. Click Save.
3. When the dialog box appears, enter a name for your Saved Search.

If you use the name of an existing Saved Search 
within the same table, you will be asked if you 
want to replace the older version of that Saved 
Search. If you use the name of an existing Saved 
Search within a different table, you will be asked 
if you want to use this name again. A Saved 
Searches for the same table must have a unique 
name but a Saved Search for a different table can use the same name again.

Once you save a search, you can re-load it from the New Query form.
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To load a saved search from a database record

1. On the New Query form, click Load to display 
the available Saved Searches for the current 
master table.

2. Select the appropriate Saved Search.
The search criteria appear in the upper box on 
the New Query form. You can modify a saved 
search using the data fields, combining operators and values on the form.

3. To execute the search, click Query.

If you believe there is a Saved Search available that is not in your pop-up list, click 
Refresh List.

All users can review Saved Searches from 
the Preferences form by selecting File > 
Preferences and then selecting Search/
SeqSearch-Checklist. The list on the right 
side of the Preferences form shows all 
tables in the database, with plus sign (Win-
dows) or arrow (Mac) to denote tables 
with a saved search. Opening the sublist 
shows the saved searches. To view a Saved 
Search, double-click on its list item and a 
Saved Search form will appear, looking 
identical to the New Query form but with your search criteria already listed.

If you want to save/load a Saved Search to or from a file on your computer, use the Prefer-
ences form (see “Search/SeqSearch-Checklist” on page 128). This section also explains 
how users with administrator or subadministrator privileges can edit or delete saved 
searches.

Executing Sequential Searches
A Sequential Search is a series of saved searches executed in a predefined order. The 
results of the individual Saved Searches are then intersected to create a final result set. 
This feature can be very useful. For example, it may be more convenient and flexible to 
group four Saved Searches with 10 search query lines each in a Sequential Search than to 
create one large, inflexible Saved Search with 40 search query lines. Sequential Searches 
can also be useful in creating a complex search requiring the use of the OR (|) combining 
operator for more than one data field (see “With search queries, order does make a differ-
ence” on page 75).
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To execute a Sequential Search

1. Starting from the Search form, double-click on a 
search set or the Create New Set item to open the 
New Query form.

Note: You should select Create New Set from the 
table you wish to search. You can only
perform a sequential search on one table at a time.

2. Click Sequential Search and the Execute Sequential 
Search form opens with a list of available Sequen-
tial Searches on the left.

3. Select a sequential search from the list on the left.
You can review the individual searches by double-clicking on them in the list on 
the right.

4. Click Execute Sequential Search.
A new search set is added to the Search form containing the results of your 
Sequential Search.

For more information, see “Search/SeqSearch-Checklist” on page 128.

Special Relation searches
Standard searches allow you to rapidly create data sets that are related by special identifier 
fields, such as the Subject_ID field. However, in some cases you may wish to perform a 
search using values from unrelated fields to create a "pseudo-relationship."  For example, 
using the "audiograms with thresholds > 25 dB" set to define the set of "tympanograms 
which are related to those audiograms".  In the previous example used for searching we 
found a set of subjects with "audiograms with thresholds > 25 dB" and “Type C tympano-
grams”.  We did not specify that the Type C tympanograms belong to the specific audio-
grams, just that they belong to the subject.  It is possible that the subject had a Type B 
tympanogram on the same day they had their audiogram done and a Type C on another 
day.  By executing a Special Relation query we can make sure the tympnaogram belongs 
to the audiogram by relating the [Audiogram]Related_Tympanogram_No field.

The Special Relation query form can be accessed by dragging-and-dropping a search set 
onto the Special Relation box at the bottom of the Search form. This form allows you to 
perform two types of searches: 1) searches comparing field values from one set of records 
with field values in all the available records in a table, and 2) searches performing opera-
tions on a set of records to select the records with the "minimum" or "maximum" values 
within subgroups of these records.

Let's work through the "find the tympanograms for the audiograms with thresholds > 25 
dB" example to illustrate the first type of Special Relation query.
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To perform a standard comparison query

1. In the Appendices you would find 
information on the Audiogram table 
and, subsequently, the 
Related_Tympnaogram_No field. 
This field stores a long integer with 
the following values:

•0 = No related tympanogram
•Tympnaogram_No of the related 

tympanogram
2. Use the New Query form to create a 

new search set from the Audiogram 
table. Your search set is looking for audiograms with air thresholds > 25 dB as for 
the previou search example.

3. We have a set of 14 audiograms. Now we want to find the 
tympanograms which are related to these audiograms. To 
do this we will perform a Special Relation search.

4. Drag-and-drop this set on the Special Relation box at the 
bottom of the Search form. The Special Relation form appears.

This form allows you to select a field from a table and relate it to any appropriate field in the data-
base (even if the table that stores the second field is not related to the first table). In order to be 
appropriate, the two fields must have similar data types (string/text; integer/long integer/real; date/
date). Once you have selected a field from the box on the left, AudBase displays a list of appropriate 
fields in the box on the right. If you are relating a string or text field, you have the option to include 
records with just a portion of the text or the exact text. (See “Appendices” on page 193..) 

A Note about the Special Relation Form and Appropriate Fields 
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5. Use the Special Relation form to create a search set relating the 
Related_Tympanogram_No values in our set of 14 audiograms to the 
Tympanogram_No field from the Tympanogram table. 

6. This results in a set of 7 tympanograms related to the 14 
audiograms.  You could now search within this set for Type 
C tympanograms by double clicking on the set to open the 
New Query form.

Let's work through another example to illustrate the second type of Special Relation 
query. In this case, you want to find the first audiogram for all subjects.

To perform a Special Operations query

1. In the Appendices you would find information on the Audiogram table and, sub-
sequently, the Audiogram_Date field. For subjects with multiple audiograms, the 
first audiogram will have the earliest Audiogram_Date.

2. Create a set of all available audiograms by holding down the 
shift key and double-clicking on the "Create New Set" Item in 
the Audiogram table list on the Search form.

3. Next, drag-and-drop this set on the Special Relation box at the bot-
tom of the Search form. 
The Special Relation form appears. 

4. Select the Standard Comparators pop-up and change the selection 
to Special Operations.
The Special Operations are applied only to the current set of records in the master 
table so the related table information disappears. 
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5. Group the audiogram records by 
subject by selecting the 
Subject_ID field and the "group 
by" operator. 

6. Add a second line by selecting the 
Add Line button on the lower right 
of the Special Relations form. 

7. Select the Audiogram_Date field 
and the "min value" operator to 
find the earliest Audiogram_Date 
for each subject.

8. Click on Query to create a new set 
with the first audiograms in it.

In this example, we started with 23 audiograms (Audiogram 001 
[23]) and found data on 8 of the first audiograms (Audiogram 002 
[8]). The difference in numbers is due to follow-up audiograms. 

9. Find the related 8 subjects by dragging-and-dropping it on the Subject list on the 
Search form.

10. View the subjects, by dragging this new set to the Drop Selected Subject Set box 
at the bottom of the Search form.

You could also identify all the subjects with multiple audiograms by creating two sets of 
audiograms, the first and the last audiograms, and recombining these sets by placing the 
"last" audiogram set in Set 1 and the "first" audiogram set in Set 2 then creating a new set 
from their Difference. Drag the resulting set to the Subjects table.
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Exporting and Reporting
AudBase includes tools that allow you to sort, examine and export data. You can also cre-
ate customized reports and form letters from information stored in the database.

AudBase’s export feature is designed with clinical trials in mind. You can export the data 
in a variety of formats. AudBase also includes a number of security features. Whether you 
are participating in a clinical trial or running one of your own, you can feel confident in 
the security of the data. 

Since many of the export and report features involve searching for data, it may be helpful 
to review Chapter 4, “Searching.”

Exporting data
AudBase allows you to export data to other programs in several different formats. You can 
export complete records or a subset of data fields. You can also export a secure set of data 
for use in clinical trials. Exporting data involves searching for records, selecting an export 
format and then performing the export.

Selecting data for export
In order to export files from AudBase you must search for and select the appropriate data.

To select data for export

1. From the Subject list, select Reports > Export 
Data to open the Search for Export form.

2. Create a set of records to export (see Chapter 4,  
“Searching” on page 70).

3. Drag the set of records to Drop Export Set and 
the Export Data form opens.

Note: The following example is for an export consisting of fields from the [Audiogram] 
table and the [Subject] table.

The Export Data form has two tab selections: Field Info and Export Format. Field Info 
allows you to choose specific fields to include in the export. Export Format allows you to 
select the format for export.

Searching for records
Many of the export and report 
functions start with searching for a 
set of records. To review the 
search function, see Chapter 4, 
“Searching,” on page 70.
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A pop-up above the field list controls the display of the data fields for export. To begin 
with, it reads “Master Table,” which is the full set. You can choose from two other 
options:

• “Master table, sorted” displays the data fields for the master table in alphabetical 
order. 

• “Related tables” once again displays the master table data fields in their native order 
(the order in which they appear in the database), with the addition of nested sublists 
denoting relationships with related tables.

You can select data fields for export in the following ways:

• Drag a single field name from Select the Fields on the left to Export Field List on 
the right.

• Click a single field name from Select the Fields while holding down the Shift key.
• Select a single field name from Select the Fields and click the single arrow.
• Click on the double arrow to move all fields to the Export Field List. 

Using the single arrow or shift-clicking on a field will add fields in the order they were 
selected. When you drag a field from left to right it will be placed above the field it is 
dropped on. You can change the order of the fields in the list on the right by dragging them 
to a new position.

When the list fills the screen, you can add a new field name to the end of the list (no matter 
where you drop it) by dragging while holding down the Shift key. 

To remove fields from the Export Field List, do one of the following:

• Drag a single field to the Trash in the lower right of the form.
• Click on a single field in the Export Field List while holding down the Shift key.
• Click Clear in the upper right to remove all fields in the list.



90 ·  AUDBASE

Audbase.book  Page 90  Thursday, May 4, 2006  10:04 PM
Selecting format for export
AudBase can export data files in a number of different formats depending on how the data 
will be used. In the Export Data Form, select the Export Format tab.

Depending on the format you choose, different options will appear. The first two formats 
are CHECKSUMS and TRANSFER, which are used for sharing data with other partici-
pants in a study using AudBase. Selecting the PICT format will export a graphic that you 
have stored in AudBase. The last three formats, DIF, SYLK, and TEXT, are all text for-
mats, which can be imported by spreadsheets and statistical packages as well as other 
databases. See Table 5.1 for a list of the type of files AudBase exports.

Table 5.1: Export file types and their use

Type Format Use
Checksum AudBase “ot2” file or text Shares security information for clinical study
TRANSFER AudBase “ot2” file Shares data for clinical study
PICT Graphic Exports fields containing graphics as PICT files
DIF Text Exports as text file for spreadsheets, 

statistical packages, and databases.SYLK
TEXT
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Exporting the Checksum format
The Checksum export type is unique to AudBase and primarily used to report interim data 
in a clinical trial. Exporting Checksum files allows both the sender and recipient to be sure 
that the data has not been tampered with or changed without having to share the actual 
data. For more information on how the Checksum works, see “Checksums” on page 183.

When exporting Checksums, you have two options:

• Export as text document
• Complete records

If you choose Export as text document, AudBase generates 
a tab-delimited text document with the checksum informa-
tion. This text document can be opened by any word pro-
cessing or spreadsheet program.

If you do not choose to Export as text document, AudBase 
generates the Checksum in a TRANSFER document, which 
can only be interpreted by AudBase. Although a Checksum 
text file will tell you if any of the data has been changed or 
tampered with, it does not prevent the omission of an entire record. To ensure a higher 
level of security for your Checksum data, do not check “Export as text document.”

When you export the Checksum as a TRANSFER document, the recipient can open the 
document, extract the Checksum and place this information in a text document for analy-
sis. The recipient can also compare the Checksum information with data records they have 
imported in the past to check for changes. For more information, see “Importing TRANS-
FER documents” on page 144.

Selecting the Complete records option sends the Checksum stored internally for the entire 
record in the database, rather than just calculating checksums for the individual fields 
selected for export. If you are participating in a clinical trial, selecting the Complete 
records options allows you to send secure information about your files without sending all 
the data in the files. For more information on using Checksums and TRANSFER docu-
ments, see the Clinical Trials manual.
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Exporting the TRANSFER format
The TRANSFER format is unique and can only be inter-
preted by AudBase. When exporting TRANSFER docu-
ments, you have two options:

• Complete records
• Include checksum info.

If you check Complete records, AudBase exports all fields 
in a record and ignores the export field list, with one 
important exception. Since TRANSFER documents may 
include data from more than one table, the field list is eval-
uated for the tables exporting complete records. Therefore, 
to use the Complete records option at least one field must 
be specified.

Include Checksum Info is selected by default. This option 
offers a number of advantages for the person importing 
these files in a clinical study. First, since the checksum 
information can be placed in a text file, the person 
importing the data can check to see if the files are secure, 
prior to importing the records. Second, the person import-
ing the checksum for an imported record can compare it 
to the checksum from any pre-existing records. In this 
way, the data for import can be checked prior to updating 
or replacing records. If the data is not secure, it will not 
be imported and therefore, previous secure data will not 
be lost. Additional import options are available based on 
this checksum analysis (see “Importing TRANSFER doc-
uments” on page 144).For more information on using Checksums and TRANSFER docu-
ments, see the Clinical Trials manual.

Exporting the PICT format
The PICT export format is designed to export picture data fields in PICT files, which can 
then be opened by a graphics program. Therefore, a PICT file will only be available for 
export if one was previously imported into AudBase. AudBase does not create graphics, 
but instead stores them for future use. This feature allows you to use AudBase to keep all 
information about a subject in one place.

“Complete” records
Since TRANSFER docu-
ments may include data 
from more than one table, 
the field list is evaluated for 
the tables exporting com-
plete records. Because of 
this, to use the Complete 
records option you must 
specify at least one field 
from each table used in the 
export.
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Exporting the DIF, SYLK, and TEXT formatsThe 
final three export file types, DIF, SYLK, and TEXT, allow you to export 
data as text. These file types can be imported by spreadsheets, statistical 
software and databases. When selecting options for this type of export, 
it is often helpful to be familiar with the preferred method of import 
required by the specific software you are exporting the files to.

When exporting text documents, you have three options:

• Filter special characters
• Sort records
• Field name

The DIF, SYLK, and TEXT for-
mats require special characters, 
known as delimiters, for success-
ful import into spreadsheets, sta-
tistical software and databases. 
Delimiters help to ensure even 
spacing of data in a table format. 
The most common delimiters in a 
TEXT file are tabs and carriage 
returns, which can be changed by 
the user. DIF and SYLK use dif-
ferent delimiters, which cannot be 
changed by the user.

The three text export formats share the following options: 

• Filter special characters: If a text data field includes delimiters it could interfere 
with proper importation. Selecting Filter special characters replaces any field delim-
iters and record delimiters within the text field with identifiers: {FD} and {RD}.

• Sort Records: By selecting Sort records you can choose the order of the records 
prior to export.

• Field Names: This pop-up list allows you to choose to include field and/or table 
names.

If you select the TEXT export type, three additional options 
appear:.

• Field Delimiters
• Record Delimiters
• TEXT field bracketing



94 ·  AUDBASE

Audbase.book  Page 94  Thursday, May 4, 2006  10:04 PM
These options give you additional choices for how your data will appear after it is 
exported.

In some cases you may want to specify a delimiter other than the default. For example, 
you may want to use the data from AudBase in a spreadsheet that requires that the delim-
iter be the “#” symbol.

To select your own field or record delimiter

1. Select Other in the pop-up list and a text box appears.
2. Enter the character you wish to use for the field or record delimiter and click OK.

On Export, the character you specified will appear in the file.

For text exports there is also a special option in the Field delimiter pop-up list: Fixed field 
size. Rather than use a field delimiter, some programs prefer to import fields that have a 
fixed length.

To specify a fixed length for an export field

1. In the Export Field List, hold down the Shift key while double-clicking on the 
field name.
A Fixed Field Size dialog appears with the maximum number of spaces allocated 
for the field.

2. Enter the number of spaces and click OK.

Note: If you don’t specify a length, standard 
default lengths are used (see “Default field 
lengths for text exports” on page 176).

Exporting the data
After you have selected the records and defined the for-
mat, exporting data is easy.

To export the data

1. Once the fields and format have been selected, select Export Data.
2. In the Save As dialog, browse to a location and enter a name for the exported data 

file.
3. Click Save.
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Saving/loading exports as database records
Often you may need to export the same group of fields on more than one occasion. The 
Saved Export feature allows you to save the settings for common exports.

Export settings can be saved in the current database or they can be saved to disk to allow 
sharing with other AudBase users, specifically ones who may be participating in the same 
study. Saving an Export will store both the specified export fields and format. 

To save an export to a database record

1. Complete the Export Data form by choosing fields and selecting a format.
2. Click Save and a Request dialog appears.
3. Enter a name for this export and click OK. 

If you use the name of an existing Saved Export within the same table, you will be 
asked if you want to replace the older version of that Saved Export. If you use the 
name of an existing Saved Export within a different table, you will be asked if you 
want to use this name again.

If you want to load a Saved Export from a disk, do so through Preferences (see “Export/
Grouped Export” on page 118).

To load an export from a database record

1. On the Export Settings form, click Load.
A pop-up list of available Saved Exports 
appears.

2. Select the appropriate Saved Export.

Note: Use the Refresh List selection if you believe there is a Saved 
Export available, but it does not appear in your pop-up list.

Grouped exports
In addition to individual Saved Exports, you can perform Grouped Exports, which allow 
you to execute a series of Saved Exports. This capability can be used to export a set of 
records as part of a multi-center clinical study. To create a Grouped Export see “Export/
Grouped Export” on page 118. A Grouped Export must be executed by the administrator 
or subadministrator (see “Exporting a Grouped Export” on page 146). 

Saving and loading exports outside AudBase
If you create an export you would like to share with another AudBase user, you 
can save that export to a file on your computer. You can also load an export that 
another user exported. To do so you must first save the export to the database. 
For more information, see “Saving and loading Saved Exports outside AudBase” 
on page 120. 
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Graphing data
AudBase also allows you to use data to create virtually any form of graph in extremely 
flexible and sophisticated ways. First you use the search function to select a set of data and 
then the Chart Wizard guides you through the steps needed to create a graph. For more 
information see Chapter 4, “Searching” on page 70.

To access the Chart Wizard 

1. Select Reports > Graph Data to open the Search form.
2. Search for a set of records to include in the report. 
3. Drag the selected set of files to Drop Graph Set and the Chart Wizard form opens.
4. Choose and customize a chart. 

Note: For more information about the built-in graphing function, see 
the 4D Supplemental documentation files, included in Adobe Acrobat 
format during installation. To find these files, browse to the AudBase 
program folder and select the Documentation folder.

Creating reports
AudBase provides a number of built-in specialty reports and documents for your use 
including a quick report feature and a word processor. The Quick Report form creates dif-
ferent kinds of customizable, formatted reports that you can export to disk or print out. 

To access the Quick Report form 

1. Select Reports > Report Data.
The Search form opens

2. Search for a set of records to include in the report. 
3. Drag the selected set of files to Drop Report Set. 
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You can customize the Quick Report form to display the data and the order in which it 
appears. You can save a report template and load it from a disk for future use.

Note: For more information about AudBase’s the built-in report function, see the 4D 
Supplemental documentation. These files were included during installation in Adobe 
Acrobat format. To locate these files, browse to the AudBase program folder on your 
computer and select the Documentation folder.

Editing documents
Included in a standalone installation of AudBase is a word processing program known as 
4D Write. For client-server versions the functionality requires an additional license.  This 
program allows you to create merged documents using the data stored in AudBase. For 
example, you can create documents such as subject reminder letters, clinician referrals, or 
operation reports.

Similar to other word processing programs, 4DWrite can open and save in a variety of 
formats that can be used by other word processing programs, such as Microsoft Word.

You may use 4D Write to create documents as you are working with AudBase. But you 
can also merge subject information from the database with standard documents. This 
feature allows you to create documents for different subjects in batches.
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To edit an existing document in the database

1. Select File > Edit Documents. 
The Edit Document form opens. 

2. Select the Document Record List 
pop-up on the bottom left.
The Document Record List 
appears.

3. Select a document.
The document opens.

4. Make changes or additions to the 
document and Click Save to 
Record on the bottom left. 
A Request dialog opens.

5. Save the document in one of two 
ways: 

• If you wish to save the changes 
to this document permanently, 
click OK. 

• If you wish to save the changes as a new document, enter a unique name and 
click OK. 

To edit a document from a disk

1. Select File > Open from the 4D Write window.
2. Browse to the document you wish to open and select Open.

To save a document to the database

1. At the bottom of the window, select Save to Record.
A Request dialog appears.

2. Enter a unique name and select OK. 
The document is saved to the database. It will now appear in the Document 
Record List.
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To save a document to a disk

1. Select File > Save or File >Save As from the 4D Write window. 
A 4D Write Export window appears.

2. Enter a unique name, select a format and select Save. 
The document is saved to the location you specified.

Note: You can save the document in a variety of formats including 4D 
Write, RTF, MS Word and others. 

Printing documents
AudBase allows you to print documents created in 4D Write. You can print a single docu-
ment you have created, such as a memo. You can also merge data within AudBase with a 
document such as a letter, which is often called a mail merge. Merging data allows you to 
print the same document for a large number of subjects. 

To print a single document from 4D Write that does not have to be merged with database 
information, simply choose File > Print. If you are printing documents that contain subject 
information from the database, there are a number of choices. The menu item Reports > 
Print Any Document has a different context depending on which form it is accessed from. 
If the Home Window or the Subject List form is displayed, you can print documents that 
include data from any of the database records. You can load a previously saved document 
or create a new one.

Note: You cannot edit a previously saved file from this window. To do so, see “Editing 
documents” on page 97.

To print a document that includes data related to 
any subject

1. From the Home Window or Subject List select 
Reports > Print Any Document to open the 
Search form. 

2. Search for a set of records to include in the 
report. 

Note: For more information, see “Merging 
documents with data fields” on page 174.

3. Drag the selected set of files on Drop Print Set 
and the Print Document form opens.

 

Note: The document will display the actual 
data in the file. If you wish to see the names of 
the fields you are exporting select View > Ref-
erences from the 4D Write Menu bar.
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4. Select File > Print or File > Print Merge from 4DWrite’s menu bar on the form.
See the 4DWrite manual for further details.

To print a document about a specific subject 

1. From the Subject Studies form select Reports > Print Any Document to open 4D 
Write. 

2. Select Document Record List.
3. Choose a document and click Select.
4. To print the document, Select File > Print or File > Print Merge from 4DWrite’s 

menu bar on the form.

Note: Any document without embedded data fields, or with data fields 
from the Subject table only, will print correctly. If you need to print a 
document that includes data fields from other tables, select the Reports 
> Print Any Document from the Home Window or Subject List form in 
order to select the proper related records. 

When selecting data to merge with documents it is important to understand how AudBase 
stores information. For example, a subject can have more than one audiogram, but an 
audiogram can only be associated with one subject. For more information on the concept 
of related fields, see Chapter 8,“Database Design and Theory” on page 168.

Printing reminders and related forms
At times you may want to send a letter to a subject or a group of subjects that acts like a 
reminder. For example, you may want to remind a subject it is time to make an appoint-
ment or, if a subject is participating in a clinical study, you may want to send a letter ask-
ing a subject to return a QOL (Quality of Life) form.

For the purposes of illustration, we’ll outline a letter process for a QOL study. When a 
subject participates in a QOL study, he or she is asked to fill out a form at regular intervals 
(such as 3 months, 6 months, 12 months and so on). Subjects are also sent follow-up let-
ters that are a reminder to return the completed form. AudBase lets you automate this pro-
cess, generating the QOL forms and the reminder forms.

The forms can be generated using Reports > Print Any Document, but this method can be 
tedious and it also requires that clinic staff manually track the letters. When you use the 
reminder function in AudBase, the process is more efficient.



SIX: EXPORTING AND REPORTING · 101

Audbase.book  Page 101  Thursday, May 4, 2006  10:04 PM
To print a reminder

1. Select Reports > Print Reminder Docu-
ment.

2. From the Reminder Documents dialog, 
select Type of reminder from pop-up 
and specify if it is an initial document 
or a follow-up reminder.

3. Specify a start and end date for the pos-
sible reminders.

4. Select OK and a list of Reminder Doc-
uments to Print appears.

If you do not wish to print one of the reminders in the list, remove it by selecting the 
reminder with one click and then selecting Remove from list. 

To open an individual reminder, double-click on itFor more information see “Working 
with reminders” on page 46.

To print the selected document, click Print.
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Note: Selecting “Remove from List” does not delete the reminder; it only removes it 
from the list of reminders to print. 

Printing referrals
AudBase can create letters to send as referrals for a single subject or a group of subjects. 

To print a referral letter for a group of subjects

1. Select Reports > Print Referral Document to open the Search form.
2. Search for a set of records to include in the report. 
3. Drag the selected set of files on Drop selected Subject Set and the Print Document 

dialog opens.
4. Select the type of document you wish to print 

You can then select the document you wish to print. It will be merged with data from the 
Subjects’ records and with any referring Provider records. 

The letter or document to be merged can include data from any Subject or Provider data 
field. A letter or document will be generated for each referring provider.

To print a referral for a specific subject

1. Starting from the Subject Studies form, select Reports > Print Referral Document.
The referral document opens.

2. Select Print.

Accessing subject information
You can view or print frequently requested demographic 
information, such as subject address, telephone number 
and provider information. 
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To print or view subject information

1. From the Subject List, select Reports > Subject Information.
2. Select Display or Print.
3. Select OK and the Subject Info form displays.

Checking for missing data
When subjects are assigned to a Clinical Group (in other words, a clinical study) you can 
analyze their records to ensure they comply with a Checklist. A Checklist ensures that a 
record is completed with at least the minimal information for that study. 

You can also search the database for subjects who have related records fitting the Clinical 
Group’s Checklist, therefore qualifying them for inclusion in the Clinical Group (both 
options are limited to the subjects whom the user has access privileges for.) 

To check for missing data

1. From the Home Window, select Data Manager > Check Missing Data to open the 
Clinical Groups with Checklists dialog.

2. Highlight a Clinical Group name by clicking once. Select one of the following 
options:

•If this is the first time you are searching 
for incomplete records belonging to 
the Clinical Group, select In Clinical 
Group.

• If you have previously searched for 
saved checklist results, you will see a 
“#” sign before the Clinical Group 
Name. To open these saved results, 
select Open Saved Checklist.
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3. Double-click on the group name. 
4. The result of the checklist search will be displayed in a dialog.

You can print out the information for reference by selecting Print. To open the record 
directly, highlight the record by selecting the string that begins and ends with “ID,” then 
click Select. 

If the Qualify for Group radio button is selected, double-clicking on the 
Clinical Group’s name will search for subjects who are not currently part 
of the group, but meet the Clinical Group’s checklist criteria.

Checking Any Criteria will identify subjects who meet any table’s check-
list criteria, not just those who exactly meet the checklist criteria for every 
table. For example, if you have a checklist that requires a subject who has 
an audiogram with a threshold > 25 dB and is over 65, checking Any crite-
ria will find all subjects with an audiogram with a threshold > 25 dB and all 
subjects over 65.

Copying and pasting Checklist errors
When checking for missing data, you may find missing information you wish to bring to 
another AudBase user’s attention. For example, you may want to let another user know 
that he or she has not completed a subject’s records. To help the other user easily locate 
the incomplete record, you can cut and paste from the Checklist Error Window.
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To copy a checklist error

1. From the Checklist Error window, select 
the text you wish to copy.

Note: Be sure to include the string that 
begins and ends with “ID.” This specifi-
cally formatted text is the identifier used 
to find the record.

2. Select Copy. 
3. Select Finished.
4. Paste the text into an email or text file.

To paste and use a checklist error to find a record

1. Copy the specially formatted test from an 
email or text file.

2. From the Home Window, select Data 
Manager > Check Missing Data to open 
the Clinical Group selection list.

3. Double-click “USE COPY AND 
PASTED INFO.” to open a blank Copy/
Paste Checklist Error window 
opens.Click Paste.

4. To locate the file, highlight the value 
beginning with [ID: and ending in :ID], and click Select.

5. The record opens so you can add the missing information.

Checking study statistics
AudBase comes equipped with features that allow you to check study statistics, depending 
on your version of the program.

Viewing Human Subjects information
For use in year-end “Human Subjects” reports, AudBase allows you to access the total 
number of subjects, total enrolled over the past year and the total still active.

To view Human Subjects Info

• From the Home Window, select Data 
Manager > Human Subjects Info.
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Preferences
The Preferences form lets AudBase users modify their settings for a wide variety of fea-
tures. To open the form, select File > Preferences from the Home Window or Subject List 
menu bar.

Table 6.1 below summarizes the Preference items available to various AudBase users. 
Open any of these items by single clicking from the Preferences form.

The rest of this chapter will discuss the items in the order they appear on the Preferences 
form.

Entry Formats
The *Entry Formats* item allows users to customize some of AudBase’s data entry fea-
tures to fit their needs. The Format On/State List and date checking items are available to 
all users, while the Modify Lists item can only be used by the administrator or a subad-
ministrator.

Format On/No Format
The Format On/No Format item allows all users to set a preference for automatic format-
ting when entering data on the Subject, Clinical Group and Provider forms. When filling 
out a new record, you can use the Format On button to turn on or off automatic formatting 
of such fields as names, telephone numbers, zip code, universal ID or selected identifier. 
The identical button appears in Preferences to let you turn auto-formatting on or off as a 
global preference rather than having to change it for each new record.

State List
AudBase has a pop-up list that helps you pick out the stan-
dard two-letter abbreviation for a U.S. state when filling 
out a new subject form. Users outside the United States can 
customize an equivalent list for their country (see “Data-
base Localization” on page 116). Here, you can set a 
default preference for new records on whether the state list 

Table6.1: Preference items available to various users

Any user Administrator/subad-
min

Administrator only 

*Entry Formats*
Export/Grouped Export
Search/SeqSearch-
Checklist
On Line Help
Serial Port Settings
Subject Info/Navigation
Audiology 1-3

Comorbidity Info
Database Access
Database Localization
Home Window logo

Database Localization
Record Access
Audiology (Admin only)
Warning Message
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will appear by clicking State List, which turns to No State. You can override this setting on 
any form by clicking the identical button.

Turn ‘date checking’ off
When entering dates such as “date of death” on the Subject Info form, an informational 
dialog may be displayed warning the user that an expected range has been exceeded. This 
can be bothersome if a large volume of retrospective data is being entered. The function 
can be turned off for this session.

Modifying lists
The administrator or a subadministrator can use this feature to edit pop-up lists and selec-
tion lists that help guide data entry on many of the forms in AudBase, or to create new 
lists. The lists may display basic data entry choices such as Salutation (“Mr.” Or “Mrs.”) 
or race, or describe tumor chemotherapy or surgery types.

Note: You can also import lists that were created outside of the database in a word pro-
cessing program (see “Importing lists” on page 149).

To create or modify a data entry list

1. With the *Entry Formats* page showing on the Preferences form, click Modify 
Entry Lists.
A Modify Lists dialog appears showing all the lists currently stored in the data-
base. List names preceded by a © symbol are central lists (see “Modifiable Lists” 
on page 181. 

2. Click New List, or double-click on the name of the list you’d like to change.
3. If you are creating a new list, enter a name for the list and click OK.
4. Follow the directions on the Modify Lists form that displays to add, delete, change 

or reorder an item on the list.
Note that certain types of lists allow you to create sublists of “parent” and “child” 
items.
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5. To create a child item, select 
any item on the list, click Add 
Child Item, and type in the 
name of the child item. You 
can change the order of both 
parent and child items by 
dragging them. To delete 
items from the list, drag them 
to the trash.

6. When you are finished mak-
ing changes, click Update to 
save the changes.

7. On the Modify Lists form, 
click Finished.
The changes you made 
should now be reflected on the data entry form where the list appears.

Note that some types of lists display a unique reference number for each list item. When 
you add an item to these lists, AudBase automatically creates a new reference number, or 
you can specify one.

Audiology (1)
This Preferences page lets you customize defaults for 
new Audiograms. This feature saves you from having to 
repeatedly enter items like Examiner, Audiometer, Trans-
ducer, Entry Form, etc. Choose your defaults from the 
pop-up lists under each heading. For informational pur-
pose the version number of the MDC_AudBaseTools 
plug-in is displayed at the top right.

Additionally, the Display Options list allows you to set 
defaults for the appearance of new Audiograms. If you 
want to activate a default option, click to the left of the 
list item. A symbol appears to indicate that the list item is 
active. To turn off an active list item, click on the symbol 
to the left of the list item.  List items without a symbol 
are not active defaults. These list items are explained 
more fully in the section on Audiograms (see “Entering 
basic test information” on page 51). You can override any default settings on the Audio-
gram form itself. 

IMPORTANT NOTE: Most of the items on this pageconsist of modifiable lists. If you 
modify one of these lists (e.g. the Examiner list) you must close the Preferences form and 
reopen it to refresh the pop-up lists on the Preference form.
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Audiology (2)
This Preferences page lets you customize additional 
defaults for new Audiograms and Tympanograms.  You 
can specify default settings for Spondee Stimulus and 
Word Rec Type by clicking on the respective buttons.  In 
each case, a click and drag form appears.  Use this form to 
drag default options from the box on the left into the box 
on the right.  When there are default settings, the button is 
displayed in italics. Use the pop-up lists to specify default 
settings for the Tympanogram graphs.

The preference items for the audiogram tab entry form 
control the entry of dB pure tone values and the way that 
No Response values are displayed on locked entry forms 
and printed forms.

Audiology (3)
Specify default print form settings by clicking on either 
the Audiogram Single Print Forms or Audiogram Multi 
Print Forms button.  In each case, a click and drag form 
appears.  Use this form to drag default options from the 
box on the left into the box on the right.  

Check the Audiogram auto-save box to automatically 
save the Audiogram form every thirty seconds.  This 
form involves a significant amount of data, and this fea-
ture allows you to protect yourself from data loss (for 
instance, as the result of a computer crash). Records that 
have been auto-saved are marked as such on the Subject 
Studies form.
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You can make default Serial Port Device Assignments for each type of device which can 
communicate through the serial port. You can override any default settings on the entry 
form itself. At the time of this writing audiometers and tympanometers are the only sup-
ported types. As other device types are added they will be handled in similar manner. 
Selecting the button will open the Serial Port Device Assignments form.

For each device type, a default device name, communications port and serial port protocol 
can be defined. If you are connecting an audiometer and a tympanometer, they can be con-
nected to different serial ports. The communication protocol is automatically changed 
depending on the entry form page being displayed (e.g. tympanometer protocol is used 
when the Tymps tab is selected on the Audiogram form). The serial ports can be opened 
automatically when a record is open and unlocked. IMPORTANT NOTE: Most preference 
items belong to an individual user or to the database globally. The Serial Port Device 
Assignments belong to the computer which is running the AudBase program (standalone 
or client). The computer’s network name is used to identify the preferences and needs to 
be unique among all the computers using the same database and which are setup for serial 
port communications.

Audiology (Admin)
These preferences are only accessible to the Administrator. 

The default Hearing Level Standard can be set for new audio-
grams. The hearing level standard is modifiable when the 
record is unlocked by selecting the Audiogram > Change 
Hearing Level Standard menu item.
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Word lists can be displayed in a floating window when an audiogram is open by selecting 
the Audiogram > Display Word Lists menu item. The word lists are modified and addi-
tional word lists created here. 

Extended comments can be inserted into the Notes field on an audiogram. The comments 
can be up to 32,000 characters in length and are perfect for history and physical templates 
with blanks to be filled in for the individual subject.The title of the comment is created in 
the list on the left and the attached comment is entered on the right.
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Print form footers can be customized for each print form in use. In some versions of Aud-
Base custom forms may have been ordered which include their own footer. Selecting the 
Customize Print Form Footers button opens the Audio Print Footers form

Selecting the print form in the list on the left allows you to select one of the standardized 
versions or allows you to customize the footer to your own specifications. The footer 
options include three text items and three pictures. The location and sublocation entries 
can be displayed in the footer as well. Once you have defined your own custom footer you 
can copy it for use with other forms.

Database Access
These Preference items allow the administrator to set read/write privileges (lock/unlock) 
for various AudBase users, set certain subadministrator privileges, set user reminder priv-
ileges, and set password expiration.
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Setting global read/write privileges

The administrator controls the “global” ability of users to lock and unlock data entry forms 
by granting “Write” access to records that have been previously saved. This allows users 
to make changes to the data entry forms and their underlying records in the database. 
Forms that cannot be unlocked are considered in “Read Only” mode (see “Unlocking 
forms” on page 40). The changes made using this Preferences item are used as a default 
when the user does not have special access privileges assigned (see “Assigning read/write 
access privileges” on page 125).

Three options are available from the pop-up list:

• Full access allows all users to unlock records at any time by default (gives them 
“Write” access to previously saved records).

• Limited time access allows all users by default to unlock a record for a limited num-
ber of days after it has first been saved. An entry box allows you to specify the days.

• No access restricts users from changing (unlocking) records after they have been 
saved for the first time.

The administrator is always capable of unlocking all 
records. The administrator can also use the checkboxes on 
this form to allow:

• Subadministrators to unlock all records.
• Subadministrators to delete records. 
• Subadministrators to set lock/unlock privileges for 

other users.

Note: Regular users can never delete records with the 
exception of Reminder records.

Setting user reminder privileges
By default, users have the privilege to change or delete 
their own Reminder records. Removing the check from this 
boxon the Database Access section of the Preferences form 
takes away this privilege.



116 · AUDBASE

Audbase.book  Page 116  Thursday, May 4, 2006  10:04 PM
Setting password expiration

Administrators can set a time limit for user passwords by clicking the Password Expiration 
preference item. The dialog allows you to specify an expiration period of 1 to 32,000 days. 
If the Password Expiration Interval item is left blank, passwords will not expire.

Database Localization
Choosing the Database Localization preference item lets you change some data entry 
fields on AudBase forms to automatically reflect the customary formats in your country. If 
you would like to use U.S. formats for zip code, and telephone, click “Database located in 
USA.” Otherwise, modify formats according to the directions below.

The Current Date Format is automatically set by AudBase to reflect the user's main com-
puter preferences. To change the Current Date Format, you must change your computer 
date settings, then restart AudBase. Previously entered dates will be automatically cor-
rected to reflect the change in format.

To set or modify data entry formats

1. With Database localization selected on the Preferences 
form, make sure “Database located in USA” is not 
checked.

2. Click in the box next to the field you would like to auto-
matically format.

3. Use the following characters to set entry formats for 
postal code and telephone number:

• “$” to stand for a number
• “@” to stand for a letter
• “?” to stand for a letter or number.

4. Type in any fixed characters that you wish to appear, such 
as parentheses, hyphens or spaces.

If the postal code in your country has an optional part (for example, the last four digits in 
the U.S. zip code), you can use the “Zip code format suppression” box to override this part 
of the code on data entry forms. (You can always override the autoformat function by 
selecting Format On/Off). By entering zeros in place of the optional numbers here, you are 
telling AudBase to allow data entry personnel to skip this part of the postal code and sup-
press the printing of “-0000.”

Note: Regardless of which data entry format you use to save information in such fields 
as date or telephone number, AudBase will perform accurate searches. For example, a 
user in Great Britain who uses a different date format could still perform a search based 
on dates for records exported from a U.S. database, despite the differences in entry for-
mats.
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Creating a non-USA State List
This preference allows you to create a list of abbreviations 
for provinces or administrative subdivisions that will help 
guide data entry on some forms.

To create a non-USA State List

1. With Database localization selected on the Preferences form, make sure “Data-
base located in USA” is not checked.

2. Click Non-USA State 
List.
A Modify List form 
appears.

3. Click Add Item.
4. Enter the full name of 

the province or other 
administrative subdivi-
sion, followed by an 
equal sign (“=”) and 
then the abbreviation 
you wish to use. Do not 
leave spaces on either side of the equal sign (for example, Alberta=AB, Edin-
burgh=EH, Rheinland-Pfatz=RP).

5. Continue adding items by the same method, and when finished, click Update.
The data entry forms will reflect your changes.

To test your changes, go to 
a form such as the Subject 
Info form, make sure the 
State List button has not 
been disabled (turned to 
“No State”), and then type 
a letter in the State field. 
When you tab out of the 
field, a Select from List 
dialog should appear, with 
a list of the full names of the provinces or subdivisions. Double-clicking on the name will 
enter the abbreviation on the form.
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Setting Universal ID format
All subjects entered into AudBase can have a unique identi-
fication number, known as the universal ID. The most com-
monly used example of a universal ID in the United States is 
a Social Security number, but its use is subject to legal limi-
tations. The universal ID preferences item allows an administrator to format a unique ID 
to prevent different sites in a multi-center clinical trial from entering duplicate subjects. 

The formatting set here will automatically apply to the Universal ID field on the Subject 
Info form. The auto-formatting is designed for the convenience of data entry personnel, 
although they can override it if desired. A format consists of the special characters “$” for 
any number, “@” for any letter, and “?” for either letter or number. Spaces and other char-
acters such as hyphens should also be entered here, and will then appear automatically. For 
example, the University of Washington Medical Center uses the following format:

U 1-23-45-67

To set up this format, you would type the following:

U $-$$-$$-$$

The data entry person need only enter the variable number portion of the number (in the 
example, 1234567) and it will be automatically formatted.

Export/Grouped Export
Selecting this preference item allows users to do the following, depending on their access 
privileges:

• Create a Saved Export.
• Edit or delete a Saved Export.
• Save and load Saved Exports outside AudBase.
• Create a Grouped Export.
• Edit or delete a Grouped Export.
• Save and load Grouped Exports outside AudBase.

Opening the Saved Exports sublist will reveal all available tables. Clicking on a table 
name will enable the New Saved Export button for creating a Saved Export, which will 
belong to the selected master table. Table names with plus signs or arrows have a sublist 
consisting of any existing Saved Exports for that table. For details on creating a Saved 
Export, see “Saving/loading exports as database records” on page 95.

This section will discuss the other Export/Grouped Export features in the order they 
appear above. All of the following procedures assume you have clicked Export/Grouped 
Export on the Preferences form.
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Editing a Saved Export
The administrator and subadministrators can make changes to Saved Exports using this 
feature. Other users can review a Saved Export document here. Start by selecting Export/
Grouped Export on the Preferences form.

To edit a Saved Export

1. Open the Saved Export sublist on the Preferences form, and find the Saved Export 
you wish to edit by opening the master table list for that export.

2. Double-click on the Saved Export name in the list.
3. On the Edit Export Settings form, make the desired changes to the Field Info or 

Export Format tabs.

4. Click Save.
A dialog will ask you to name the Saved Export.

5. Do one of the following:
• Keep the current name, which will replace the existing Saved Export with the 

new settings.
• Choose a different name, which will create a new Saved Export and keep the 

existing one.
6. Click Finished.

The name of any newly created Saved Exports will appear in the sublist.
7. To delete a Saved Export, double-click on the name in the sublist, then click 

Delete on the Edit Export Settings form.



120 · AUDBASE

Audbase.book  Page 120  Thursday, May 4, 2006  10:04 PM
Saving and loading Saved Exports outside AudBase
Administrators and subadministrators can save the export settings used to create Saved 
Exports to a file on their computer and then reload them. This is useful when exchanging 
data in multi-site trials. By using this function, you can avoid having to rebuild the exports 
that are used to create Saved Exports.

To save a Saved Export to disk

1. Open the Preferences form (File > Preferences).
2. Click Export/Grouped Export.
3. Open the Saved Exports list in the box on the right by using the plus sign or arrow.
4. Find the Saved Export you wish to save to a file on your computer by opening the 

tables that have plus signs or arrows next to them.
5. When you have found the Saved Export, double-click it to open the Edit Export 

Settings form.
6. Click File > Save to Disk.
7. In the Save As dialog, browse to a destination folder, name the file, and click 

Save.
The export settings used to create the Saved Export will be saved in a special for-
mat that allows them to be reloaded into AudBase.

To load a Saved Export from disk

1. Open the Preferences form (File > Preferences).
2. Click Export/Grouped Export.
3. Open the Saved Exports list in the box on the right by using the plus sign or arrow.
4. Find the table that matches the one used to create the Saved Export you are load-

ing, then do one of the following:
• With the table name highlighted, click New Saved Export to open a blank Edit 

Export Settings form.
• Double-click on a Saved Export name within the table to open an existing 

Edit Export Settings form.
5. Click File > Load from Disk.
6. In the Open dialog, browse to the file that contains the Saved Export you wish to 

load, and click Open.
The Edit Export Settings form will change to reflect the settings from the file you 
loaded.
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7. Click Save. 
A Request dialog appears.

8. Enter a unique name for this export and click OK. If you use the name of an exist-
ing Saved Export, you will be asked if you want to replace the older version of 
that Saved Export.

Creating Grouped Exports
A grouped export is an export derived from multiple tables. It is created from a series of 
Saved Exports in the same way that a Sequential Search is created from a series of Saved 
Searches. 

Opening the Grouped Export sublist on the Preferences form will reveal any previously 
defined Grouped Exports.

To create a Grouped Export

1. Click the Export/Grouped Exports list item on the Preferences form.
2. Select Grouped Exports from the list on the right, and click New Grouped Export.

The Grouped Export form displays.
3. From the Saved Export list on the left, use the plus signs or arrows to open list 

items containing Saved Exports.
4. Drag the Saved Exports you wish to assemble into a Grouped Export to the list of 

tables on the right.
AudBase will only allow you to drag a Saved Export to the table it was created 
from, and you can only drag one Saved Export per table.

5. When you have built your Grouped Export, click Save.
6. Using the dialog, name your Grouped Export, then click OK.
7. Click Finished.

The name of the new Grouped Export appears in the sublist on the Preferences 
form.

Note: You can save Grouped Exports to a file on your computer, and they can be 
reloaded into the database. This is especially useful for sharing defined exports among 
participants in multi-site clinical studies. This works for both new Grouped Exports and 
those previously saved to the database. With the Grouped Export form open, select File 
> Save to Disk or File > Load from Disk.

If you are trying to share files between platforms (for example, 
Windows-to-Mac), the normal open dialog may not show the file 
you are looking for. In this case, hold down the Shift key while 
selecting File > Load from Disk. This forces the Open dialog to 
display all files.

Special 
note on 
Windows 
vs. Mac
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The administrator or subadministrators can modify previously saved Grouped Exports 
from the Grouped Export form by adding new Saved Exports or dragging old ones to the 
Trash. To delete a Grouped Export, open the form and select Delete.

Changing the Home Windows logo
The Home Window in AudBase comes with a standard logo. You may wish to substitute 
your own picture or graphic to customize your version. Selecting this preference item will 
open a form displaying the current Home Window logo. You may then paste a new logo. 
The form displays the standard image size to help you design your logo.

To install a new Home Window logo

1. On the Preferences form, click Home Window logo.
2. Click on the current logo to select it.
3. Paste the new logo.

You can change back to the current logo prior to updating by selecting the Revert 
button.

4. Click Update.
After your logo is saved, you can de-install the logo by selecting the logo and the Edit > 
Cut menu item. The default copyright logo will then be displayed again in the Home Win-
dow.

On Line Help
When on line help files are included in the installation 
package the files can exist on the local hard disk or by 
a web connection. Installing the help files on the local 
hard disk makes them accessible even if an internet 
connection is not available. The ‘Help’ link file can be 
generated if it doesn’t already exist and local ‘Help’ 
files can be downloaded from the server in a client-
server environment by selecting the appropriate but-
tons. The Create Local ‘Help’ Files button will be greyed out in a standalone version.
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Record Access
The administrator can use this Preferences item to set the following 
privileges for more than one user at a time:

•· Access to view, write, or create new records for specific 
tables in the database

•· The ability to see or hide parts of the Subject Studies form
•· Anonymous Status

Assign 'Anonymous' Status button
The administrator can change individual users to Anonymous Status 
by modifying their Provider record (See “Anonymous function” on page 22.). This Prefer-
ences item allows Anonymous Status to be set for a group of users all at once.

To assign Anonymous Status to multiple users

1. With Record Access selected on the Preferences form, click Assign Anonymous 
Status.
A dialog appears.

2. Select Yes to assign Anonymous Status.
The Search for Providers form appears to allow you to select providers.

3. Double-click on the Create New Set item in the Provider table 
list.
The New Query form appears.

4. Use the form to search for Providers by name, Clinical Group, 
or other criteria (See “Searching” on page 70.).

5. Drag the newly created set to the Drop Selected Provider Set box at 
the bottom of the Search form.
Anonymous Status will be changed for the group of providers you 
selected.

Note: If you wish to make a change for all providers in the database, hold down the 
Shift key while double-clicking on the Create New Set item in the Provider table list. The 
set of all providers will appear, and you can then drag it to the Drop Selected Provider 
Set box.

Once the Anonymous function has been activated, the Provider's privileges will be 
affected in a variety of ways. The most obvious change is the information displayed on the 
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Subject List. Providers in Anonymous mode can only see a list of Anonymous subjects 
with a generic identification number.

The Demographics tab of the Subject Studies form will appear modified as well.

Additionally, this function limits the information available when performing exports and 
searches. Only non-identifying fields will appear as search and export options. If a user 
tries to load a saved search or export created by a user with greater database access, an 
alert will appear.
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If the unauthorized fields are essential to the search or export, the activity cannot be exe-
cuted. However, sometimes the search or export may be performed. In this case, the unau-
thorized fields are deleted from the display before it is shown to the user.

Assigning read/write access privileges
The administrator can set individual users’ read/write access to individual tables in the 
database using their Provider record (see “Setting table record privileges” on page 23). 
This Preferences item allows table access privileges to be set for a group of users all at 
once.

To set table access privileges for multiple users

1. With Record Access selected on the Preferences form, click Assign Read/Write 
Access.
A Table Access Privileges dialog opens. To the left of the list of tables are three 
columns, displaying either a “Y” (meaning “Yes, you do have this privilege”) or a 
blank space (no privilege).

2. Toggle the letter Y on or off by clicking on them to set privileges for viewing or 
writing records, or creating new records. You can change an entire column by 
shift-clicking. After setting overall table access privileges, you can also use the 
pop-up list to specify default access, limited-time access (in days) or full access.

3. Use the checkboxes to set user privileges for printing or exporting data from 
tables they can view.

4. Click Update.
The Search for Providers form appears to allow you to select which providers to 
change access privileges for.

5. Double-click on the Create New Set item in the Provider table list on the form.
The New Query form opens.

6. Use the form to search for Providers by name, Clinical Group, or other criteria.
7. Drag the newly created set of records from the Pro-

vider table list to the orange Drop Selected Provider 
Set box at the bottom of the Search form.
Access privileges will be changed for the group of pro-
viders you selected.

Note: If you wish to make a change for all providers 
in the database, hold down the Shift key while dou-
ble-clicking on the Create New Set item in the Provid-
ers table list. The set of all providers will appear, and 
you can then drag it to the orange box.
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Setting Subject Studies access privileges
The administrator can set an individual users’ ability to customize the Subject Studies 
form, or their access to parts of the form, using the Provider Information form (see “Mod-
ifying Subject Studies Access” on page 24). This Preferences item allows the same access 
and customization privileges to be set for a group of users.

To set Subject Studies privileges for multiple users

1. With Record Access selected on the Preferences form, click Assign Subject Stud-
ies Access.
A dialog displays the different tabs that a Subject Studies form can display, with 
two columns on the left for setting the following two privileges:

•Tab accessible to user: Whether the user will see the tab on the Subject Studies 
form.

•Tab modifiable by user: Whether the user has the ability to show or hide the 
tab.

2. Toggle the “Ys” on or off by clicking on them to set privileges. You can change an 
entire column by shift-clicking.

Note: If you remove a Provider’s privilege to see a tab on the Subject 
Studies form, it will affect his or her ability to search the database. This 
is because you have limited the provider’s access to the tables in the 
database that are connected to the respective tab.

3. Click Update.
The Search for Providers form appears to allow you to select which providers to 
change access privileges for.

4. Use the form to search for Providers by name, Clinical Group, or other criteria.
5. Drag the newly created set of records from the Provider table list to the orange 

Drop Selected Provider Set box at the bottom of the Search form.
Access privileges will be changed for the group of providers you selected.

If you wish to make a change for all providers in the database, hold down the Shift key 
while double-clicking on the Create New Set item in the Providers table list. The set of all 
providers will appear, and you can then drag it to the orange box.

Tracking user record access

AudBase automatically keeps track of basic record modifica-
tion activity within the database, showing which user has 
changed a record, and when. The results are stored in a field 
called Record Modification History that appears in every 
table. By using the Record Access Log File item, the adminis-
trator can choose to have a separate log file created that will not only show that records 
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have been changed, but also which individual fields were modified and by whom, and 
even who has looked at what records.

The administrator can choose what kind of information to save to the log file using this 
Preferences item. The choices, and the types of log files they create, are:

• Record modifications: Lists all records that have been changed.
• Individual field modifications: Shows not only the record that was changed, but the 

individual fields within that record that were changed.
• All record viewing: Shows all records that have been viewed whether or not they 

were changed.

To log individual field modifications, you must first check Record modifications. This is 
because a file showing all changes to all fields must include the entire record that those 
fields are part of.

When one of these options is selected, AudBase creates a text file in the same folder where 
the program’s data files are saved, and names it with your version of AudBase plus 
“Log.TXT.”

Dividing record access log files
Log files of activity within the database can quickly 
grow quite large, especially if you choose to keep track 
of all record viewing. This feature generates a new text 
file when the initial log file grows beyond a set size in 
kilobytes, or based on the number of days of database activity recorded.

The default setting is Use Size, which allows you to set a log file size limit between 500 
and 65,534 kilobytes. When the file reaches your specified limit, AudBase creates a new 
text file in the same folder. You can also choose Use Days, and specify a number of days 
between 1 and 1,000. A new log file will be created after the number of days has elapsed.

The current log file will be named using your version of AudBase 
and the word Log. Archived versions of the log file will be named 
with the date following “Log.” If more than one file is created per 
day, AudBase will number the files consecutively with the number 
appearing before the date.
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Search/SeqSearch-Checklist
Saved Searches, Saved Special Relation Searches, and 
Sequential Searches can be created, edited and deleted 
using this preference item. Checklists can also be cre-
ated and edited here (see “Creating Checklists” on 
page 131). Saved Searches, Saved Special Relation 
Searches, and Sequential Searches opened here can be 
saved to your computer or reloaded by selecting the 
File > Load from Disk or File > Save to Disk menu 
items attached to the Saved Search, Saved Special Rela-
tion Search or Sequential Search forms (see “Saving 
and loading Saved Exports outside AudBase” on 
page 120

Opening the Saved Searches or Saved Special Relation 
Searches sublist will reveal all available tables. Click-
ing on a table name will enable the New Saved Search 
or Saved Special Relation Search button for creating a 
Saved Search or Saved Special Relation Search, which will belong to the selected master 
table. Table names with plus signs or arrows have a sublist of any existing Saved Searches 
or Saved Special Relation Searches for that table.
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Editing a Saved Search
The privilege to edit or delete a Saved Search or Saved Special Relation Search is reserved 
for the administrator and subadministrators though all users can review a Saved Search or 
Saved Special Relation Search at any time.

To edit a Saved Search

1. Double-click on the Saved Search name in the list.
2. On the Saved Search form, modify your search criteria.

3. Click Save.
A dialog will ask you to name the Saved Search.

4. Do one of the following:

• Keep the current name, which will replace the existing Saved Search with the 
new settings.

• Choose a different name, which will create a new Saved Search and keep the 
existing one.

5. Click Finished.
6. The name of any newly created Saved Searches will appear in the sublist.

To delete a Saved Search, double-click on the sublist item to open the Saved Search form, 
then click Delete.

To edit a Saved Special Relation Search

1. Double-click on the Saved Special Relation Search name in the list.
2. On the Saved Special Relation Search form, modify your search criteria.

3. Click Save.
A dialog will ask you to name the Saved Search.
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4. Do one of the following:

• Keep the current name, which will replace the existing Saved Special Relation 
Search with the new settings.

• Choose a different name, which will create a new Saved Special Relation 
Search and keep the existing one.

5. Click Finished.
6. The name of any newly created Saved Special Relation Searches will appear in 

the sublist.

To delete a Saved Special Relation Search, double-click on the sublist item to open the 
Saved Search form, then click Delete.

Creating Sequential Searches

The administrator and subadministrators can use this item to create, edit and delete 
Sequential Searches. This is a very useful function that works by performing a series of 
Saved Searches and then combining the results to create a final set. This capability can be 
especially helpful in allowing you to define a set of records for export as part of a multi-
center clinical study.

For example, it may be more convenient and flexible to group four Saved Searches with 
10 search query lines each in a Sequential Search than to create one large, inflexible Saved 
Search with 40 search query lines.

When you execute a Sequential Search, individual Saved Searches are combined using the 
AND combining operator, also known as “intersection.” This means AudBase finds only 
those records that meet the criteria in all of the saved searches.

Note: Sequential Searches can consist of Saved Searches from multiple tables, which 
can be very useful for exporting related records. Sequential Searches that are executed 
from the New Query form will only display and use the searches from the master table 
that was used to open the New Query form (see “Using the New Query form” on 
page 72).
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To create a Sequential Search

1. Click the Search/SeqSearch-Checklist item on 
the Preferences form.

2. Select Checklist/Sequential Searches from the 
list on the right, and click New Checklist/
SeqSearch.

3. From the Saved Searches list on the left, use 
the plus signs or arrows to open list items con-
taining Saved Searches.

4. Drag the Saved Searches you wish to assemble 
into a Sequential Search to the list on the right.
You can change the order of the Saved 
Searches by dragging them to a different posi-
tion in the sublist.

5. When you have built your Sequential Search, 
click Save.

6. Using the dialog, name the search, then click OK.
7. Click Finished.

The name of the new Sequential Search appears in the sublist on the Preferences 
form.

The administrator or subadministrators can modify Sequential Searches from the Sequen-
tial Search/Checklist form by adding new Saved Searches or dragging old ones to the 
Trash.

To delete a Sequential Search, open the form and select Delete.

Creating Checklists
Especially in the case of a clinical study, it is important to make sure records saved in 
AudBase meet certain minimum criteria. For example, you would want a new subject 
record to have at least a first and last name before it can be saved. To simplify and enforce 
this process, AudBase allows the administrator to create Checklists that will review a data 
entry form when it is being saved, and prompt the user if any of the minimum information 
is missing.

Checklists are built from Saved Searches in the same way you build a Sequential Search 
(see “To delete a Saved Special Relation Search, double-click on the sublist item to open 
the Saved Search form, then click Delete.” on page 130). But instead of using the search to 
find all the records meeting certain criteria, you use a Checklist search to ensure that a new 
record being saved in AudBase meets certain criteria to begin with.
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In the following example, a Checklist was created for a hypothetical Clinical Group study 
where all the subjects were treated for tumors whose primary site is either spine or pelvis. 
To create this checklist, the New Query form was used to build a Saved Search for the 
Tumor_Description table. 

When used as a Saved Search for the 
Tumor_Description table, this set of query lines 
would find all spine or pelvis tumors. When 
you create a Checklist from the search and 
assign it to a Clinical Group, AudBase performs 
the same search whenever a user belonging to 
this group (and who has been assigned this 
Checklist) tries to save a Tumor_Description 
record. The criteria for being able to save the 
record is that it must contain spine or pelvis.

Any attempt to save a Tumor_Description 
record that does not satisfy all the Checklist criteria will prompt a dialog telling the user 
about the deficient fields. This is especially useful in controlling data for the purposes of a 
study.

To create a Checklist

1. Using the Search form and New Query form, create one or more Saved Searches 
that define the criteria for your Checklist.

2. From the Preferences form, select Search/SeqSearch-Checklist.
3. Click on the Checklists/Sequential Searches list item in the right-hand box.
4. Click New Checklist/SeqSearch.

The Sequential Search/Checklist creation form appears. On the left, a list contains 
all Saved Searches in the database, organized by table. An item with a plus sign or 
arrow contains a sublist of Saved Searches.

5. Open the sublists and find the Saved Search(es) that you created.
6. Drag the Saved Search sublist item(s) that you wish to define your Checklist to the 

list on the right.
You can change the order of the Saved Searches by dragging them to a different 
position in the sublist.

7. Once you have defined your Checklist, click Save.
A request dialog will ask you to name your Checklist search.

8. Enter a name and click OK.
9. Click Finished.

The newly created Checklist search appears in the list of Checklists and Sequen-
tial Searches on the Preferences form.
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Assigning Checklists
Once you have created a checklist, you must assign it to a Clinical Group, and then to Pro-
viders, to make it properly test for your criteria.

To assign a Checklist to a Clinical Group and Providers

1. From the Home Window or Subject List menu bars, select File > Clinical Group 
Info to open the Clinical Group List, then double-click on the group you wish to 
assign the checklist to.
The Clinical Group form opens.

2. Unlock the Clinical Group form by clicking on the black lock.
3. Click Clinical Group Checklist.

A form opens with a list on the left of all Checklists 
saved in the database.

4. Click the Checklist you would like to associate with 
this Clinical Group.
The Checklist Definition box displays all tables, with sublists attached to the 
tables that contain the Saved Searches comprising your checklist. You can double-
click a Saved Search to display it and check the criteria.

5. Click Update Checklist Selection.
The Clinical Group form appears again. The text on 
the Clinical Group Checklist button has changed to 
italics to signal that a Checklist is associated with this 
Clinical Group.

6. Open a Provider Information form by selecting File > Provider Info from the 
Home Window or Subject List menu bar.
The Provider List appears, allowing you to choose the provider record you wish to 
assign the Checklist to.

7. Unlock the Provider Information form, then click 
Provider Checklist.
A list creation form appears, allowing you to select 
a Checklist and also decide whether to allow the 
user to override the Checklist.
Whenever the user saves a record, AudBase will run 
the Saved Searches used to create this Checklist to 
enforce the criteria you set.
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Using an assigned Checklist

You can pre-test the Checklist before saving a new or modified record or test it on a previ-
ously saved record by selecting the Data Checklist menu item found in one of the menus 
attached to the data entry form (for example, Subject > Data Checklist or > Data Check-
list)

A Checklist pretest can always be dismissed by selecting the Close button. The adminis-
trator or a subadministrator has the option to enforce a Checklist when the record is saved 
(Recheck is the only option) or allow a user to save the record anyway (Accept is also an 
option).

The Checklist is displayed in a dialog that you can keep open for informational purposes 
while modifying a data entry form. When satisfied with your changes, you can select 
Recheck.

Master Checklist for data entry

You can choose one Clinical Group’s Checklist as the default master checklist for the data-
base by clicking the Select Master Checklist button from the Search/SeqSearch-Checklist 
item on the Preferences form. A list-creation form will open and allow you to choose one 
group’s checklist (see “Assigning a Clinical Group Checklist, Search and Export” on 
page 30). Whatever checklist you select will become the default checklist for users who 
have not been assigned a Checklist. Clicking the Allow checklist override box will allow a 
user to save a record that does not satisfy the checklist criteria.

Note: If a Saved Search making up the Master Checklist is modified, you will have to 
update the Checklist by reselecting the Master Checklist button and choosing the Clini-
cal Group’s checklist again. This is done automatically on database startup, but in a cli-
ent-server mode the server would otherwise have to be restarted.

Assigning Checklists to multiple users

The administrator can assign a Checklist to one or more 
users that overrides the Master Checklist, allowing the 
selected users to save records that meet other criteria. To 
make this change for one user, go to the Provider Infor-
mation form (see “Assigning a Provider Checklist” on 
page 25). The “Assign Checklist for Users” item allows the administrator to assign a 
checklist that differs from the Master Checklist to a batch of users.

Note: The administrator can assign him or herself a checklist using a special menu item 
attached to the Provider List form. See “Assigning an Administrator Checklist” on 
page 19.

To assign a Checklist to a group of users
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1. With Search/SeqSearch-Checklist selected on the Preferences form, click Assign 
Checklist for Users.
A List Creation form displays all the defined Clinical Groups or Checklists on the 
left, and the default Master Checklist on the right.

2. Drag the name of the Clinical Group whose Checklist you would like to assign to 
this group of users to the box on the right.
The new Checklist replaces whatever was previously in the box.

3. Click Update.
A Confirm dialog displays.

4. Do one of the following:
• Click All to make the 

Checklist apply to all 
providers in the data-
base.

• Click Select to choose 
which Providers the Checklist will apply to.
A Search for Providers form displays, allowing you to create a set of Provid-
ers  (see “Opening the Search form” on page 71). Drag the set to the Drop 
Selected Provider Set box at the bottom of the search form.

Serial Port Settings
Generic serial port settings can be specified for data cap-
ture via the serial port. These settings should match the 
settings on the equipment you are connecting to. Refer to 
specialized version serial port settings elsewhere in this 
manual as needed.
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Subject Info/Navigation
You can customize your Subject List form using this Pref-
erences item by defining which patients will appear on the 
form, and also choose which navigation tabs will appear 
on the Subject Studies form. This item also allows you to 
set default providers and Clinical Groups for new subject 
records.

When you click Criteria to modify your Subject List crite-
ria, your changes will be retained the next time you 
launch AudBase, unlike when you modify the Subject 
List criteria with the Home Window or the Subject List 
form open (see “Setting Subject List criteria” on page 11).

This form also allows users to decide which of the naviga-
tional tabs on the Subject Studies form they wish to view 
(hide tabs that they never use, for example). The ability to 
hide these tabs can be restricted by the administrator, 
however, using the individual Provider record (see “Modifying Subject Studies Access” 
on page 24), or for more than one user through the Preferences form (see “Setting Subject 
Studies access privileges” on page 126).

To change the appearance of the Subject Studies form (for Providers)

1. With Subject Info/Navigation selected on the Preferences form, click Subject 
Studies Access.
A dialog displays the tabs on the Subject Studies form you have privileges to 
remove from view.

2. Click “Y” (“Yes”) in the Tab Displayed column to remove the tab from the form.
3. Click Update, and then click OK on the Preferences form to save the changes.
4. To restore the tab, open the dialog and click in the left column. The “Y” will reap-

pear.

Note: User preferences will not affect whether or not tables appear on Search forms.

Setting new subject defaults

You can also use the Subject Info/Navigation part of the Preferences form to set default 
provider and clinical institutions that will appear automatically on each new Add Subject 
Records form. A Create List form appears and you can drag names from the Full Provider 
List to the list of default providers on the right. You can designate multiple providers and 
Clinical Groups using this method. Clicking on one provider or Clinical Group name 
before saving the preference will designate them as the primary provider or group.
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Warning Message
The Warning Message item allows the administrator to set a message that appears when 
any user logs into AudBase. This can be useful, for example, to comply with regulations to 
inform users that they are logging onto a confidential database program.

AudBase provides a default message 
that you can activate, or you can add 
your own custom message. The final 
item allows you to remove a message.

To set the default message

1. From the pop-up menu, select Default Message.
The default message appears for your review.

2. If you wish to activate 
this message, select 
Update.
The message at right 
will appear the next 
time a user logs into 
AudBase.

3. If you wish to print the 
message, select Print.

Note: You cannot edit or modify the default message. 

To set a custom message

1. From the pop-up menu, select Custom Message.
A blank text box appears.

2. Type in a custom warning message.
3. Select Update to save what you have typed. When you are done, click Finished.

The message appears next time a user logs into AudBase. 
4. If you wish to print the message, select Print.

To remove a message

1. From the pop-up menu, select No Message. 
2. Select Update.
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Administrator Functions 
In AudBase, the administrator is a sort of chief security officer, in charge of protecting the 
integrity of the database and making sure data is shared in a secure manner. This chapter 
explains tasks that users with administrator privileges carry out.

It begins with the special administrator menu bar that controls some of the import and 
export functions of AudBase, then describes such tasks as deleting records, assigning 
passwords, and upgrading to a new version of the program.

Using the Administrator Menu Bar
AudBase has a special menu bar where you will find options for administrator-only import 
and export functions, along with a special Search form for administrators, and several 
other functions. This section will discuss each item on the administrator menu bar in the 
order in which they appear in AudBase. Subadministrators can select any menu item 
except one: The Clean Ups > Clear Unconnected Recs menu item is only available to the 
administrator.

To view this special menu bar:

• From the Home Window, select Data Manager > Administrator Menu Bar.
The menu bar will change to display menu items only available to the administrator 
or a subadministrator.

You can return to the standard menu bar by selecting File > Home Window Menu Bar.

Home Window menu bar (above)

Administrator menu bar
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Import\Export Menu items
The Import\Export menu on the administrator menu bar is where many of the administra-
tor-only functions related to the sharing of data are carried out. An explanation of each 
option follows.

Performing administrator-only searches
Selecting Import\Export > AdminOnly Search opens the AdminOnly Search form for 
tables that are not accessible to regular users. The form has two navigation tabs on its right 
side, allowing the administrator to switch back and forth between the AdminOnly Search 
form, and the Search form that is available to all users (labeled “Common Structure”).

The administrator-only table list includes three tables with no direct relationships with the 
other tables in the database: Constants, LargeObject, and Saved Sets. These tables can be 
searched for diagnostic and informational purposes and are also included in the Admin-
Only Export Search form (see “Note: To access the standard search format, select the 
Common Structure tab. Any Clinical Group, Provider or Subject sets defined on one tab 
will appear on the other tab.” on page 142).

In addition to the three unconnected administrator-only tables, the form displays three 

special linkage tables: SubjectProvider, SubjectClinicalGroup, and ProviderGroup. These 
linkage tables are normally hidden from the user and are only useful in special circum-
stances to an administrator.
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An example is the circular path formed by these three linkage tables and the Provider 
table, the ClinicalGroup table, and the Subject table. Because this is a circular path, 
searches can end up with different answers depending on which way the search is per-
formed. This only affects the special situation where the administrator or subadministrator 
would like to know which subjects belong to group administrators for the various Clinical 
Groups.

In the normal Search form, creating a Provider set and dragging it to the ClinicalGroup 
table list first creates a set of all the Subject records related to the Provider set and then 
creates a set of all the ClinicalGroup records related to those Subject records. This does 
not answer the original question: Which subjects belong to the group administrators for 
those Clinical Groups? Since this is a circular path, the program must be “forced” to get 
the desired answer. This is accomplished through a two-step process that is explained on 
the AdminOnly Search form. Briefly, a ProviderGroup set is first created by dragging the 
starting Provider set or ClinicalGroup set to the ProviderGroup table list. Then, you can 
choose one of two directions on the “circular” path:

• Drag the ProviderGroup set to the Provider table list, then to the Subject list.
• Drag the ProviderGroup set to the ClinicalGroup table list, then to the Subject list.

You will obtain a different set of subjects depending upon which direction you drag the 
sets.

Note: To access the standard search format, select the Common Structure tab. Any Clin-
ical Group, Provider or Subject sets defined on one tab will appear on the other tab.
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Performing administrator-only exports
The AdminOnly Export item on the administrator menu bar allows you to create sets for 
export by searching the tables that are only available to the administrator or a subadminis-
trator. Clicking it brings up a form called Search for Export (Admin Only).

You can export records from all tables except Constants and Saved Sets. Constants and 
Saved Sets records only have a context in the data file in which they reside. LargeObject 
records include exportable items such as the tumor stage info records, modifiable lists, 
picture data, documents created with the 4DWrite plug-in program, and Saved Search, 
Sequential Search, Saved Export, and Grouped Export records. Exporting these records 
allows you to share them with other sites. You export records from these tables in the same 
manner as the other tables (see “Exporting and Reporting” on page 88).

Note: To access the standard export tables, select the Common Structure tab.

Import Raw Data menu item
Importing some data types into AudBase requires a custom application. Selecting this 
menu item from the administrator menu bar displays an alert box that tells you to contact 
the AudBase vendor (e-mail: AudBase@u.washington.edu). Once the Import_AudBase 
application is added, you can use this item to import TEXT type exports from other data-
base programs into AudBase, or import information in the DIF, SYLK or DBF formats.
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Importing TRANSFER documents
The Import TRANSFER Doc menu item allows you to open, examine and import 
TRANSFER type export documents that contain data records and/or checksum data. 
Selecting this item will open the standard dialog to let you choose a file to import.

After you choose the file, the Import TRANSFER Doc dialog appears, giving you three 
options:

• Checksum Info import records
• Checksum Info current records
• Import the record data.

Here is a look at how the three options work:

Checksum Info Import Records
This option allows you to simply examine the 
TRANSFER document to see what informa-
tion it contains before taking steps to import it. 
Selecting this option then clicking the Create 
Text Doc button will generate a tab-delimited 
text file that will include the required internal 
ID fields for each record that has been 
exported, along with the checksum for the 
exported data fields. If data fields were 
exported without checksum calculations, the 
text file will so indicate. 

Checksum Info Current Records
This option allows you to compare the exported records to the records that they would 
replace if you imported them. Selecting this option then clicking the Create Text Doc but-
ton will create a tab-delimited text file containing the required internal ID fields for each 
record exported. The text file will also show the calculated checksum for any existing 
records with the same internal IDs currently residing in the destination data file that would 
be updated if the “new” record data were imported. In addition, if the checksum data was 
included in the TRANSFER-type document, AudBase will compare the existing destina-
tion data file record fields and the data fields that would be imported from the TRANS-
FER-type file. 
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Import the record data
Selecting this option gives you three more 
choices before you import data. AudBase uses 
the required internal ID fields that are always 
included in the TRANSFER type document to 
search for an existing record in the data file. 
The three options differ in how they affect 
existing records:

• Replace without warning: This will 
update the data fields in existing records 
with the imported data without warning 
the user.

• Replace with warning: This will warn the user before each update is performed. 
The user can choose to skip that record or update it accordingly. The displayed con-
firmation dialog will include the required internal ID fields for that record.

• Do not replace: This will leave any existing records untouched.

If no existing record is found, AudBase creates a new one and populates it with the 
imported data fields.

Note: If the TRANSFER type document does not include the actual record data, the 
Import the Record Data button will be disabled.

For more information, see “Exporting and Reporting” on page 88 and “Exported records 
and required internal ID fields” on page 174, as well as the AudBase Clinical Trials man-
ual. For an example of the tab-delimited text file, see“Checksum Reports” on page 184.

A Grouped Export is an export that comes from more than one table. A series of TRANSFER type 
documents are created with the records from each table included in the Grouped Export. All of the 
TRANSFER documents will be placed in a folder that you select when they are created. You must 
keep these documents together for importing by the Import a Grouped Export function. Otherwise, 
you will see an error message. Since each one of the documents in a Grouped Export is a standard 
TRANSFER type export document, you can open them individually by selecting the Import\Export > 
Import TRANSFER Doc menu item.

When you send the export documents via e-mail, AudBase saves a backup copy of each document 
in the OTBEC folder on your computer. The location of this folder is always available by looking in 
the File Info tab of the About AudBase dialog (from the Home Window Menu bar, Help > About Aud-
Base). The folder will be automatically named for the date of the mailing, for example '4_21_2001' to 
signify April 21, 2001. 

Note on the location of files used in a Grouped Export



146 ·  AUDBASE

Audbase.book  Page 146  Thursday, May 4, 2006  10:04 PM
Exporting a Grouped Export
For the purposes of sharing data in a 
clinical study, you can create a group 
of related records or subsets of their 
data fields pertaining to the study, and 
then export this data. This simplifies 
exporting for users in a clinical study 
and helps to ensure that fields for the 
study are valid and complete. You 
define the data fields that make up a 
Grouped Export using the Preferences 
form (see “Export/Grouped Export” on 
page 118) and then assign the Grouped 
Export to a Clinical Group. For more 
details on this process, see the AudBase Clinical Trials manual.

Selecting the Export a Grouped Export item on the administrator menu bar opens the form 
called Clinical Groups with Defined Exports.

The form displays a list of all Clinical Groups. If you double-click on one of the groups, 
AudBase will execute the predefined searches for the records to be exported. In addition 
to selecting the appropriate Clinical Group for export, you can choose to export just the 
checksums without the actual data.

If you select the Checksums option, AudBase will export the checksums in a TRANSFER 
type document.

Selecting the Records option will add the records that make up a Grouped Export to a set 
of previously exported records. If you try to export the same records, you will see an Alert 
dialog reminding you that the records have already been exported (“There are no new 
records to export”). To export these records again in the future, open the Clinical Group 
form and select the Clinical Group > Erase Grouped Export Set menu item.

If the Clinical Group was designated as a study and if an encryption key pair has been 
assigned to the study, the export files will be encrypted automatically. In addition, if a 
study participant ID was assigned, it will be substituted in all ID fields (see “Assigning the 
Participant ID” on page 7).

When exchanging TRANSFER documents between platforms 
(for example, Windows to Mac), the normal Open dialog may 
not show the file you are looking for. In this case, hold down the 
Shift key when you select Import/Export > Import TRANSFER 
Doc. This will force the Open dialog to display all files.

Special 
note on 
Windows 
vs. Mac
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Importing a Grouped Export
Selecting Import a Grouped Export on the administrator menu bar will open a dialog that 
asks you to choose an import method, either Disk File, Disk File from E-mail, or E-mail. 
Depending on your choice, you will either browse to a folder containing the Grouped 
Export documents, or be asked to enter your password for your AudBase e-mail connec-
tion. For more information, see the AudBase Clinical Trials manual.

If you choose a Grouped Export document and all of the associated disk documents are in 
the same folder together, the Import GroupedExport form displays (see“Importing 
TRANSFER documents” on page 144 for information concerning the different options on 
the form, and a note about opening files saved in a different operating system).

If you select either of the two Checksum Info options on the Import GroupedExport form, 
a tab delimited text document will be generated for each of the Grouped Export TRANS-
FER documents and placed in the same folder with the Grouped Export’s TRANSFER 
documents.

For more information see the AudBase Clinical Trials manual.

Encrypting a TRANSFER document
To ensure the security of clinical data being shared by disk, e-mail or networked comput-
ers, as well as for verification purposes, AudBase allows you to encrypt TRANSFER doc-
uments and generate an encryption key that the person importing your data can use for 
decryption. AudBase will manually encrypt a TRANSFER document when you select this 
menu item. For this function to work, the Clinical Group you are encrypting the document 
for must be designated as a study by checking the appropriate box on the Clinical Group 
form. You must also have generated a private (encryption) key for the group (see “Study 
Export” on page 34). For more information, see the AudBase Clinical Trials manual.

To encrypt a TRANSFER doc

1. From the administrator menu bar, click Import/Export > Encrypt TRANSFER 
Doc.

2. Select the TRANSFER document 
you want to encrypt.
A Select From List dialog appears 
with the names of Clinical Groups 
that have been designated as studies 
and have private (encryption) keys.

3. Click the appropriate group name on 
the list, and click OK.
The encrypted document will 
replace the unencrypted copy.
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Note: Study Participant IDs are not substituted during a manual 
encryption. This only occurs as part of an automated Clinical Group 
export.

Decrypting a TRANSFER document
An encrypted TRANSFER document can be manually decrypted using the Decrypt 
TRANSFER Doc item on the administrator menu bar. First, a standard dialog will be pre-
sented to let you select the TRANSFER document to be decrypted.

The encrypted TRANSFER document includes information that is used to select the 
proper decryption key. The decryption key to be used is identified by:

• The Clinical Group’s List Name, which should be unique for all the participants in a 
multi-site trial.

• The study participant’s ID.

The decrypted document will replace the encrypted copy. For more information, see the 
AudBase Clinical Trials manual.

Decrypting Grouped Exports
The Decrypt a Grouped Export menu item on the administrator menu bar allows you to 
manually decrypt a Grouped Export document set. Decrypting is mandatory for Grouped 
Exports saved to disk, whereas e-mailed documents are automatically decrypted after 
downloading and conversion. Choosing the Decrypt a Grouped Export menu is item will 
open a standard dialog allowing you to select one of the TRANSFER documents to be 
decrypted. For more information, see the AudBase Clinical Trials manual.

The decrypted documents will replace the encrypted copies.

If a disk document(s) you are trying to encrypt or decrypt has 
been exported by a Windows computer and is being imported 
on a Mac, you must hold down the Shift key when you select 
one of the three encrypt/decrypt menu items. Otherwise the 
document(s) will not appear in the “Open File” dialog box.

Special 
note on 
Windows 
vs. Mac
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Export Lists menu item
The Export Lists menu 
item allows the admin-
istrator or a subadmin-
istrator to view 
modifiable lists to ver-
ify their current con-
tents. You can choose to 
save the lists to a disk 
document, or print 
them. This is the same 
function available by 
selecting Reports > 
Modifiable Lists menu 
item attached to the 
Home Window. It is here for convenience and proximity to the Import Lists menu item on 
the administrator menu bar.

Importing lists
Two types of modifiable lists exist:

• “Central” lists that are saved as part of the database structure file (identified by a 
“©” in the list of modifiable lists). Distributing a copy of the database structure file 
would include these lists. It is important to recognize that there are only a limited 
number of central lists in the structure file.

• Lists stored as LargeObject records in the data file.

 A list can be created or modified in a word processor or a spreadsheet program and saved 
as a text document. The list can then be imported and interpreted by AudBase. These lists 
can be replaced by importing updated versions.

Note: In the case of a list in a LargeObject record that is being shared by a multi-center 
clinical study, the originator of the list should use the Import\Export > AdminOnly 
Export function to export the list as a TRANSFER type document. The resulting file 
can then be distributed and imported in a more efficient, error-resistant fashion using 
the Import TRANSFER Doc item on the administrator menu bar (see “Importing 
TRANSFER documents” on page 144). It can also be encrypted/decrypted.
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Each item in a list must have a unique reference number. Lists can be imported with or 
without special item references. If item references are not included in the imported text 
file, AudBase will generate a unique item reference for the list item. The item reference 
number is a long integer (+/- 2,147,483,647). This allows the creation of special lists that 
include item numbers such as CPT codes in the tumor surgery list .

TEXT documents being imported must follow a predetermined format. The first line of 
the TEXT document must include the name of the list by itself (“ProcedureList” in the 
example above). In the case of multiple version lists the first line includes the “ListFami-
lyName$ListName.” The second line must be blank. Place the first list item on the third 
line of the text file. Put one tab before sublist items (in the “Procedure List” example 
below, the sublist items are Sublist Item 1, Sublist Item 2). The second sublist item has its 
own sub-sublist (Sub-Sublist Item 1). Precede sub-sublist items with two tabs. You can 
define up to six levels of sublists. The name of the list and any list items can be up to 255 
characters in length. The example list on page 150 includes CPT codes for the list items. 
The CPT codes are preceded by a single tab separating them from the list item’s text.

ProcedureList ProcedureList w/ CPT codes

List Item 1 Thyroid Gland 1
Sublist Item 1 Partial 60210
Sublist Item 2 Secondary 60260

Sub-Sublist Item 1 Total 60240
List Item 2 Thyrotomy 31300

Sublist Item 3
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To import a new list

1. After creating a list, select Import/Export > Import List from the administrator 
menu bar.

2. Specify where the list is to be saved by choosing “As a central list” or “As a data-
base record” from the dialog.

3. From the same dialog, choose whether the list 
includes item references.

4. Click OK and an Open dialog displays allowing 
you to select the text document containing the 
new list for import.

5. Verify whether the list replaces an existing list.

For more information, see “Modifiable Lists” on 
page 181.

Creating a User Privileges Report
AudBase provides you with an easy way to keep track of user privileges to view, write or 
create new records. By selecting the User Privileges Report item on the administrator 
menu bar, you can create a report that lists the access privileges for one or more users, and 
save the report to a file on your computer.

To create a User Privileges Report

1. With the administrator menu bar on your screen, 
select Import/Export > User Privileges Report to open 
a Search for Providers form.

2. Select which users you will create a report for. You 
can create a set of all providers by shift-double-click-
ing on the Create New Set item in the Provider table list. Or, build a more specific 
search by double-clicking on the Create New Set item and using the New Query 
form.

3. Drag the search set to the orange Drop Selected Provider Set box at the bottom of 
the form.

4. From the Save As dialog, browse to a location on your computer where you’d like 
to save the report, give the file a name, and click Save.

The resulting tab-delimited text file shows users’ names, their login names for the data-
base, and their levels of access.
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Database Structure Menu item
Information on all the data fields in the database can be saved to a file on your computer 
or printed by selecting this menu item on the administrator menu bar. You can find this 
same information in the appendices.

Clean Ups Menu items
The Clean Ups Menu is mainly focused on performing house-
keeping chores that may be occasionally necessary in a multi-
user environment. Two items, Export for Upgrade and Import 
for New Version, are important for saving central modifiable 
lists and other customized items when you switch to a new ver-
sion of AudBase. Here is an item-by-item look at the Clean 
Ups menu:

Deleting LargeObject records
The LargeObject table in the database stores some user modifiable items such as multiple-
version lists. Large Object records are not directly accessible to the database user. If it is 
necessary to delete LargeObject records, an administrator can select and delete them using 
the Clean Ups > Delete LargeObject Recs item on the administrator menu bar.

Updating subject sets
Subject sets are Saved Sets that AudBase uses to define the user’s access to subject 
records. These sets are updated every time a Subject record’s Provider(s) and/or Clinical 
Group(s) are modified. It is extremely rare that such a set will not be updated. If you click 
Clean Ups > Update Subject Sets from the administrator menu bar, AudBase will check 
the sets, update them as necessary and display statistics on the updating for the administra-
tor.

Updating searches and exports
AudBase checks Saved Searches, Sequential Searches, Saved Exports and Grouped 
Exports for validity each time you use them. Selecting the Clean Ups > Update 
Searches\Exports menu item on the administrator menu bar lets you update all searches 
and exports at the same time. This is especially useful if major changes have been made in 
the database since the last time any of these searches or exports were used. AudBase will 
continue to update all searches and exports individually when you use them; this menu 
item just gives you the convenience of updating them with a single click.
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Clearing unconnected records
The Clean Ups > Clear Unconnected Recs item on the admin-
istrator menu bar is only available to the administrator. Uncon-
nected records are created when someone deletes a record 
while another user has locked an associated record in Read 
Write mode. For example, someone may delete a Subject 
record while one of the subject's Tumor_Description records 
was locked and thus could not be deleted. In this case, the 

Tumor record would no longer have a Subject record to connect with.

This option must be used carefully if the data file includes records imported from partici-
pants in a multi-site clinical study. In this case, records may have been imported for the 
purposes of the study that are not connected to a Subject record in the data file. By default, 
this function will avoid deleting these unconnected records as long as the Participant IDs 
for the different study sites are all unique.

After selecting Clear Unconnected Records, you can remove all unconnected records for:

• This participant only
• All participantsFor more information, see “Assigning the Participant ID” on page 7 

and “What makes up an internal ID number” on page 176.

Execute All Clean Ups menu item
You can execute three of the Clean Ups menu items, Update Subject Sets, Update 
Searches\Exports, and Clear Unconnected Recs, by selecting the Clean Ups > Execute All 
Clean Ups menu item on the administrator menu bar. AudBase will perform the functions 
in that order.
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Exporting items before upgrading versions
The Export for upgrade item on the admin-
istrator menu bar allows you to export all 
central modifiable lists and other customiz-
able items. These lists are stored in the 
database’s structure file, which is replaced when you upgrade to a new version of Aud-
Base. When you select this item, a special document is created in a special AudBase 
folder called OTBEC on your computer. To find this folder, with the Home Window or 
Subject List on your screen, click Help, then click on the File Info tab of the About Aud-
Base form. The box under AudBase directory will show you the location of the OTBEC 
folder.

Note: If you work on a networked computer system you may not have access to the 
OTBEC folder. If this is the case, contact your network administrator.

For steps to follow in exporting these lists before an upgrade, see “Upgrading to a new 
version of AudBase” on page 157.

Importing items for a new version
Selecting the Import for a new version item on the administrator menu bar lets you import 
central modifiable lists and other customizable items from an older version of AudBase-
For steps to follow in importing these lists before an upgrade, see “Upgrading to a new 
version of AudBase” on page 157.

Web Server menu item
If your are using the standalone version of AudBase that has Web server capability, you 
will see the Web Server on the administrator menu bar. This item allows you to start and 
stop the Web server. If you have Web server capability, you can set an IP address and port 
through the Preferences form.

If you are using the AudBase Server, you will not see this option since the Web settings 
are controlled by 4D Server. The Web Server menu appears in the 4D Server menu bar. 
You can set the IP address and port number through File > Database Parameters. For more 
information, see AudBase.
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Deleting records
By default, the administrator is the only 
one who can delete records in AudBase. 
He or she can extend the privilege to sub-
administrators. The administrator can also 
allow all users to delete Reminder records. 
For directions on changing the default 
delete privileges, see “Setting global read/
write privileges” on page 115. 

To delete records, use the menu item that 
goes along with the form you are using (for example, Subject > Delete Subject, Tumor > 
Delete Tumor Record). The Provider and ClinicalGroup forms have delete buttons on the 
associated list while Reminder records have a button on the form.

Reminder records are handled individually or in a group. In each case you will be asked to 
confirm your choice prior to deleting; once you’ve deleted a record it can’t be recovered. 
If you delete a record, all related records will also be deleted. For example, deleting a sub-
ject record would automatically delete that subject’s tumor records, etc.

You can delete multiple subjects by using the Subject List form. Select a group of subjects 
for the “User Set” then click the Subjects > Delete Subject menu item.

Marking complete records
An important part of managing a database is 
checking to make sure that records have been 
completely filled-in. AudBase simplifies this 
process by allowing administrators to create 
data entry checklists that scan for complete-
ness whenever users try to save a record. In cases where checklists are optional, adminis-
trators can set up saved searches to find all incomplete records. They can then use the 
built-in Internal Mail or e-mail to send reminders to people who should complete the 
records.

However, sometimes a record is as complete as it will ever be and the data manager will 
want to exclude it from a search for incomplete records. To mark a record as complete, the 
administrator can use the Completed checkbox on many of the forms in AudBase. Check-
ing this option adds a “true” value to the Boolean field called Completed_Record in the 
respective table, allowing you to exclude these records from a search.
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Assigning passwords
The administrator can change a user’s login password, as can the user. Only the adminis-
trator can add, remove or modify the login names for users and add or remove users from 
the subadministrators group. While subadministrators can add provider records, only the 
administrator can enter a login name for them or assign their first password. To add a new 
user, the administrator should select the New button on the Provider List form.

The administrator will need to enter a first name and last name. A login name also must be 
entered if the provider is to be given login privileges or be added to the subadministrators 
group. Upon saving a new provider record, the administrator will be asked to assign a 
login password. Granting of all other database privileges can be left to a subadministrator 
with the exception of the subadministrator’s group privilege. The administrator can desig-
nate a provider as a subadministrator by selecting Sub Admin on the Provider form. 

To permanently remove login privileges for a user, the administrator should delete the 
user’s provider record. As a temporary measure, the administrator can change the user’s 
password. 

For more information, see “How privileges and access are controlled” on page 7  and 
“Entering Provider data” on page 18.

Dividing large data files
Data files can become very large, especially with the storage of picture information. There 
are practical limits to the size of files and it is recommended that data files be segmented 
as they approach 2 Gigabytes in size. Segmentation expands the practical limits by split-
ting data into multiple files. This process is transparent to the user of the database and data 
is handled as if it belongs to a single data file. Segments can be added using the Add data 
file segment button on the second tab of the About dialog (Help > About).

For a quick way to locate the data and structure files on your computer, with the Home 
Window or Subject List on your screen, click Help. The About AudBase form appears.
The second tab of the form lists the complete path names of the structure file and the data 
file. In addition, administrators can access the Add data file segment button. For further 
information on creating new segments please refer to the 4D_Supplemental_User_Ref.pdf 
manual included on your installation CD.
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Switching data files
The first time you open AudBase, the program may ask you to find your data file. Once a 
data file has been assigned you are not normally asked again unless AudBase cannot find 
the file because it has been moved. For more information on data files, see “Working with 
data files” on page 4.

To switch to a different data file

1. Launch AudBase.
2. After entering your login and password, hold down the Option key on a Mac or 

the Alt key on Windows when clicking the Connection button.
3. From the Open file dialog, browse to the data file you wish to substitute, and click 

Open.
‘File not found’ errorOccasionally when the folder structure on your computer has 
been modified, AudBase will have trouble finding your data file and may display a “File 
Not Found” dialog box giving you no option but to quit the program.

If that happens, log in again and follow the same procedure as shown in “Switching data 
files” on page 157.

Upgrading to a new version of AudBase
Before installing a new version and connecting it to your old data file, you may wish to 
import all central modifiable lists and other customizable items from your old version, 
especially those you have changed. Because these lists are stored in the structure file, 
which will be replaced by the new version, you need to export them from the old version 
to a file on your computer, then import them into the new version. 

Make a backup copy of your data files before
converting to a new version of AudBase. Caution:
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Exporting/importing modifiable items

To move modifiable lists into a new version 

1. In your current version of AudBase, switch to the administrator menu bar (Data 
Manager > Administrator Menu Bar), then select Clean Ups > Export for 
Upgrade.

2. Read the Confirm dialog, then click OK.
An Alert displays, telling you that an export file has been created. This file con-
tains all the central modifiable lists. The Alert also shows the location of the file 
on your computer (for example, C:\WINNT\OTBEC\file name.TMP).

3. Click OK.
4. Install the new version of AudBase (see 

“Installing AudBase” on page 2).
5. From the administrator menu bar in the new 

version, select Clean Ups > Import for New Version.
6. Read the Confirm dialog, then click OK.

A Lists to be Imported dialog appears.
7. Click OK.
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AudBase Server
AudBase is a flexible solution that can be used over a network so multiple users can 
access the same data file. The AudBase Server contains all the features of the standard 
version of AudBase but also allows you to run the program in a client-server environment. 
Therefore, if you install the AudBase Server, you do not have to install the standalone ver-
sion of AudBase. 

AudBase Server integrates a database server engine called 4D Server which is a product 
of 4D Inc. (www.4d.com). AudBase Server is cross-platform, which means you can install 
the server on either a Windows or Macintosh and it will easily communicate with clients 
on both operating systems.  Prior to using AudBase Server, you must first obtain and 
install the Runtime Server License from 4D along with AudBase licenses from Sienna 
Software Inc (www.SiennaSoftwareInc.com). The 4D Runtime Server License comes 
with two concurrent client licenses.  You may install clients on as many machines as you 
wish, but the number of clients that can be logged in at the same time depends on the num-
ber of licenses you have. If you wish to have more than two clients logged in at the same 
time you should purchase additional concurrent client licenses from 4D and Sienna Soft-
ware

This chapter explains how to install and get started with AudBase Server. Instructions on 
installation are available for both Windows and Macintosh in addition to general informa-
tion for both platforms.

The installation and configuration of the server should be performed by a network admin-
istrator who can set-up the proper folder privileges for the AudBase installation. Keep in 
mind that a user who has administrator privileges for a machine or a network is not neces-
sarily the same person as the AudBase administrator.

Installing AudBase Server
Installing AudBase Server on the server machine will enable client machines to connect 
remotely. In this section you will learn how to install and configure AudBase Server for 
Windows and Macintosh.

System requirements
To use AudBase Server, you need the following:

• 70 MB of available hard-disk space for installation of AudBase Server 
• CD-ROM drive

When establishing a client/server environment for AudBase, you will need to install the 
following software.

1. For the server machine:
• AudBase Server
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• 4D Write (optional, a 4D license is needed)
2. For the client machine:

• AudBase Client

Note: If this is a upgraded version installation, remember to back up your data file(s) 
before proceeding further.

To install AudBase Server for Windows

1. Insert the AudBase CD in the CD-ROM drive.
2. Browse to your computer’s CD drive using Windows Explorer or My Computer.  

Open the AudBase Server folder.
3. Double-click on the Setup_SVR file.

An install dialog appears.
4. Click Yes indicating you want to install AudBase.

A wizard opens to guide you through the installation.

To install AudBase Server for Mac

1. Insert the AudBase CD in the CD-ROM drive.
2. Browse to your computer’s CD drive.
3. Double-click the AudBase Server Install  file.

An install dialog appears.
4. Click Yes indicating you want to install AudBase.

A wizard opens to guide you through the installation.

Note: In order for AudBase Server to run properly, it is necessary for the folder with all 
AudBase files to have Read/Write access for itself.  In addition the folder with the data-
file must also be Read/Write accessible for AudBase Server.  AudBase Server will also 
setup a series of folders in the ....\Application Data folder on Windows or the   
....\Library folder on Mac.  These folders include a 4D folder and an OTBEC folder 
which contain the respective licenses. IMPORTANT: The desired default directory for 
AudBase application data on Windows is the 'System Drive\Documents and Settings\All 
Users\Application Data\'  and on Mac is the "System Drive\Library\Application Sup-
port\" common user folder.  If the common user folder is locked AudBase will try to 
make use of the current system user's folder.  This is not optimal because the licenses 
and other common documents may not be available to all system users who use Aud-
Base. The best solution is to give AudBase server and standalone installations access to 
the common user Application Data or Application Support folder.  4D Client installa-
tions since they do not require local machine licenses will make use of the current  sys-
tem user's folders.

Note: To see a list of files installed with AudBase, see Appendix A, “Installation Files,” 
on page 194.
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Running AudBase Server

1. Browse to the AudBase Server. folder
2. Double-click on the AudBase Server executible file.
3. When a dialog prompts you to find the AudBase data file, do one of the following:

• If this is your first time working with AudBase, we highly recommend that 
you use the Example Data file. Find it in the AudBase root directory in the 
Example Data folder.  You may create a new data file at anytime in the future 
by simply moving the current data file or renaming it. You will get the Find 
Datafile dialog again and can click on the New button.

• If you wish to create a new data file, click New, choose a name for the new 
file and click OK. 

• If you wish to use an existing data file, browse to the file and click OK.
Encrypted connections in a client/server environment

In order to increase the security of your connection, you can stipulate that clients only access the 
server over an encrypted network. Establishing an encrypted connection is highly recommended to 
maintain the security of your data.   Encryption is turned on in the server by going to the Edit > 
Preferences menu item on WIndows or File > Preferences menu item on Mac within AudBase 
Server.  Select the Client-Server/Publishing list item on the left to display the proper page and then 
select the Encrypt Client-Server Connections checkbox.

Note: Encrypted connections may slow down the communication between server and client.
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Using 4D Write
Some of AudBase’s features, such as generating 
reminder letters, are enabled by a built-in word pro-
cessing program called 4D Write. The 4D Write 
license is included in standalone versions of AudBase. 
In a client/server environment, if you wish to use 4D 
Write you can purchase a license from 4D. 

To install a license for 4D Write

1. Run 4D Server.
2. With the server running, select Help > Update 

Licenses.
3. A dialog appears, enter the expansion number 

and click OK.

Configuring the client machine
The AudBase Client installer programs run just like the server installer programs do (see 
“Installing AudBase Server” on page 160). The AudBase Client software must be 
installed on each client machine that is connecting to the server. You can install the Aud-
Base client on as many machines as you like, but the number that can be connected to the 
server simultaneously depend on the number of licenses you have.  Install the AudBase 
Client folder in  the ....\Program Files directory on Windows or the ....\Applications direc-
tory on a Mac.

To connect to the server for the first time

1. Double-click on the AudBase Client 
executible file and a dialog will 
prompt you to select a server to con-
nect to.  Since this is the first time 
you are using the client no servers 
will be listed under the Recent tab. 

2. If the server you wish to connect to 
is on the same network subnode, 
then AudBase Client should auto-
matically detect the server and dis-
play its name on the TCP/IP tab. Just 
double-click the server name.

3. If the server is not visible you must 
tell AudBase Client where the server 
is this first time.  After you have 

4D Write and the server
In a client/server environment, 4D 
Write is installed on the server 
machine and you must purchase a 
license if you wish to use these fea-
tures. If you do not have a license for 
4D Write, an alert appears stating 
that the 4D Write plug-in requires an 
expansion number. If you do not 
wish to install 4D Write, just dismiss 
the alert.

You can permanently dismiss the 
alert by removing the 4D Write files 
from both the Win 4Dx and Mac 4Dx 
folders. 
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logged into it once the server’s name will be added to the Recent tab and you will 
be ableto select it just by double-clicking on it.  

•Go to the Custom tab.
•Type in a nickname for the server which will 

be used in the Recent list to identify it (e.g. 
MyAudBase).

Note: for encrypted connection names 
see the next section

•Enter the IP address for the server computer 
and click OK.  The login dialog should 
appear. Enter in your user name and pass-
word

Connecting to an encrypted server

If the server you are connecting to is encrypted 
(see “Encrypted connections in a client/server environ-
ment” on page 162E, a caret (^) needs to precede the 
server’s name.

This indicates that the server is encrypted and the client will 
know to choose the proper protocol to login. Encrypted serv-
ers located on your network subnode will automatically dis-
play the caret in their nicknames.

To manually connect to an encrypted server

1. Next to Name, type in a nickname for the server you are looking for, including an 
asterisk, such as ^MyAudBase.

2. Enter the IP address for the computer running the server.
3. Click New.
4. When the server appears in the list, double-click the server name. 

Using AudBase Server in a cross-platform environment
The following section will give you a better idea of how AudBase works in a networked 
environment.
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Using a cache system
AudBase Server interacts with clients using an efficient disk cache system. A cache 
allows you to download and store frequently used files in order to speed up connec-
tion times. 

As a client, when you connect to AudBase Server for the first time a number of 
resource files are downloaded immediately and cached, or saved, on your computer. 
As long as these resources remain the same on the server you do not need to download 
them again. Each time you request a new file from the server, it is downloaded and 
cached for future use. As you continue to use AudBase and your cache files increase, 
your communication with the server consists mainly of just record data. You will 
notice a significant increase in the speed of AudBase’s data entry and display. 

Processing information in a cross-platform environment
Since AudBase Server can handle both Mac and Windows clients, the cached files on 
the client-side must be compatible with the client’s platform. 

The AudBase Server structure file contains code for both client platforms. Likewise, 
plug-in documents such as the MDC_Audiotools must be in both Mac and Windows 
formats. 

After installing AudBase Server, you may note that there are two folders for plug-in 
files: Mac4DX and Win4DX. Although these plug-in files may have similar names, 
they are not the same. Be sure not to delete or combine these folders. 

Upgrading to a new version of AudBase Server 
Upgrading to a new version of AudBase Server is similar to upgrading the stand-alone 
version of AudBase. Please refer to “Upgrading to a new version of AudBase” on 
page 157 for details. AudBase Server requires the administrator to have access to a 
client machine for two functions: Export for Upgrade, which is run before upgrading 
AudBase Server, and Import for New Version, which is run after upgrading AudBase 
Server. "For this purpose you can run AudBase Client from the same machine the 
AudBase Server is on.

Note: The AudBase administrator should perform the upgrade to a new version of 
AudBase Server.
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AudBase Server Backup
Data backup is a critical function.  AudBase Server has a number of ways to backup the 
data including the use of log files to allow for data restoration between scheduled data file 
backups. To configure the backup options go to the Edit > Preferences menu item on Win-
dows or File> Preferences menu item on Mac within AudBase Server.  Select the Backup 
list item on the left. There are four pages devoted to configuration of the backup.  For fur-
ther details consult the 4D Server manual.

AudBase Server Service Registration
To further automate AudBase Server you should 
register it as a “service” of your operating system, 
Windows or Mac.  As a registered service AudBase 
Server will be automatically restarted in case of a 
system crash. To do so go to the File > Register Cur-
rent Database As Service menu item.

AudBase Server Routine Main-
tanance
AudBase Server requires little in the way of configuration or on-going support. As with all 
programs which run for extended lengths of time, it is prudent to restart the program every 
few months to clear out memory and increase the program’s efficiency.
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Database Design and Theory
To get the most from the data gathering, exporting and reporting capabilities of AudBase, 
it helps to understand a few design considerations.

AudBase was written using 4th Dimension, a relational database development system 
available from 4D, Inc. AudBase is a complete software package with no need for addi-
tional software when used in a stand-alone implementation. Additional capabilities, such 
as a multi-user client-server system and interfacing with other databases (for example, 
ORACLE or SQL servers), can be added through software packages that are available 
through 4D, Inc. (www.4d.com). For more information on client-server applications, see 
Chapter 8, “AudBase Server” on page 160.

During the development of AudBase a considerable amount of thought went into the orga-
nization of the data. The biggest weakness of some databases is the difficulty of retrieving 
information. This can be due both to poor relationship structure (for example, the inability 
to relate two disparate pieces of data because the potential relationship was not recognized 
at the time the database was developed) and the incompatibility of the exported data with 
other programs, such as statistical software. AudBase attempts to solve these shortcom-
ings, and this chapter will describe some of the essential elements of its structure.

Note: Some of the examples in this chapter are based on a version of AudBase used to 
study tumors.

Table structure
The illustrations on the next three pages show:

1. The entire structure of AudBase
2. A close up of the structure of the provider/Clinical Group/reminder section
3. A close up of the customized data section.

Please refer to the schematics as you read this section. Lines connect related tables. The 
arrows point from the “many” table to the “one” table (see: “Table relationships and 
design philosophy” on page 173 and “Merging documents with data fields” on page 174).
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Complete subject-related table list
In AudBase, the complete subject-related table structure that is normally accessible to the 
user consists of a number of tables, listed below:

Kernel
• ClinicalGroup
• Provider
• Reminder
• Subject

AudBase tables
• Audiogram
• SAT_SRT_WordRecognition
• Tympanogram

AudBase uses three additional tables internally as “bridging” tables: SubjectProvider, Pro-
viderGroup and SubjectClinicalGroup. Under normal circumstances users do not access 
these tables directly (see “For administrators and subadministrators only” below).

For administrators and subadministrators only
Six additional tables are not accessible to the typical user: two subject-related tables (Sub-
jectProvider, SubjectClinicalGroup), a provider/Clinical Group-related table (Provider-
Group) and three tables with no direct relationships (LargeObject, Constants and Saved 
Sets).

The tables SubjectProvider and SubjectClinicalGroup are not accessed directly for any 
normal needs. They are “bridging” tables that relate two tables with a relationship more 
complex than a simple Many-to-One.

For example:

A Subject record can have more than one Provider. Likewise a Provider record can have 
more than one Subject. 

Provider                  SubjectProvider                  Subject
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The “bridging” table, ProviderGroup, tracks Group Administrators (see “How privileges 
and access are controlled” on page 7). This table creates a circular relationship path that 
requires special handling when searching (see “Performing administrator-only searches” 
on page 141).

Table relationships and design philosophy
Table relationships are typically referred to as Many-to-One or One-to-Many. The arrows 
in the database structure illustrations represent the relationships between tables with the 
arrow pointing to the “one” table. Records in all of the subject-related tables relate to a 
single Subject record. It can be said that these tables have a Many-to-One relationship 
with the Subject table either directly, for example:

or indirectly. For example, in a tumor database, an indirect relationship exists for a tumor 
treatment and a subject.

Some of these tables can have multiple records for each Subject record. For example, a 
subject can have many Reminder records and several Audiogram records, since they can 
have multiple audiograms. Other tables are limited to a single record because of design 
philosophy:

In a medical database, each Subject record has only one Social_Habits record tracking 
smoking and alcohol history. The design philosophy is that Social_Habits data is cumula-
tive and should be updated (for example, total number of years smoking).

Provider                  Provider Group                

Clinical Group

Reminder                    Subject                

TumorChemotherapy_Description                  Tumor_Description                     Subject

Social_Habits              Subjects
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Merging documents with data fields
In order to use information from AudBase in documents such as letters and reminders, it 
helps to understand two general relational database concepts referred to as the Related 
Many table and the Related One table.

Consider this example from a tumor database: a subject can have many tumors and a 
tumor can have many chemotherapy treatments attached to it. With respect to the 
Tumor_Description table, the Subject table is the Related One table (one subject per 
tumor) while the TumorChemotherapy_Description table is the Related Many table (many 
chemotherapy treatments per tumor). Seen from the TumorChemotherapy_Description 
table’s perspective, both the Tumor_Description table and the Subject table are Related 
One tables (for each TumorChemotherapy_Description questionnaire there is only one 
tumor and one subject). In the table structure illustration, the arrows point toward the 
Related One table in each relationship. 

When you search the database to create sets of records, the Search form handles the 
nuances of these relationships without your need to know except in one instance: Docu-
ments with embedded data fields that will be merged with the data from the records in the 
search set.

Let’s say you have a letter with fields from the Tumor_Description table (for example, pri-
mary site) and the Subject table (name, address, etc.). If you were to select a set of Subject 
records and use the Reports > Print Any Document menu item to print them, AudBase has 
a dilemma: Some subjects have multiple tumors, and which tumor record do you choose 
to fill in the primary site field value? In this case you should use the Tumor_Description 
set to print from instead of the Subject set, since each Tumor_Description record only 
relates to one Subject record.

Exported records and required internal ID fields
When exporting records it is usually necessary to uniquely identify the records. Most 
tables in AudBase have required internal ID fields to accomplish this. Exported records in 
a TRANSFER or CHECKSUM type document automatically include the required internal 
ID fields whether or not the Saved Export document specified them (see “Exporting and 
Reporting” on page 88 and “Importing TRANSFER documents” on page 144). In the case 
of TEXT type export documents, you must explicitly include these fields to be able to 
uniquely identify the exported record data. The following fields are the required internal 
ID fields for exported records:

This group requires two internal ID fields, but has no unique record identification:

TumorChemotherapy_Description                  Tumor_Description                     Subject
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Kernal
• [Reminder]Subject_ID, [Reminder]Provider_ID

Version-specific
AudBase

• None
This group requires one internal ID field for unique record identification:

Kernal
• [ClinicalGroupClinical]Group_ID
• [Constants]Constant_Name
• [Subject]Subject_ID
• [Provider]Provider_ID
• [Saved Sets]Set Name

Version-specific
AudBase

• None

This group requires two internal ID fields for unique record identification:

Kernal
• [LargeObject]LargeObject_ComboID, [LargeObject]LargeObject_SubID
• [SubjectClinicalGroup]Subject_ID, [SubjectClinicalGroup]ClinicalGroup_ID
• [SubjectProvider]Subject_ID, [SubjectProvider]Provider_ID
• [ProviderGroup]Provider_ID, [ProviderGroup]ClinicalGroup_ID

Version-specific
AudBase

• [Audiogram]Subject_ID
• [Audiogram]Audiogram_No
• [SAT_SRT_WordRecognition]Subject_ID
• [SAT_SRT_WordRecognition]SAT_SRT_WordRec_No
• [Tympanogram]Subject_ID
• [Tympanogram]Tympanogram_No

This group requires three internal ID fields for unique record identification:

Kernal
• None

AudBase
• None
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What makes up an internal ID number
AudBase internal ID numbers identify and relate records in different tables. The Partici-
pant ID number, assigned when you first create a new data file, is part of the internal ID 
numbers see “Exported records and required internal ID fields” on page 174). The follow-
ing discussion about the Subject_ID applies to all uses of internal ID numbers in Aud-
Base.

All subject-related records have a 
Subject_ID field that uniquely identifies 
the subject the record relates to. The 
internal Subject_ID number is a long 
integer (+/- 2,147,483,647). The first 3 
digits of the Subject_ID have been 
reserved for the Participant ID number. 
The Participant ID number, which is set 
the first time the database is used with a 
new data file, is a number between 0 and 
999. It in turn is used to set the first 3 
digits of any new Subject_ID.

Note: If you are running a consortium 
study and are dealing with independent 
sites for data collection, make sure all 
the participating sites have been 
assigned their own Participant ID for the purposes of this study. This way when the data 
is pooled all Subject_ID numbers will be unique for all study participants. This is also 
true for all similar ID numbers.

Other internal ID numbers are constructed in the same way as the Subject_ID to uniquely 
identify records where Subject_ID is not sufficient.

Default field lengths for text exports
You can export data in a text document using the 
Fixed field size option to separate each field value, 
rather than using field delimiters such as tabs or 
commas (see “Exporting and Reporting” on 
page 88). AudBase uses nine types of data fields. 
Two are alphanumeric (String, Text), two are 
numeric-related (Date, Time), three are numeric 
(Integer, Long Integer, Real) and two are special 
formats (PICT, BLOB). PICT and BLOB data 
fields are not exported in text documents. Of the 
remaining fields, Date and Time have a non-vari-

Viewing unique ID fields
Sometimes you may want to quickly view the 
unique ID fields in one of the tables associated 
with a data entry form. An example of this would 
be telling a fellow study participant to examine a 
subject record without your having to disclose 
the subject's name.
As the administrator or subadministrator, you 
can do this easily by holding down the shift key 
when you click on the Data Checklist item on the 
menu bar (for example, Subject > Data Checklist 
or Tumor > Data Checklist). A dialog appears 
with the name of all unique ID fields in the tables 
associated with the form that is active on your 
screen. The other study participant could then 
do a search within the table for a record with that 
ID field.
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able size. Integer, Long Integer, Real, String and Text have default sizes that you can vary 
up to a maximum size.

Table 9.1 below shows the default and maximum sizes of the various types of data entry 
fields in AudBase, noting which have variable sizes.

Table 9.1: Data field types and their sizes

Notes: 

1 Numeric fields have a maximum size that would be the size of the string needed to 
accommodate all the significant positions if they were filled (for example, an integer = 
-32767; 6 places). For Real types the maximum is 10 places to the right and 10 places 
to the left of the decimal point (10.10). The maximum size is the default size. If you 
know that the maximum field value requires fewer spaces, you can specify a shorter 
export field size. If you specify an export field length less than the maximum, any data 
value that requires more spaces will be cut off.

2 String fields in the database have a ‘declared’ length. The ‘declared’ length is the default 
size. If the data value stored in the string field is shorter blank spaces are padded onto 
the end to fill in the specified export field size. If you know that the maximum field 
value requires fewer spaces, you can specify a shorter export field size. If you specify 
an export field length less than the maximum, any data value that requires more spaces 
will be cut off.

Set theory and searching
Searches consist of multiple search query lines created by using the New Query form (see 
“Using the New Query form” on page 72).

Each query line in a search consists of a combining operator (AND {&}, OR {|}, NOT 
{#}), a data field, a comparison operator (for example, >, =, <) and the value for the com-
parison. Each search query line in effect defines a set of records that meet the criteria in 
the line (SubjectLastName contains ‘Smith’). Each search query line is combined with the 
previous line by means of the combining operator. The combining operators (AND {&}, 
OR {|}, NOT {#}) act in the same manner that the Intersection, Union and Difference 
selections do on the Combine Sets form (see Chapter 4, ‘Searching’). The results of each 
search query are combined in a linear sequence. The order of the search query lines is crit-
ical when using the OR operator. Consider the following search:

Field Type Variable size? Default size Maximum size
Date No 10
Integer Yes1 6 6
Long Integer Yes1 11 11
Real Yes1 10.10 10.10
String Yes2 Declared size Declared size
Text Yes 40 32000
Time No 8
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Line 1:   [Subject]LastName contains “Smith”
Line 2:   [Subject]Gender = 1(1 = Female; 2 = Male)
Line 3:   [Subject]Birthdate < 12/02/1955

Query line 1 by itself finds 20 records that meet the criteria.
Query line 2 by itself finds 50 records that meet the criteria.
Query line 3 by itself finds 70 records that meet the criteria.
Assume that all 20 of the Smiths are male, 10 of the Smiths were born before 12/02/1955, 
and 25 of the females were born before 12/02/1955:

The search lines are executed two at a time, from left to right.

Line 1 OR Line 2 AND Line 3: The first comparison (Line 1 OR Line 2) yields 70 
records (all 20 Smiths plus all 50 females). Next, that result is compared with Line 3 using 
AND. This search returns the 25 females, plus the 10 Smiths born before 1955. So the 
query returns a total of 35 records.

Line 1 AND Line 2 OR Line 3: The first comparison (Line 1 AND Line 2) yields no 
records, because there are no records that meet both criteria (none of the Smiths are 
female). Next, that zero result is ‘OR’d’ with Line 3. The search returns all of the Line 3 
records (all subjects born before 1955) because only one OR the other line needs to be 
true. So this query returns 70 records.

The lesson to remember from this is that an OR at the end of a search can only expand the 
number of records in the set. This tends to swamp out the careful selection that the previ-
ous query lines have achieved.

Follow these two rules of thumb:

• If possible, place all OR’d query lines at the beginning of a search.
• Don’t combine OR statements from more than one field in a search. 



TEN: DATABASE DESIGN AND THEORY · 179

Audbase.book  Page 179  Thursday, May 4, 2006  10:04 PM
Use different searches and combine them with the Intersection selection on the Combine 
Sets form. You can get the same results by executing a Sequential Search containing mul-
tiple Saved Searches for a table.

Let's use a tumor database for an example.  In this example tumor subsite involvement is 
stored in string fields consisting of combinations of three characters depending on the 
location of involvement: 'R'ight 'C'enter and 'L'eft.  When a location is not involved an 
asterix, '*', is used as a placeholder.  For example if only the center and left portions of the 
brain are involved the stored value would be '*CL'.  Using these 

&Tumor_SubsitesBrain contains “*”
|Tumor_SubsitesBrain contains “RCL” (the only combination without an ‘*’)

You can also write it without OR’d search query lines:

&Tumor_SubsitesBrain is not equal to“(<blank>)”
&Tumor_SubsitesBrain is not equal to “No”

Note: <blank> is the Not Done value, see below. 

The “Not Done/N.D.” field value
To ensure that AudBase searches produce accurate results, it is important to be able to tell 
which fields have not been filled in. The ‘Not Done/N.D.’ value is designed to solve this 
problem. For example, when describing subsite involvement in a Tumor form, there’s a 
critical difference between the following two entries:

• “No” (no involvement in this subsite)
• Field simply left blank.by the data entry person or the subsite was not examined 

(“Not Done/N.D”).

Within the database, special values are assigned to the “Not Done/N.D.” response so that 
searches can distinguish it from real data. This section will explain those values, first 
looking at two general principles that underlie the “Not Done/N.D.” value, and then 
explaining two special cases.

Note: See Appendix B, ‘Tables and Fields,’ page 196 and Appendix C, ‘Data lists and 
their stored data field values,’ on page 231 for specific information on all the data fields 
and the interpretation of their values. Special cases have comments attached to the indi-
vidual fields.
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General Principles
• For alphanumeric text and string data fields, the <blank> string value is reserved for 

the “Not Done/N.D.” value. To search for fields with the “Not Done/N.D.” value, 
you would leave the value on the New Query form blank. “No” is placed in the data 
field as a real value when selected from a pop-up. So in this case, you would search 
for “No.” For text fields not associated with pop-ups the user must place a “No” or 
‘None’ in the field explicitly. Most associated lists of values have a selectable “No/
None” value to ensure correct spelling and to prompt the user.

• For numeric data fields, the number “0” value is reserved for the “Not Done/N.D.” 
value unless “0” is a valid answer for the data field (see Special Case No. 1 below). 
In the case of pop-up lists associated with integer data fields, the stored value is 
based on the relative position in the pop-up list (item at top of list is “1,” etc.). This 
is true for every list item except the “Not Done/N.D.” item. In AudBase the “Not 
Done/N.D.” item always appears at the end of the list, so its stored value (“0”) does 
not reflect its position in the list.

Special cases
• For numeric fields where “0” is a valid answer (for example, number of siblings) the 

special “out of range” value, -32767, is used. These data fields are not displayed on 
forms directly since the field would display “-32767,” which may cause confusion. 
Instead the fields are <blank> when displayed without a valid data entry.

• Since “Not Done/N.D” is not a possible entry for fields that store only true-false 
(yes-no) values (such as whether there were surgical complications), these fields 
store “0” for the “Not Done/N.D.” value, “1” for “No” and “2” for “Yes.”

Searching for “Not Done/N.D.” values
When searching for “Not Done/N.D.” alphanumeric fields, the search value is simply left 
blank. For an example of how searching for a blank field could be useful, consider a 
search for any involvement of a tumor subsite (see “Set theory and searching” on 
page 177). You could put together an OR’d search for every possible combination of 
(R)ight, (C)enter and (L)eft. Alternatively you could simply exclude records with “No” 
and ones that are <blank>. See the example on page 179.

When searching for values other than “Not Done/N.D.” in numeric fields, construct the 
search query line to look for values greater than (>) the “Not Done/N.D.” value. For 
example:

[Subject]Gender > 0 (“0” is the “Not Done/N.D.” value.)
-or-
[Subject]NumberOfSiblings >= 0 (“0” is a real value while “-32767” is the “Not Done/
N.D.” value.)
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Modifiable Lists
Many of the lists used to aid data entry in AudBase, such as pop-up lists or lists in text 
boxes on forms, can be modified. The administrator or a subadministrator have privileges 
to modify lists.

The easiest way to modify lists is by using the Modify Entry Lists feature on the Prefer-
ences form (see “Modifying lists” on page 109). This feature allows you to type in new 
list items and add them to the list or modify/delete old ones. There are two restrictions on 
adding new items or rearranging old ones:

• If the underlying data field is an alphanumeric field (for example, diagnosis in a 
tmor database) then the ordering of the list is not crucial since the actual stored 
value comes straight from the list display values.

• If the underlying data field is an integer value then you should only add new items 
to the end of the list and should not rearrange list orders. This is because the stored 
integer value represents the position of the selected item in the list in ascending 
order from top to bottom.

Subadministrators are usually not allowed to modify lists in a way that violates the list 
restrictions. The administrator will be warned if they are violating the restrictions, but 
they can override the warning.

You can also print out or create a text file copy of the most current version of a list by 
selecting the Reports > Modifiable Lists menu item attached to the Home Window. The 
administrator and subadministrators can do the same by selecting Import\Export > Export 
Lists attached to the administrator menu bar.

These lists can also be updated by importing a modified version. In the case of an 
imported version, the “Not Done/N.D.” item needs to be explicitly included at the end of 
the list. 

Note: you should never add a “Not Done/N.D.” item to a pop-up list when modifying 
the list using the list-creation form. It will be automatically added to all modifiable pop-
up lists. If you are importing a new version of a pop-up list you should export the old 
version to a file on your computer and use it as your starting point.

To export the old version, do one of the following:

• Click the Reports > Modifiable Lists menu item attached to the Home Window.
• Click Import\Export > Export Lists in the administrator menu bar attached to the 

Home Window.

Some lists are always presented in scrollable areas (for example, a list of surgeries in a 
tumor database). These lists may be hierarchical with attached sublists. These lists can be 
updated by using the list modification form or by importing a modified version. In some 
cases the hierarchical list items must be identified by special reference numbers. You can 
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view the list item reference numbers by opening the modifiable list form or exporting the 
old version with list set numbers to a file on your computer. Lists requiring special refer-
ence numbers are noted in Appendix C, “Data Lists and their Stored Field Values” on 
page 231.

Multiple version lists
Central lists (lists that are only kept in the structure file) have only one version. An exam-
ple of this is the Gender list. Only the administrator can import new versions of these lists. 
Some lists in the database can exist in multiple versions that the administrator can make 
available to a user via a button on the entry form. In a tumor database these would include 
the Tumor Surgery Description list and the Tumor Chemotherapy Description list. These 
lists could have a default version that is stored in the structure file. All other versions are 
saved as LargeObject records. This means that if you distribute a copy of AudBase to 
another site, you need to include a “starter” data file with the LargeObject records in it. 
You can also export the LargeObject records as a TRANSFER type document and have 
them imported into a new, empty data file as templates.

The multiple versions of a list belong to a list family. The list family name is limited to 12 
characters and is used as part of the default list’s name stored in the structure file (List-
FamilyName + “_Default”). In a tumor database, for example, the Tumor Surgery 
Description list has a list family name of “TumSurgDesc.” The default Tumor Surgery 
Description list stored in the structure file is named ‘TumSurgDesc_Default’. All other 
lists in the “TumSurgDesc” list family are stored in LargeObject records where [LargeOb-
ject]LargeObject_ComboID = ListFamilyName (with a modifier that is automatically 
added by AudBase) and [LargeObject]LargeObject_ComboID = ListName.

When you open a form with a multiple-version list, AudBase searches for a list to be dis-
played. It searches the LargeObject table first for a default list replacement. If none is 
found the default list in the structure file is loaded. If one of the LargeObject lists has a 
ListName = “TumSurgDesc_Default” (the same name as the default list in the structure 
file) it will be loaded preferentially as the default list. Since only the Administrator can 
import and replace lists stored in the structure file, a subadministrator can override the 
structure file default list by this mechanism.

When importing multiple version lists the first line of the import file should be:

‘ListFamilyName$ListName’ (‘$’ separates the two names)

ListFamilyName can be up to 12 characters long. The ListName can be up to 31 charac-
ters long (see “Importing lists” on page 149 for more details).
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Equivalent value lists
Some modifiable AudBase lists have two values for each list item:

• The value to display on a form.
• The value or values to save in the underlying data field. 

Each list item has the format: “DisplayValue=StorageValue.” The list of U.S. states is an 
example of an equivalent list:

State
Alabama=AL
Alaska=AK
American Samoa=AS
Arizona=AZ
Arkansas=AR
California=CA

The full name of the state is displayed in the selection list, but the underlying data field 
only stores two characters. For Alabama, “AL” is stored. Some lists have numeric values 
instead of string values (for example 5dB=5). If you are modifying an equivalent value 
list, you must include the “=” sign with a value or else the StorageValue will be interpreted 
as <blank> or 0 depending on the underlying data field type.

Some equivalent value lists form the basis for parsed text entries where the data is entered 
by a multiple choice pop-up.  For example, you may have a list of House Colors where the 
pop-up includes Brown, Yellow, Red.  The item and its associated choices are stored in the 
list as:

House Colors=Brown;Yellow;Red;N.D.    (NOTE: ‘N.D’ or its equivalent. is added to the 
end of the choices)

Appendix C, “Data lists and their stored data field values” on page 231 shows which lists 
can be modified and has information on their location in the database and their modifiabil-
ity.

Checksums
Checksums are an extremely helpful tool in verifying that the data sent from one computer 
arrives at another computer without being changed. Especially in the case of multi-site 
clinical studies, checksums can also be used to make sure that subject data sent from vari-
ous sites is never changed after first being collected. In essence, checksums are a mathe-
matical way of analyzing a data stream and reducing it to a single, representative long 
integer (+/- 2,147,483,647). The data stream is made up of data bits, each equal to 0 or 1. 
By processing a series of repeated calculations using a specially selected “polynomial,” a 
computer can examine a data stream and detect the change in a single bit.
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Checksums are most often used in data transmission where a data stream is sent followed 
by its calculated checksum. The receiving computer calculates its own checksum on the 
data stream and compares it to the received checksum. If the two match, the data stream 
has remained unchanged during transmission and is therefore valid.

The same theory underlies the use of checksum calculations in AudBase for entire data-
base records and exported data field subsets. All records or fields exported in a TRANS-
FER type export document include their unique internal ID fields in addition to the 
requested export fields. Calculating a checksum on all of these fields virtually guarantees 
that a record or selected subset of data fields cannot be modified without changing the 
checksum. It is important to realize that subtle changes such as capitalizing a letter in a 
text field result in a completely different checksum calculation.

Control of data in multi-center clinical studies
If checksums are used it is not even necessary for participating institutions or individuals 
to exchange the actual data until the conclusion of a study. Instead, a CHECKSUM-type 
export document can be exchanged with the coordinating institution. At the conclusion of 
the study the actual data can be exchanged and the checksums compared to verify that no 
data has been altered.

Checksum Reports
When you create CHECKSUM or TRANSFER type export files, checksum data is 
included in a special format. If you select the CHECKSUM option on the Export Settings 
form, you can export the checksum information in a text format document or in a TRANS-
FER document (see “Since many of the export and report features involve searching for 
data, it may be helpful to review Chapter 4, “Searching.”” on page 88). 

Note: The TRANSFER document does not have to include the actual data from the 
records selected for export.

Any spreadsheet or word processing software can open the text format document. In con-
trast, you must open a TRANSFER document that contains checksums by clicking 
Import\Export > Import TRANSFER Doc on the administrator menu bar. You can then 
place the TRANSFER document checksum information in a text format document for 
inspection. 

The advantage to using a TRANSFER document rather than a plain text documents is that 
it is harder to tamper with the checksum data and the TRANSFER document can be 
encrypted for additional protection against tampering. 

The following example, using a tumor database version, will show the type of checksum 
information included in the resulting text format document. For this example, a TRANS-
FER document was generated by selecting Reports > Export Data. A search set was cre-
ated for records from the Tumor_Description table where the primary site contains 
“paranasal.”
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The TRANSFER document, called PARANASALTransfer, included the record data from 
four Tumor_Description data fields: Primary_site, T stage, N stage, and M stage. In this 
example we are only exporting the Tumor_Description records so only the 
Tumor_Description fields will be in the TRANSFER document. Because the Include 
Checksum Info option was checked, the TRANSFER document also included checksum 
information on the exported data fields.

The TRANSFER document was opened 
by selecting the Import\Export > Import 
TRANSFER Doc menu item on the 
administrator menu bar. Since the docu-
ment includes the actual data along with 
the checksum information, all three 
options are available:

•  Checksum Info import records
•  Checksum Info current records
•  Import the record data.

You can generate two types of text format 
documents from the checksum data:

• The Checksum Info import records option will include the checksum data on the 
records in the TRANSFER document. This is a fast process since no further analysis 
of data needs to be done.

• The Checksum Info current records option will additionally analyze the checksums 
for any pre-existing records in the data file that will be updated by the import opera-
tion. Since these checksums need to be calculated, the process may take longer. 
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Checksum Info import records
With the Checksum Info [Import Records] radio button selected, click on the Create Text 
Doc button to save the text file version of the Checksum Information. Opening the text 
format document created by the Checksum Info [Import Records] option will reveal the 
following:

The file includes:

• File type identification and date of export
• The table(s) included in the export and their exported field numbers. In this exam-

ple, only Tumor_Description fields were included in the export since we were only 
exporting records from the TumorDescription table (see the Export Settings form in 
the figure above). Six fields were included in the exported data and the checksum 
calculations: 1 (Subject_ID), 5 (Tumor_No), 9 (Primary_site), 16 (T Stage), 17 (N 
Stage), and 18 (M Stage). These are the four fields specified on the Export Settings 
form plus the two required ID fields for the Tumor_Description table.

Note: The ID fields could have been explicitly included in the Export 
Settings. Since they were not, the required ID fields were automatically 
added.

• Names of the required ID fields for the included table(s).

As you can see from the final group of data, each exported record is identified by the table 
of origin, any required ID field values and the calculated checksum for the exported fields.

Since critical data records are identified by a unique ID or unique combination of IDs, the 
checksum is a unique identifier for the record it represents (1 in 2,147,483,647). Even if 
two records have the same data in the data fields specified in the Export Settings form, the 
two checksums will be different because of the unique ID fields that are automatically 
included in all CHECKSUM and TRANSFER type documents. This is why study partici-
pants do not have to exchange the actual data to guarantee that the data has not been tam-
pered with. The checksums allow you to say with certainty that the data for the entire 
study is valid. 

 Record Export Checksum Info
 Export date: 04/25/1999:
 
 Tablename Exported Field Numbers
 Tumor_Description 1,5,9,16,17,18,
 
 Tablename ID Field #1 ID Field #2
 Tumor_Description Subject_ID Tumor_No
 
 Tablename ID Field #1 ID Field #2 Checksum for exported fields
 Tumor_Description 251000 174000 81827828
 Tumor_Description 275000 215000 1520154295
 Tumor_Description 277000 218000 584311072
Tumor_Description 38000 224000 1094207930
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Checksum Info [Current records]
When you are importing a TRANSFER type document, the text format document created 
when you select the Checksum Info [Current Records] option includes all the information 
for the Checksum Info [Import Records]. In addition, AudBase uses the unique ID field(s) 
for each record to find any existing records in the current data file that would be updated 
by the data import. A checksum is then calculated for the corresponding data fields and 
compared with the checksum for the import data.

Here is the text document for the same set of Tumor_Description records, this time with 
the Checksum Info [Current Records] option selected.

You can use the information in the “Previous record status” column to verify any changes 
in previously shared data. Note the number “2” in the second to last record; this indicates 
that the checksums did not match and something has changed.

By exchanging checksum data on a regular basis, a coordinating institution can monitor 
data collection and guarantee data integrity without having to control all or any of the 
actual data. Use of the Checksum only option for Clinical Group Grouped Exports will 
guarantee the selection of the records qualifying for a clinical study and the export of the 
proper data fields for the clinical study (see “Exporting a Grouped Export” on page 146).

 Record Export Checksum Info
 Export date: 08/25/1999:
 
 Tablename Exported Field Numbers
 Tumor_Description 1,5,9,16,17,18,
 
 Tablename ID Field #1 ID Field #2
 Tumor_Description Subject_ID Tumor_No
 Previous record status: 0=none, 1=found w/ same checksum, 2=found w/ different checksum, 3=more 
than one record found
 
 Tablename ID Field #1 ID Field #2 Checksum for Previous record 
 exported fields status
 Tumor_Description 251000 174000 81827828 1
 Tumor_Description 275000 215000 1520154295 1
 Tumor_Description 277000 218000 584311072 2
 Tumor_Description 38000 224000 1094207930 0
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This section details a number of procedures to follow if you believe your files have been 
corrupted, and offers additional tips on how to maintain healthy files. It also includes a 
procedure to follow if you are having trouble with your password.

Backing up files
As with any program, always make backup copies of your AudBase files. This will ensure 
that if the files are damaged you can retrieve them while keeping data loss to a minimum.

Corrupted files
From time to time computer files may become corrupted. This can happen for many rea-
sons, including power surges, hardware problems and computer viruses, along with oth-
ers.

You may be able to repair a corrupted AudBase file by using the 4D Tools application. 4D 
Tools allows you to diagnose and repair corrupted data and structure files. If you are using 
AudBase Server, the 4D Tools were installed with the program. 4D Tools are included on 
your installation disk or you can download the 4D Tools application and documentation at 
from 4D at http://www.4d.com.

Download the version of 4D Tools compatible with the 4D version associated with Aud-
Base. To find out the 4D version number, do one of the following:

• If you are using Windows, see Help > About, and select the File Info tab. 
• If you are using Macintosh, select Apple > About AudBase, and select the File Info 

tab.

Troubleshooting
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Fixing data and structure files
If your data or structure file has been corrupted, use 4D Tools to diagnose and repair the 
file. If the structure file cannot be repaired, reinstall the AudBase program and log in with 
the initial administrator password (see “Initial passwords for a structure file” on page 4).

When repairing a data file with 4D Tools, the internal references associated with a record 
may become altered. Under normal circumstances, AudBase relies on the stability of these 
internal references to speed up processes, such as limiting record access for different 
users. To ensure these functions operate correctly after using 4D Tools, the first time a 
repaired data file is used the administrator needs to execute two items from AudBase’s 
Clean Up Menu. 

To clean up a data file after repair

1. Log in as the administrator.
If necessary, synchronize the data and structure files. 

2. From the Home Window, select Data Manager > Administrator Menu Bar.
3. Select Clean Ups > Update Subject Sets.
4. Select Clean Ups > Update Searches\Exports

For more information, see “Clean Ups Menu items” on page 152.

Ongoing file maintenance
Over time data files can fragment, which can affect the performance of your files. It is rec-
ommended that you occasionally use 4D Tools to defragment and compact data files. 
Once the files have been compacted, you must execute the Clean Up Menu items 
described above.

Rebuilding static program elements
To increase efficiency, structure information, such as the table and field lists on an Export 
form, is stored in records in the data file. If you suspect that these records have become 
corrupted or do not reflect changes you know have occurred (such as a new field that does 
not appear in the list), you can force AudBase to rebuild these records. 

To force AudBase to rebuild a static program element record

1. Log in as the administrator.
2. After entering the user name and pass-

word, hold down the shift key while click-
ing Connect.
A dialog displays asking if you wish to 
rebuild the static program elements.

3. Click Yes.
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Note: Using the Shift-Alt key combination (Windows) or Shift-Option (Mac) while 
clicking Connect will switch data files. 

Trouble with passwords
Because AudBase passwords are stored in the data file, when you switch to a different 
data file you must enter a password for that file to successfully log in. Synchronization of 
the structure file and the data file passwords can sometimes become confusing when 
switching between different data files (see “How passwords work” on page 4). If you for-
get which data file you were last connected with and cannot log in, follow these steps.

To log in if you forget which password to use for AudBase

1. Uninstall AudBase (this will not affect your data files).
2. Reinstall the program.
3. Use the initial Administrator/Otolith2 login and password combination.
4. Browse to whatever data file you wish to work with and click Open to connect 

with it.
5. Following synchronization of the structure file and data file, log in with the pass-

word stored in that data file (or create a new password at this time).

Note: When using multiple data files, it is best to keep a record of the passwords for 
each.



192 · AUDBASE

Audbase.book  Page 192  Thursday, May 4, 2006  10:04 PM



This section
mation abo
nization of 

Audbase.book  Page 193  Thursday, May 4, 2006  10:04 PM
Appendices

 contains reference infor-
ut the structure and orga-
the  AudBase software.



194 · AUDBASE

Audbase.book  Page 194  Thursday, May 4, 2006  10:04 PM
Appendix A: Installation Files

Files and folders installed with AudBase include:
1. Structure file and associated files. These files include the executible program and 

all resources.
2. Example data file. This data file uses the default Administrator password and is 

meant to allow a new user to learn to use the program. When you start with your 
actual data you should create a new data file (see “Creating new data files” on 
page 5)

3. Documentation. PDF documents including the User manual and Tutorial are 
installed together. Additional 4D manuals are inluded as required to explain spe-
cial features such as 4D Write. Web Help files are also installed within the 
Mac4DX or Win4DX directories included with the database structure files.

4. Templates. Templates allow the administrator to add functionality to a new data 
file by importing the template records

AudBase License Installation
AudBase licenses are stored in HTML-compatible documents which can be displayed in a 
web browser. The actual license data read by the program is encrypted. The license docu-
ments are kept within the Licenses directory (folder) located within the AudBase directory 
also known as the OTBEC directory. You can find the location of your current OTBEC 
directory by opening the About AudBase form by one of the following methods:

• If you are using Windows, see Help > 
About, and select the File Info tab. 

• If you are using Macintosh, select Apple > 
About AudBase, and select the File Info 
tab.

Select the File Info tab and you will see the 
directory information displayed for the AudBase 
directory.

You can place your AudBase licenses within the 
directory manually or you can transfer them 
from their present directory to the license direc-
tory by opening the Preferences form and select-
ing the Audiology (Admin) page. 
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The encrypted license data is loaded by the program 
automatically on start-up. If new licenses are manu-
ally placed in the license folder while the program is 
running they must be loaded by selecting the Load 
License Info button before becoming active. Alterna-
tively when you select the Load License button you 
will be asked if you want to move licenses from their 
present location. If you answer yes you will be asked 
to select the folder (directory) which the licenses are 
currently in. If appropriate licenses are found they 
will be copied to the Licenses directory and the new 
licenses will then be loaded automatically.

Licenses for an AudBase server installation must 
reside on the server machine. A request to load new 
licenses is generated from a client connection which 
can be performed on the server machine or remotely. 
Licenses can be moved to the server’s Licenses direc-
tory from a remote client machine.
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Appendix B: Tables and Fields
This appendix consists of two sections that contain a list of tables and their fields. Within 
each section the data fields are divided into kernel tables, included with all versions of 
AudBase, followed by any custom tables specific to this version.

In the first section the data fields appear in their native order, in other words, the order 
they appear in the database structure.

Each field lists:

1. Table field number
2. Field name
3. Field type
4. Associated data list name and other special notes.

The associated data lists contain the text items displayed on the forms for data entry pur-
poses. The actual data stored in the data field may be an integer value. Find the associated 
data lists and their data field values in “Appendix C: Data lists and their data field values” 
on page 231. Using these two appendices you can search for any data in the database. For 
example, the [Subject]Gender field uses the Gender list. The data field values correspond-
ing with the Gender list selections are: 1 = “Female”, 2 = “Male” and 0 = “N.D.” A search 
for female subjects would include the query line: “[Subject]Gender” = 1. 

In the second section the data fields appear in alphabetical order for cross-referencing with 
field numbers. 

Fields listed in native order
In this section, fields are listed in native order, in other words, the order they appear in the 
database structure.  

Kernel Tables

ClinicalGroup
Field # Field name Field type Associated data list/Notes
1 ClinicalGroup_ID Long Integer
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Name Alpha 50
6 Address Text
7 City Alpha 20
8 State Alpha 2
9 ZipCode Alpha 10
10 Country Alpha 20
11 Phone1 Alpha 20
12 Phone1Type Integer Telephone Type
13 Phone2 Alpha 20
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14 Phone2Type Integer Telephone Type
15 Phone3 Alpha 20
16 Phone3Type Integer Telephone Type
17 EMail_Address Text
18 ListName Alpha 20
19 ClinicalGroupIdentifierFormat Alpha 15
20 Is_A_Study Boolean
21 ClinicalGroupChecklist Text
22 ClinicalGroupGroupedExport Text
23 ClinicalGroupExportSeqSearch Text
24 EMail_AttachmentMaxSize Integer
25 EMail_SingleAttachmentsOnly Boolean
26 PrivateKeyEncrypted Text
27 PublicKeyEncrypted Text
28 Study_ParticipantID Integer
29 Study_ImportKeysEncrypted Blob
30 CountryPhoneCode Alpha 5
31 Completed_Record Boolean
32 Group_Type Alpha 40 ClinicalGroup_Type

Constants
Field # Field name Field type Associated data list/Notes
1 Constant_Name Alpha 60
2 LongInt_ID Long Integer
3 Alpha_Constant Alpha 20
4 Text_Constant Text
5 Blob_Constant Blob
6 Date_Constant Date

LargeObject
Field # Field name Field type Associated data list/Notes
1 LargeObject_ComboID Alpha 41
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 LargeObject_SubID Alpha 31
6 LargeObject_Blob Blob
7 LargeObject_Text Text
8 LargeObject_Pict Picture

Provider
Field # Field name Field type Associated data list/Notes
1 Provider_ID Long Integer
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Salutation Alpha 4 Salutation
6 FirstName Alpha 20
7 LastName Alpha 20
8 MiddleName Alpha 20
9 Title Alpha 4
10 Address Text
11 City Alpha 20
12 State Alpha 2
13 ZipCode Alpha 10
14 Country Text
15 Gender Integer Gender
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16 Phone1 Alpha 20
17 Phone1Type Integer Telephone Type
18 Phone2 Alpha 20
19 Phone2Type Integer Telephone Type
20 Phone3 Alpha 20
21 Phone3Type Integer Telephone Type
22 EMailAddress Text
23 LoginName Alpha 30
24 ListName Alpha 24
25 LocalProviderList_Set Blob
26 LocalClinicalGroupList_Set Blob
27 ClinicalGroupsInsubjectList_Set Blob
28 AllsubjectPrivileges Boolean
29 EMail_OutgoingServerName Text
30 EMail_OutgoingUserName Text
31 EMail_IncomingServerName Text
32 EMail_IncomingUserName Text
33 CountryPhoneCode Alpha 5
34 Occupation Alpha 31
35 Info_Blob Blob
36 Completed_Record Boolean
37 E_Mailbox_Type Integer

ProviderGroup
Field # Field name Field type Associated data list/Notes
1 Provider_ID Long Integer
2 ClinicalGroup_ID Long Integer
3 IsGroupAdministrator Boolean

Reminder
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Provider_ID Long Integer
6 Study_ID Long Integer
7 DueDate Date
8 OrigDueDate Date /Date saved when reminder

is originally created 
9 ActionDate Date
10 ActionTaken Boolean
11 Note Text
12 ReminderType Alpha 20 Reminder Type
13 Study_Name Alpha 30
14 Subtype_Num Long Integer

Saved Sets
Field # Field name Field type Associated data list/Notes
1 Set Name Alpha 31
2 File Number Integer
3 Rec Mod Date
4 Set Data Blob
5 Records_In_set Long Integer

Subject
Field # Field name Field type Associated data list/Notes
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1 Subject_ID Long Integer
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Salutation Alpha 4 Salutation
6 FirstName Alpha 20
7 LastName Alpha 20
8 MiddleName Alpha 20
9 Title Alpha 4
10 Address Text
11 City Alpha 20
12 State Alpha 2
13 ZipCode Alpha 10
14 Country Text
15 Phone1 Alpha 20
16 Phone1Type Integer Telephone Type
17 Phone2 Alpha 20
18 Phone2Type Integer Telephone Type
19 Phone3 Alpha 20
20 Phone3Type Integer Telephone Type
21 CountryPhoneCode Alpha 5
22 Birthdate Date
23 DeathDate Date
24 LastContactDate Date
25 Gender Integer Gender
26 Race Integer Race
27 LivingStatus Integer Yes/No
28 LivingStatus_Contact_History Text Subject_Living Status  (Subject_Living Status 

in special text format)
29 Inactive Boolean
30 Notes Text
31 ClinicalGroupIdentifier_Primary Alpha 15
32 ClinicalGroup_ID_Primary Long Integer
33 Provider_ID_Primary Long Integer
34 ProviderName_Primary Alpha 24
35 Universal_ID Alpha 20
36 ReferralProviderIDs Text
37 Completed_Record Boolean

SubjectClinicalGroup
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer
2 ClinicalGroup_ID Long Integer
3 ClinicalGroupIdentifier Alpha 15

SubjectProvider
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer
2 Provider_ID Long Integer

Audiogram/Tympanogram/SAT_SRT_WordRecognition Tables
The following section lists the specialized tables for AudBase. For a better understanding 
of the fields in this section, it may be helpful to understand the naming conventions
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For right and left pure tone fields, the following abbreviations are used:

• First character: A = air, B = bone
• Second character: U = unmasked, M = masked
• Third character: R = right, L = left
• Frequencies: 00125 - 12000 or SpFxx = special frequency field number 

For example “PureTone_AUR_00125” means AirUnmaskedRight at 125 Hz; 
“PureTone_AUR_SpF01” for a special frequency audiogram it is the first unmasked spe-
cial frequency field.  To determine the corresponding special frequency value, refer to the 
SpecFrequencyAudiogram_FieldHz field.

For comfort levels, the first two character abbreviations are used: 

• MC = maximum level
• UC = uncomfortable level

For example “PureTone_MCR_02000” means MaximumComfortRight at 2000 Hz.

All soundfield names begin with the two characters “Sf”. For unaided sound fields a single 
character is added designating side or bilaterality:

• SfU/SfR/SfL = soundfield unaided, bilateral/right/left

For example “PureTone_SfU_01000” means SoundfieldUnaided, bilateral at 1000 Hz.

For aided soundfields the type of aid is designated along with the side (R=right, L=left, 
B=bilateral). Combinations are ordered following the convention of the image of the 
patient facing the examiner:

• SfA = soundfield Aided (hearing aid)
• SfCI = soundfield Cochlear Implant
• SfH = soundfield Hybrid

For example “PureTone_SfCIR_04000” means SoundfieldCochlearImplantRight at 4000 
Hz. “PureTone_SfHB_01000” means SoundfieldHybridBilateral at 1000 Hz. 
“PureTone_SfARCIL_02000” means SoundfieldAidedRightCochlearImplantLeft at 2000 
Hz

For word recognition fields use the same basic abbreviations for type and side plus:

• Binaural = binaural under phones
• #number = position (1 - 4)
• pct = percent
• dB = decibel level
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For example “WordRecognition_L_2_pct” means left, 2nd position, percentage. Binaural 
under phones word recognition values have an additional character denoting which ear for 
the two dB values. “WordRecognition_Binaural_2L_dB” means binaural, 2nd position, 
left ear component, decibel level.

When appropriate the fields storing decibel levels use the following special values:

• N.D. (Not Done) = -32767
• UdB (Unspecified dB [used for some acoustic reflex tests]) = 300
• CNT (Could Not Test) = 400

No response, or NR, values are encoded as their negative values. For example, no 
response at 75 decibels would be encoded as -75dB. There is an exception to this rule. 
Because the dB range from -20 to 20 is a valid range for testing purposes, this means that 
NR values for dB levels from -20 to 20 cannot be simply encoded as their negative values. 
Though it would be extremely rare that a NR value would be recorded for this range the 
NR values for values in this range are calculated as their negative value PLUS -200. Thus 
the NR value for -10 db would be -(-10) + (-200) = -190, for 15 dB the NR value would be 
-(15) + (-200) = -215. 

The tympanogram peak pressure field has a special No Peak (NP) value:

• NP (No Peak) = -500

Audiogram
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer, indexed
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Audiogram_No Long Integer, indexed
6 Completed_Record Boolean
7 Related_Tympanogram_No Long Integer, indexed
8 Related_SAT_SRT_WordRec_No Long Integer, indexed
9 Audiogram_Date Date
10 Audiogram_Time Time
11 Examiner Text Audio_Audiologist
12 Notes Text Audio_CommentsShort/

 Audio_CommentsExtended
13 Audiometer_Type Alpha 31 Audio_AudiometerType
14 Transducer_Standard Text Audio_Transducer
15 Transducer_SpecFreq Text Audio_Transducer
16 Reliability Alpha 4 Audio_Reliability
17 Testing_method Text Audio_TestingMethod
18 Testing_location Text Audio_TestingLocation
19 Testing_Sublocation Text Audio_TestingSublocation
20 PackedDisplay_selector Integer
21 Audiogram_SpecFrequencyType Integer
22 SpecFrequencyAudiogram_FieldHz Text
23 PureTone_AUR_00125 Integer
24 PureTone_AUR_00250 Integer
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25 PureTone_AUR_00500 Integer
26 PureTone_AUR_00750 Integer
27 PureTone_AUR_01000 Integer
28 PureTone_AUR_01500 Integer
29 PureTone_AUR_02000 Integer
30 PureTone_AUR_03000 Integer
31 PureTone_AUR_04000 Integer
32 PureTone_AUR_06000 Integer
33 PureTone_AUR_08000 Integer
34 PureTone_AUR_12000 Integer
35 PureTone_AMR_00125 Integer
36 PureTone_AMR_00250 Integer
37 PureTone_AMR_00500 Integer
38 PureTone_AMR_00750 Integer
39 PureTone_AMR_01000 Integer
40 PureTone_AMR_01500 Integer
41 PureTone_AMR_02000 Integer
42 PureTone_AMR_03000 Integer
43 PureTone_AMR_04000 Integer
44 PureTone_AMR_06000 Integer
45 PureTone_AMR_08000 Integer
46 PureTone_AMR_12000 Integer
47 PureTone_BUR_00125 Integer
48 PureTone_BUR_00250 Integer
49 PureTone_BUR_00500 Integer
50 PureTone_BUR_00750 Integer
51 PureTone_BUR_01000 Integer
52 PureTone_BUR_01500 Integer
53 PureTone_BUR_02000 Integer
54 PureTone_BUR_03000 Integer
55 PureTone_BUR_04000 Integer
56 PureTone_BUR_06000 Integer
57 PureTone_BUR_08000 Integer
58 PureTone_BUR_12000 Integer
59 PureTone_BMR_00125 Integer
60 PureTone_BMR_00250 Integer
61 PureTone_BMR_00500 Integer
62 PureTone_BMR_00750 Integer
63 PureTone_BMR_01000 Integer
64 PureTone_BMR_01500 Integer
65 PureTone_BMR_02000 Integer
66 PureTone_BMR_03000 Integer
67 PureTone_BMR_04000 Integer
68 PureTone_BMR_06000 Integer
69 PureTone_BMR_08000 Integer
70 PureTone_BMR_12000 Integer
71 PureTone_MCR_00125 Integer
72 PureTone_MCR_00250 Integer
73 PureTone_MCR_00500 Integer
74 PureTone_MCR_00750 Integer
75 PureTone_MCR_01000 Integer
76 PureTone_MCR_01500 Integer
77 PureTone_MCR_02000 Integer
78 PureTone_MCR_03000 Integer
79 PureTone_MCR_04000 Integer
80 PureTone_MCR_06000 Integer
81 PureTone_MCR_08000 Integer
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82 PureTone_MCR_12000 Integer
83 PureTone_UCR_00125 Integer
84 PureTone_UCR_00250 Integer
85 PureTone_UCR_00500 Integer
86 PureTone_UCR_00750 Integer
87 PureTone_UCR_01000 Integer
88 PureTone_UCR_01500 Integer
89 PureTone_UCR_02000 Integer
90 PureTone_UCR_03000 Integer
91 PureTone_UCR_04000 Integer
92 PureTone_UCR_06000 Integer
93 PureTone_UCR_08000 Integer
94 PureTone_UCR_12000 Integer
95 PureTone_AUR_SpF01 Integer
96 PureTone_AUR_SpF02 Integer
97 PureTone_AUR_SpF03 Integer
98 PureTone_AUR_SpF04 Integer
99 PureTone_AUR_SpF05 Integer
100 PureTone_AUR_SpF06 Integer
101 PureTone_AUR_SpF07 Integer
102 PureTone_AUR_SpF08 Integer
103 PureTone_AUR_SpF09 Integer
104 PureTone_AUR_SpF10 Integer
105 PureTone_AUR_SpF11 Integer
106 PureTone_AUR_SpF12 Integer
107 PureTone_AMR_SpF01 Integer
108 PureTone_AMR_SpF02 Integer
109 PureTone_AMR_SpF03 Integer
110 PureTone_AMR_SpF04 Integer
111 PureTone_AMR_SpF05 Integer
112 PureTone_AMR_SpF06 Integer
113 PureTone_AMR_SpF07 Integer
114 PureTone_AMR_SpF08 Integer
115 PureTone_AMR_SpF09 Integer
116 PureTone_AMR_SpF10 Integer
117 PureTone_AMR_SpF11 Integer
118 PureTone_AMR_SpF12 Integer
119 PureTone_AUL_00125 Integer
120 PureTone_AUL_00250 Integer
121 PureTone_AUL_00500 Integer
122 PureTone_AUL_00750 Integer
123 PureTone_AUL_01000 Integer
124 PureTone_AUL_01500 Integer
125 PureTone_AUL_02000 Integer
126 PureTone_AUL_03000 Integer
127 PureTone_AUL_04000 Integer
128 PureTone_AUL_06000 Integer
129 PureTone_AUL_08000 Integer
130 PureTone_AUL_12000 Integer
131 PureTone_AML_00125 Integer
132 PureTone_AML_00250 Integer
133 PureTone_AML_00500 Integer
134 PureTone_AML_00750 Integer
135 PureTone_AML_01000 Integer
136 PureTone_AML_01500 Integer
137 PureTone_AML_02000 Integer
138 PureTone_AML_03000 Integer
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139 PureTone_AML_04000 Integer
140 PureTone_AML_06000 Integer
141 PureTone_AML_08000 Integer
142 PureTone_AML_12000 Integer
143 PureTone_BUL_00125 Integer
144 PureTone_BUL_00250 Integer
145 PureTone_BUL_00500 Integer
146 PureTone_BUL_00750 Integer
147 PureTone_BUL_01000 Integer
148 PureTone_BUL_01500 Integer
149 PureTone_BUL_02000 Integer
150 PureTone_BUL_03000 Integer
151 PureTone_BUL_04000 Integer
152 PureTone_BUL_06000 Integer
153 PureTone_BUL_08000 Integer
154 PureTone_BUL_12000 Integer
155 PureTone_BML_00125 Integer
156 PureTone_BML_00250 Integer
157 PureTone_BML_00500 Integer
158 PureTone_BML_00750 Integer
159 PureTone_BML_01000 Integer
160 PureTone_BML_01500 Integer
161 PureTone_BML_02000 Integer
162 PureTone_BML_03000 Integer
163 PureTone_BML_04000 Integer
164 PureTone_BML_06000 Integer
165 PureTone_BML_08000 Integer
166 PureTone_BML_12000 Integer
167 PureTone_MCL_00125 Integer
168 PureTone_MCL_00250 Integer
169 PureTone_MCL_00500 Integer
170 PureTone_MCL_00750 Integer
171 PureTone_MCL_01000 Integer
172 PureTone_MCL_01500 Integer
173 PureTone_MCL_02000 Integer
174 PureTone_MCL_03000 Integer
175 PureTone_MCL_04000 Integer
176 PureTone_MCL_06000 Integer
177 PureTone_MCL_08000 Integer
178 PureTone_MCL_12000 Integer
179 PureTone_UCL_00125 Integer
180 PureTone_UCL_00250 Integer
181 PureTone_UCL_00500 Integer
182 PureTone_UCL_00750 Integer
183 PureTone_UCL_01000 Integer
184 PureTone_UCL_01500 Integer
185 PureTone_UCL_02000 Integer
186 PureTone_UCL_03000 Integer
187 PureTone_UCL_04000 Integer
188 PureTone_UCL_06000 Integer
189 PureTone_UCL_08000 Integer
190 PureTone_UCL_12000 Integer
191 PureTone_AUL_SpF01 Integer
192 PureTone_AUL_SpF02 Integer
193 PureTone_AUL_SpF03 Integer
194 PureTone_AUL_SpF04 Integer
195 PureTone_AUL_SpF05 Integer
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196 PureTone_AUL_SpF06 Integer
197 PureTone_AUL_SpF07 Integer
198 PureTone_AUL_SpF08 Integer
199 PureTone_AUL_SpF09 Integer
200 PureTone_AUL_SpF10 Integer
201 PureTone_AUL_SpF11 Integer
202 PureTone_AUL_SpF12 Integer
203 PureTone_AML_SpF01 Integer
204 PureTone_AML_SpF02 Integer
205 PureTone_AML_SpF03 Integer
206 PureTone_AML_SpF04 Integer
207 PureTone_AML_SpF05 Integer
208 PureTone_AML_SpF06 Integer
209 PureTone_AML_SpF07 Integer
210 PureTone_AML_SpF08 Integer
211 PureTone_AML_SpF09 Integer
212 PureTone_AML_SpF10 Integer
213 PureTone_AML_SpF11 Integer
214 PureTone_AML_SpF12 Integer
215 PureTone_SfU_00125 Integer
216 PureTone_SfU_00250 Integer
217 PureTone_SfU_00500 Integer
218 PureTone_SfU_00750 Integer
219 PureTone_SfU_01000 Integer
220 PureTone_SfU_01500 Integer
221 PureTone_SfU_02000 Integer
222 PureTone_SfU_03000 Integer
223 PureTone_SfU_04000 Integer
224 PureTone_SfU_06000 Integer
225 PureTone_SfU_08000 Integer
226 PureTone_SfU_12000 Integer
227 PureTone_SfR_00125 Integer
228 PureTone_SfR_00250 Integer
229 PureTone_SfR_00500 Integer
230 PureTone_SfR_00750 Integer
231 PureTone_SfR_01000 Integer
232 PureTone_SfR_01500 Integer
233 PureTone_SfR_02000 Integer
234 PureTone_SfR_03000 Integer
235 PureTone_SfR_04000 Integer
236 PureTone_SfR_06000 Integer
237 PureTone_SfR_08000 Integer
238 PureTone_SfR_12000 Integer
239 PureTone_SfL_00125 Integer
240 PureTone_SfL_00250 Integer
241 PureTone_SfL_00500 Integer
242 PureTone_SfL_00750 Integer
243 PureTone_SfL_01000 Integer
244 PureTone_SfL_01500 Integer
245 PureTone_SfL_02000 Integer
246 PureTone_SfL_03000 Integer
247 PureTone_SfL_04000 Integer
248 PureTone_SfL_06000 Integer
249 PureTone_SfL_08000 Integer
250 PureTone_SfL_12000 Integer
251 PureTone_SfU_SpF01 Integer
252 PureTone_SfU_SpF02 Integer



206 · AUDBASE

Audbase.book  Page 206  Thursday, May 4, 2006  10:04 PM
253 PureTone_SfU_SpF03 Integer
254 PureTone_SfU_SpF04 Integer
255 PureTone_SfU_SpF05 Integer
256 PureTone_SfU_SpF06 Integer
257 PureTone_SfU_SpF07 Integer
258 PureTone_SfU_SpF08 Integer
259 PureTone_SfU_SpF09 Integer
260 PureTone_SfU_SpF10 Integer
261 PureTone_SfU_SpF11 Integer
262 PureTone_SfU_SpF12 Integer
263 PureTone_SfR_SpF01 Integer
264 PureTone_SfR_SpF02 Integer
265 PureTone_SfR_SpF03 Integer
266 PureTone_SfR_SpF04 Integer
267 PureTone_SfR_SpF05 Integer
268 PureTone_SfR_SpF06 Integer
269 PureTone_SfR_SpF07 Integer
270 PureTone_SfR_SpF08 Integer
271 PureTone_SfR_SpF09 Integer
272 PureTone_SfR_SpF10 Integer
273 PureTone_SfR_SpF11 Integer
274 PureTone_SfR_SpF12 Integer
275 PureTone_SfL_SpF01 Integer
276 PureTone_SfL_SpF02 Integer
277 PureTone_SfL_SpF03 Integer
278 PureTone_SfL_SpF04 Integer
279 PureTone_SfL_SpF05 Integer
280 PureTone_SfL_SpF06 Integer
281 PureTone_SfL_SpF07 Integer
282 PureTone_SfL_SpF08 Integer
283 PureTone_SfL_SpF09 Integer
284 PureTone_SfL_SpF10 Integer
285 PureTone_SfL_SpF11 Integer
286 PureTone_SfL_SpF12 Integer
287 PureTone_SfAR_00125 Integer
288 PureTone_SfAR_00250 Integer
289 PureTone_SfAR_00500 Integer
290 PureTone_SfAR_00750 Integer
291 PureTone_SfAR_01000 Integer
292 PureTone_SfAR_01500 Integer
293 PureTone_SfAR_02000 Integer
294 PureTone_SfAR_03000 Integer
295 PureTone_SfAR_04000 Integer
296 PureTone_SfAR_06000 Integer
297 PureTone_SfAR_08000 Integer
298 PureTone_SfAR_12000 Integer
299 PureTone_SfAL_00125 Integer
300 PureTone_SfAL_00250 Integer
301 PureTone_SfAL_00500 Integer
302 PureTone_SfAL_00750 Integer
303 PureTone_SfAL_01000 Integer
304 PureTone_SfAL_01500 Integer
305 PureTone_SfAL_02000 Integer
306 PureTone_SfAL_03000 Integer
307 PureTone_SfAL_04000 Integer
308 PureTone_SfAL_06000 Integer
309 PureTone_SfAL_08000 Integer
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310 PureTone_SfAL_12000 Integer
311 PureTone_SfAB_00125 Integer
312 PureTone_SfAB_00250 Integer
313 PureTone_SfAB_00500 Integer
314 PureTone_SfAB_00750 Integer
315 PureTone_SfAB_01000 Integer
316 PureTone_SfAB_01500 Integer
317 PureTone_SfAB_02000 Integer
318 PureTone_SfAB_03000 Integer
319 PureTone_SfAB_04000 Integer
320 PureTone_SfAB_06000 Integer
321 PureTone_SfAB_08000 Integer
322 PureTone_SfAB_12000 Integer
323 PureTone_SfCIL_00125 Integer
324 PureTone_SfCIL_00250 Integer
325 PureTone_SfCIL_00500 Integer
326 PureTone_SfCIL_00750 Integer
327 PureTone_SfCIL_01000 Integer
328 PureTone_SfCIL_01500 Integer
329 PureTone_SfCIL_02000 Integer
330 PureTone_SfCIL_03000 Integer
331 PureTone_SfCIL_04000 Integer
332 PureTone_SfCIL_06000 Integer
333 PureTone_SfCIL_08000 Integer
334 PureTone_SfCIL_12000 Integer
335 PureTone_SfCIR_00125 Integer
336 PureTone_SfCIR_00250 Integer
337 PureTone_SfCIR_00500 Integer
338 PureTone_SfCIR_00750 Integer
339 PureTone_SfCIR_01000 Integer
340 PureTone_SfCIR_01500 Integer
341 PureTone_SfCIR_02000 Integer
342 PureTone_SfCIR_03000 Integer
343 PureTone_SfCIR_04000 Integer
344 PureTone_SfCIR_06000 Integer
345 PureTone_SfCIR_08000 Integer
346 PureTone_SfCIR_12000 Integer
347 PureTone_SfCIB_00125 Integer
348 PureTone_SfCIB_00250 Integer
349 PureTone_SfCIB_00500 Integer
350 PureTone_SfCIB_00750 Integer
351 PureTone_SfCIB_01000 Integer
352 PureTone_SfCIB_01500 Integer
353 PureTone_SfCIB_02000 Integer
354 PureTone_SfCIB_03000 Integer
355 PureTone_SfCIB_04000 Integer
356 PureTone_SfCIB_06000 Integer
357 PureTone_SfCIB_08000 Integer
358 PureTone_SfCIB_12000 Integer
359 PureTone_SfHR_00125 Integer
360 PureTone_SfHR_00250 Integer
361 PureTone_SfHR_00500 Integer
362 PureTone_SfHR_00750 Integer
363 PureTone_SfHR_01000 Integer
364 PureTone_SfHR_01500 Integer
365 PureTone_SfHR_02000 Integer
366 PureTone_SfHR_03000 Integer
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367 PureTone_SfHR_04000 Integer
368 PureTone_SfHR_06000 Integer
369 PureTone_SfHR_08000 Integer
370 PureTone_SfHR_12000 Integer
371 PureTone_SfHL_00125 Integer
372 PureTone_SfHL_00250 Integer
373 PureTone_SfHL_00500 Integer
374 PureTone_SfHL_00750 Integer
375 PureTone_SfHL_01000 Integer
376 PureTone_SfHL_01500 Integer
377 PureTone_SfHL_02000 Integer
378 PureTone_SfHL_03000 Integer
379 PureTone_SfHL_04000 Integer
380 PureTone_SfHL_06000 Integer
381 PureTone_SfHL_08000 Integer
382 PureTone_SfHL_12000 Integer
383 PureTone_SfHB_00125 Integer
384 PureTone_SfHB_00250 Integer
385 PureTone_SfHB_00500 Integer
386 PureTone_SfHB_00750 Integer
387 PureTone_SfHB_01000 Integer
388 PureTone_SfHB_01500 Integer
389 PureTone_SfHB_02000 Integer
390 PureTone_SfHB_03000 Integer
391 PureTone_SfHB_04000 Integer
392 PureTone_SfHB_06000 Integer
393 PureTone_SfHB_08000 Integer
394 PureTone_SfHB_12000 Integer
395 PureTone_SfARCIL_00125 Integer
396 PureTone_SfARCIL_00250 Integer
397 PureTone_SfARCIL_00500 Integer
398 PureTone_SfARCIL_00750 Integer
399 PureTone_SfARCIL_01000 Integer
400 PureTone_SfARCIL_01500 Integer
401 PureTone_SfARCIL_02000 Integer
402 PureTone_SfARCIL_03000 Integer
403 PureTone_SfARCIL_04000 Integer
404 PureTone_SfARCIL_06000 Integer
405 PureTone_SfARCIL_08000 Integer
406 PureTone_SfARCIL_12000 Integer
407 PureTone_SfARHL_00125 Integer
408 PureTone_SfARHL_00250 Integer
409 PureTone_SfARHL_00500 Integer
410 PureTone_SfARHL_00750 Integer
411 PureTone_SfARHL_01000 Integer
412 PureTone_SfARHL_01500 Integer
413 PureTone_SfARHL_02000 Integer
414 PureTone_SfARHL_03000 Integer
415 PureTone_SfARHL_04000 Integer
416 PureTone_SfARHL_06000 Integer
417 PureTone_SfARHL_08000 Integer
418 PureTone_SfARHL_12000 Integer
419 PureTone_SfCIRAL_00125 Integer
420 PureTone_SfCIRAL_00250 Integer
421 PureTone_SfCIRAL_00500 Integer
422 PureTone_SfCIRAL_00750 Integer
423 PureTone_SfCIRAL_01000 Integer
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424 PureTone_SfCIRAL_01500 Integer
425 PureTone_SfCIRAL_02000 Integer
426 PureTone_SfCIRAL_03000 Integer
427 PureTone_SfCIRAL_04000 Integer
428 PureTone_SfCIRAL_06000 Integer
429 PureTone_SfCIRAL_08000 Integer
430 PureTone_SfCIRAL_12000 Integer
431 PureTone_SfCIRHL_00125 Integer
432 PureTone_SfCIRHL_00250 Integer
433 PureTone_SfCIRHL_00500 Integer
434 PureTone_SfCIRHL_00750 Integer
435 PureTone_SfCIRHL_01000 Integer
436 PureTone_SfCIRHL_01500 Integer
437 PureTone_SfCIRHL_02000 Integer
438 PureTone_SfCIRHL_03000 Integer
439 PureTone_SfCIRHL_04000 Integer
440 PureTone_SfCIRHL_06000 Integer
441 PureTone_SfCIRHL_08000 Integer
442 PureTone_SfCIRHL_12000 Integer
443 PureTone_SfHRAL_00125 Integer
444 PureTone_SfHRAL_00250 Integer
445 PureTone_SfHRAL_00500 Integer
446 PureTone_SfHRAL_00750 Integer
447 PureTone_SfHRAL_01000 Integer
448 PureTone_SfHRAL_01500 Integer
449 PureTone_SfHRAL_02000 Integer
450 PureTone_SfHRAL_03000 Integer
451 PureTone_SfHRAL_04000 Integer
452 PureTone_SfHRAL_06000 Integer
453 PureTone_SfHRAL_08000 Integer
454 PureTone_SfHRAL_12000 Integer
455 PureTone_SfHRCIL_00125 Integer
456 PureTone_SfHRCIL_00250 Integer
457 PureTone_SfHRCIL_00500 Integer
458 PureTone_SfHRCIL_00750 Integer
459 PureTone_SfHRCIL_01000 Integer
460 PureTone_SfHRCIL_01500 Integer
461 PureTone_SfHRCIL_02000 Integer
462 PureTone_SfHRCIL_03000 Integer
463 PureTone_SfHRCIL_04000 Integer
464 PureTone_SfHRCIL_06000 Integer
465 PureTone_SfHRCIL_08000 Integer
466 PureTone_SfHRCIL_12000 Integer
467 PureToneAvg_Air_R_dB Integer
468 PureToneAvg_Bone_R_dB Integer
469 PureToneAvg_SFUnaided_dB Integer
470 PureToneAvg_Air_L_dB Integer
471 PureToneAvg_Bone_L_dB Integer
472 PureToneAvg_SFAided_dB Integer
473 PureToneAvg_Air_R_FreqCombo Integer Audio_PTAFreq
474 PureToneAvg_Bone_R_FreqCombo Integer Audio_PTAFreq
475 PureToneAvg_SFUnaided_FreqCombo Integer Audio_PTAFreq
476 PureToneAvg_Air_L_FreqCombo Integer Audio_PTAFreq
477 PureToneAvg_Bone_L_FreqCombo Integer Audio_PTAFreq
478 PureToneAvg_SFAided_FreqCombo Integer Audio_PTAFreq
479 PureToneAvg_SfAided_CalcType Integer Audio_SoundfieldAidedTypes
480 PureToneAvg_SfUnaided_CalcType Integer Audio_SoundfieldUnaidedTypes
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481 DisplayPrefsBlob Blob
482 R_CommentFlagBlob Blob
483 R_NRFlagBlob Blob
484 L_CommentFlagBlob Blob
485 L_NRFlagBlob Blob
486 BoneInfoBlob Blob
487 MaskInfoBlob Blob
488 BoneInfoText Text
489 MaskInfoText Text
490 CommentInfoText Text
491 SpecFreq_BooleanFlag Boolean
492 Comment_BooleanFlag Boolean
493 NoResponse_BooleanFlag Boolean
494 UnspecifiedBone_BooleanFlag Boolean
495 HearingLevel_dB_Standard Text
496 Other_Info_Data Text Audio_Other_Info_Data/

 Audio_Other_Info_Data_Modified
497 SpecialInfo_Blob Blob

SAT_SRT_WordRecognition
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer, indexed
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 SAT_SRT_WordRec_No Long Integer, indexed
6 Primary_Audiogram_No Long Integer, indexed
7 Completed_Record Boolean
8 Exam_Date Date
9 Exam_Time Time
10 Examiner Text Audio_Audiologist
11 Notes Text
12 SAT_SRT_Stimulus Text Audio_SpondeeType
13 SRT_Air_R Integer
14 SRT_SfAR Integer
15 SRT_SfU Integer
16 SRT_Bone_R Integer
17 SRT_UnderPhones_MCR Integer
18 SRT_UnderPhones_UCR Integer
19 SRT_Air_L Integer
20 SRT_SfAL Integer
21 SRT_SfAB Integer
22 SRT_Bone_L Integer
23 SRT_UnderPhones_MCL Integer
24 SRT_UnderPhones_UCL Integer
25 SRT_Air_R_babble Integer
26 SRT_SfAR_babble Integer
27 SRT_SfU_babble Integer
28 SRT_Air_L_babble Integer
29 SRT_SfAL_babble Integer
30 SRT_SfAB_babble Integer
31 SAT_Air_R Integer
32 SAT_SfAR Integer
33 SAT_SfU Integer
34 SAT_Bone_R Integer
35 SAT_Air_L Integer
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36 SAT_SfAL Integer
37 SAT_SfAB Integer
38 SAT_Bone_L Integer
39 WordRec_Type Text Audio_WordRecList
40 WordRec_R_1_dB Integer
41 WordRec_R_2_dB Integer
42 WordRec_R_3_dB Integer
43 WordRec_R_4_dB Integer
44 WordRec_L_1_dB Integer
45 WordRec_L_2_dB Integer
46 WordRec_L_3_dB Integer
47 WordRec_L_4_dB Integer
48 WordRec_SfAR_1_dB Integer
49 WordRec_SfAR_2_dB Integer
50 WordRec_SfAR_3_dB Integer
51 WordRec_SfAR_4_dB Integer
52 WordRec_SfAL_1_dB Integer
53 WordRec_SfAL_2_dB Integer
54 WordRec_SfAL_3_dB Integer
55 WordRec_SfAL_4_dB Integer
56 WordRec_SfU_1_dB Integer
57 WordRec_SfU_2_dB Integer
58 WordRec_SfU_3_dB Integer
59 WordRec_SfU_4_dB Integer
60 WordRec_SfAB_1_dB Integer
61 WordRec_SfAB_2_dB Integer
62 WordRec_SfAB_3_dB Integer
63 WordRec_SfAB_4_dB Integer
64 WordRec_Binaural_R_1_dB Integer
65 WordRec_Binaural_R_2_dB Integer
66 WordRec_Binaural_R_3_dB Integer
67 WordRec_Binaural_R_4_dB Integer
68 WordRec_Binaural_L_1_dB Integer
69 WordRec_Binaural_L_2_dB Integer
70 WordRec_Binaural_L_3_dB Integer
71 WordRec_Binaural_L_4_dB Integer
72 WordRec_R_1_pct Integer
73 WordRec_R_2_pct Integer
74 WordRec_R_3_pct Integer
75 WordRec_R_4_pct Integer
76 WordRec_L_1_pct Integer
77 WordRec_L_2_pct Integer
78 WordRec_L_3_pct Integer
79 WordRec_L_4_pct Integer
80 WordRec_SfAR_1_pct Integer
81 WordRec_SfAR_2_pct Integer
82 WordRec_SfAR_3_pct Integer
83 WordRec_SfAR_4_pct Integer
84 WordRec_SfAL_1_pct Integer
85 WordRec_SfAL_2_pct Integer
86 WordRec_SfAL_3_pct Integer
87 WordRec_SfAL_4_pct Integer
88 WordRec_SfU_1_pct Integer
89 WordRec_SfU_2_pct Integer
90 WordRec_SfU_3_pct Integer
91 WordRec_SfU_4_pct Integer
92 WordRec_SfAB_1_pct Integer



212 · AUDBASE

Audbase.book  Page 212  Thursday, May 4, 2006  10:04 PM
93 WordRec_SfAB_2_pct Integer
94 WordRec_SfAB_3_pct Integer
95 WordRec_SfAB_4_pct Integer
96 WordRec_Binaural_1_pct Integer
97 WordRec_Binaural_2_pct Integer
98 WordRec_Binaural_3_pct Integer
99 WordRec_Binaural_4_pct Integer
100 WordRec_R_1_dB_babble Integer
101 WordRec_R_2_dB_babble Integer
102 WordRec_R_3_dB_babble Integer
103 WordRec_R_4_dB_babble Integer
104 WordRec_L_1_dB_babble Integer
105 WordRec_L_2_dB_babble Integer
106 WordRec_L_3_dB_babble Integer
107 WordRec_L_4_dB_babble Integer
108 WordRec_SfAR_1_dB_babble Integer
109 WordRec_SfAR_2_dB_babble Integer
110 WordRec_SfAR_3_dB_babble Integer
111 WordRec_SfAR_4_dB_babble Integer
112 WordRec_SfAL_1_dB_babble Integer
113 WordRec_SfAL_2_dB_babble Integer
114 WordRec_SfAL_3_dB_babble Integer
115 WordRec_SfAL_4_dB_babble Integer
116 WordRec_SfU_1_dB_babble Integer
117 WordRec_SfU_2_dB_babble Integer
118 WordRec_SfU_3_dB_babble Integer
119 WordRec_SfU_4_dB_babble Integer
120 WordRec_SfAB_1_dB_babble Integer
121 WordRec_SfAB_2_dB_babble Integer
122 WordRec_SfAB_3_dB_babble Integer
123 WordRec_SfAB_4_dB_babble Integer
124 WordRec_Binaural_R_1_dB_babble Integer
125 WordRec_Binaural_R_2_dB_babble Integer
126 WordRec_Binaural_R_3_dB_babble Integer
127 WordRec_Binaural_R_4_dB_babble Integer
128 WordRec_Binaural_L_1_dB_babble Integer
129 WordRec_Binaural_L_2_dB_babble Integer
130 WordRec_Binaural_L_3_dB_babble Integer
131 WordRec_Binaural_L_4_dB_babble Integer
132 WordRec_R_1_pct_babble Integer
133 WordRec_R_2_pct_babble Integer
134 WordRec_R_3_pct_babble Integer
135 WordRec_R_4_pct_babble Integer
136 WordRec_L_1_pct_babble Integer
137 WordRec_L_2_pct_babble Integer
138 WordRec_L_3_pct_babble Integer
139 WordRec_L_4_pct_babble Integer
140 WordRec_SfAR_1_pct_babble Integer
141 WordRec_SfAR_2_pct_babble Integer
142 WordRec_SfAR_3_pct_babble Integer
143 WordRec_SfAR_4_pct_babble Integer
144 WordRec_SfAL_1_pct_babble Integer
145 WordRec_SfAL_2_pct_babble Integer
146 WordRec_SfAL_3_pct_babble Integer
147 WordRec_SfAL_4_pct_babble Integer
148 WordRec_SfU_1_pct_babble Integer
149 WordRec_SfU_2_pct_babble Integer
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150 WordRec_SfU_3_pct_babble Integer
151 WordRec_SfU_4_pct_babble Integer
152 WordRec_SfAB_1_pct_babble Integer
153 WordRec_SfAB_2_pct_babble Integer
154 WordRec_SfAB_3_pct_babble Integer
155 WordRec_SfAB_4_pct_babble Integer
156 WordRec_Binaural_1_pct_babble Integer
157 WordRec_Binaural_2_pct_babble Integer
158 WordRec_Binaural_3_pct_babble Integer
159 WordRec_Binaural_4_pct_babble Integer
160 SAT_SRT_WordRec_MaskInfoBlob Blob
161 SAT_SRT_WordRec_MaskInfoText Text
162 PackedDisplay_selector Integer
163 SpecialInfo_Blob Blob

Tympanogram
Field # Field name Field type Associated data list/Notes
1 Subject_ID Long Integer, indexed
2 RecordCreationDate Date
3 RecordModificationHistory Text
4 RecordChecksum Long Integer
5 Primary_Audiogram_No Long Integer, indexed
6 Tympanogram_No Long Integer, indexed
7 Completed_Record Boolean
8 Tympanogram_Date Date
9 Tympanogram_Time Time
10 Examiner Text Audio_Audiologist
11 Notes Text
12 TympanogramRecordInfoBlob Blob
13 Tympanogram_Displays Text
14 Tympanogram_TypesSaved Text
15 ProbeToneTymp_R Integer
16 EarCanalVolume_R Real
17 PeakAdmittance_R Real
18 PeakPressure_R Integer
19 ProbeToneTymp_L Integer
20 EarCanalVolume_C1_L Real
21 PeakAdmittance_L Real
22 PeakPressure_L Integer
23 AcousReflex_Stim_R_Contra_0250 Integer
24 AcousReflex_Stim_R_Contra_0500 Integer
25 AcousReflex_Stim_R_Contra_1000 Integer
26 AcousReflex_Stim_R_Contra_2000 Integer
27 AcousReflex_Stim_R_Contra_4000 Integer
28 AcousReflex_Stim_R_Contra_Noise Integer
29 AcousReflex_Stim_R_Ipsi_0250 Integer
30 AcousReflex_Stim_R_Ipsi_0500 Integer
31 AcousReflex_Stim_R_Ipsi_1000 Integer
32 AcousReflex_Stim_R_Ipsi_2000 Integer
33 AcousReflex_Stim_R_Ipsi_4000 Integer
34 AcousReflex_Stim_R_Ipsi_Noise Integer
35 AcousReflex_Stim_L_Contra_0250 Integer
36 AcousReflex_Stim_L_Contra_0500 Integer
37 AcousReflex_Stim_L_Contra_1000 Integer
38 AcousReflex_Stim_L_Contra_2000 Integer
39 AcousReflex_Stim_L_Contra_4000 Integer
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40 AcousReflex_Stim_L_Contra_Noise Integer
41 AcousReflex_Stim_L_Ipsi_0250 Integer
42 AcousReflex_Stim_L_Ipsi_0500 Integer
43 AcousReflex_Stim_L_Ipsi_1000 Integer
44 AcousReflex_Stim_L_Ipsi_2000 Integer
45 AcousReflex_Stim_L_Ipsi_4000 Integer
46 AcousReflex_Stim_L_Ipsi_Noise Integer
47 AcousReflexDecay_Stim_R_0500 Integer Tymp_Abnormal/Normal
48 AcousReflexDecay_Stim_R_1000 Integer Tymp_Abnormal/Normal
49 AcousReflexDecay_Stim_R_2000 Integer Tymp_Abnormal/Normal
50 AcousReflexDecay_Stim_R_4000 Integer Tymp_Abnormal/Normal
51 AcousReflexDecay_Stim_R_Noise Integer Tymp_Abnormal/Normal
52 AcousReflexDecay_Stim_L_0500 Integer Tymp_Abnormal/Normal
53 AcousReflexDecay_Stim_L_1000 Integer Tymp_Abnormal/Normal
54 AcousReflexDecay_Stim_L_2000 Integer Tymp_Abnormal/Normal
55 AcousReflexDecay_Stim_L_4000 Integer Tymp_Abnormal/Normal
56 AcousReflexDecay_Stim_L_Noise Integer Tymp_Abnormal/Normal
57 AcousReflexDecay_Info Text
58 TympanogramCurveType_R Alpha 2 Tymp_TympCurveType
59 TympanogramCurveType_L Alpha 2 Tymp_TympCurveType
60 SpecialInfo_Blob Blob

Fields listed in alphabetical order with field numbers
In this section the data fields appear in alphabetical order for cross-referencing with field 
numbers.

Kernel tables

ClinicalGroup
Field name Field#
Address 6
ClinicalGroupIdentifierFormat 19
City 7
ClinicalGroup_ID 1
ClinicalGroupChecklist 21
ClinicalGroupExportSeqSearch 23
ClinicalGroupGroupedExport 22
Completed_Record 31
Country 10
CountryPhoneCode 30
EMail_Address 17
EMail_AttachmentMaxSize 24
EMail_SingleAttachmentsOnly 25
Group_Type 32
Is_A_Study 20
ListName 18
Name 5
Phone1 11
Phone1Type 12
Phone2 13
Phone2Type 14
Phone3 15
Phone3Type 16
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PrivateKeyEncrypted 26
PublicKeyEncrypted 27
RecordChecksum 4
RecordCreationDate 2
RecordModificationHistory 3
State 8
Study_ImportKeysEncrypted 29
Study_ParticipantID 28
ZipCode 9

Constants
Field name Field#
Alpha_Constant 3
Blob_Constant 5
Constant_Name 1
Date_Constant 6
LongInt_ID 2
Text_Constant 4

LargeObject
Field name Field#
LargeObject_Blob 6
LargeObject_ComboID 1
LargeObject_Pict 8
LargeObject_SubID 5
LargeObject_Text 7
RecordChecksum 4
RecordCreationDate 2
RecordModificationHistory 3

Provider
Field name Field#
Address 10
AllSubjectPrivileges 28
City 11
ClinicalGroupsInSubjectList_Set 27
Completed_Record 36
Country 14
CountryPhoneCode 33
E_Mailbox_Type 37
EMail_Address 22
EMail_IncomingServerName 31
EMail_IncomingUserName 32
EMail_OutgoingServerName 29
EMail_OutgoingUserName 30
FirstName 6
Gender 15
Info_Blob 35
LastName 7
ListName 24
LocalClinicalGroupList_Set 26
LocalProviderList_Set 25
LoginName 23
MiddleName 8
Occupation 34
Phone1 16
Phone1Type 17
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Phone2 18
Phone2Type 19
Phone3 20
Phone3Type 21
Provider_ID 1
RecordChecksum 4
RecordCreationDate 2
RecordModificationHistory 3
Salutation 5
State 12
Title 9
ZipCode 13

ProviderGroup
Field name Field#
ClinicalGroup_ID 2
IsGroupAdministrator 3
Provider_ID 1

Reminder
Field name Field#
ActionDate 9
ActionTaken 10
DueDate 7
Note 11
OrigDueDate 8
Subject_ID 1
Provider_ID 5
RecordChecksum 4
RecordCreationDate 2
RecordModificationHistory 3
ReminderType 12
Study_ID 6
Study_Name 13
Subtype_Num 14

Saved Sets
Field name Field#
File Number 2
Rec Mod 3
Records_In_set 5
Set Data 4
Set Name 1

Subject
Field name Field#
Address 10
Birthdate 22
ClinicalGroupIdentifier_Primary 31
City 11
ClinicalGroup_ID_Primary 32
Completed_Record 37
Country 14
CountryPhoneCode 21
DeathDate 23
FirstName 6
Gender 25



APPENDICES· 217

Audbase.book  Page 217  Thursday, May 4, 2006  10:04 PM
Inactive 29
LastContactDate 24
LastName 7
LivingStatus 27
LivingStatus_Contact_History 28
MiddleName 8
Notes 30
Phone1 15
Phone1Type 16
Phone2 17
Phone2Type 18
Phone3 19
Phone3Type 20
Provider_ID_Primary 33
ProviderName_Primary 34
Race 26
RecordChecksum 4
RecordCreationDate 2
RecordModificationHistory 3
ReferralProviderIDs 36
Salutation 5
State 12
Subject_ID 1
Title 9
Universal_ID 35
ZipCode 13

SubjectClinicalGroup
Field name Field#
ClinicalGroupIdentifier 3
ClinicalGroup_ID 2
Subject_ID 1

SubjectProvider
Field name Field#
Subject_ID 1
Provider_ID 2
Tumor_Stage 68

Audiogram/Tympanogram/SAT_SRT_WordRecognition Tables

Audiogram
Field name Field#
Audiogram_Date 9
Audiogram_No 5
Audiogram_SpecFrequencyType 21
Audiogram_Time 10
Audiometer_Type 13
BoneInfoBlob 486
BoneInfoText 488
Comment_BooleanFlag 492
CommentInfoText 490
Completed_Record 6
DisplayPrefsBlob 481
Examiner 11
HearingLevel_dB_Standard 495
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L_CommentFlagBlob 484
L_NRFlagBlob 485
MaskInfoBlob 487
MaskInfoText 489
NoResponse_BooleanFlag 493
Notes 12
Other_Info_Data 496
PackedDisplay_selector 20
PureTone_AML_00125 131
PureTone_AML_00250 132
PureTone_AML_00500 133
PureTone_AML_00750 134
PureTone_AML_01000 135
PureTone_AML_01500 136
PureTone_AML_02000 137
PureTone_AML_03000 138
PureTone_AML_04000 139
PureTone_AML_06000 140
PureTone_AML_08000 141
PureTone_AML_12000 142
PureTone_AML_SpF01 203
PureTone_AML_SpF02 204
PureTone_AML_SpF03 205
PureTone_AML_SpF04 206
PureTone_AML_SpF05 207
PureTone_AML_SpF06 208
PureTone_AML_SpF07 209
PureTone_AML_SpF08 210
PureTone_AML_SpF09 211
PureTone_AML_SpF10 212
PureTone_AML_SpF11 213
PureTone_AML_SpF12 214
PureTone_AMR_00125 35
PureTone_AMR_00250 36
PureTone_AMR_00500 37
PureTone_AMR_00750 38
PureTone_AMR_01000 39
PureTone_AMR_01500 40
PureTone_AMR_02000 41
PureTone_AMR_03000 42
PureTone_AMR_04000 43
PureTone_AMR_06000 44
PureTone_AMR_08000 45
PureTone_AMR_12000 46
PureTone_AMR_SpF01 107
PureTone_AMR_SpF02 108
PureTone_AMR_SpF03 109
PureTone_AMR_SpF04 110
PureTone_AMR_SpF05 111
PureTone_AMR_SpF06 112
PureTone_AMR_SpF07 113
PureTone_AMR_SpF08 114
PureTone_AMR_SpF09 115
PureTone_AMR_SpF10 116
PureTone_AMR_SpF11 117
PureTone_AMR_SpF12 118
PureTone_AUL_00125 119
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PureTone_AUL_00250 120
PureTone_AUL_00500 121
PureTone_AUL_00750 122
PureTone_AUL_01000 123
PureTone_AUL_01500 124
PureTone_AUL_02000 125
PureTone_AUL_03000 126
PureTone_AUL_04000 127
PureTone_AUL_06000 128
PureTone_AUL_08000 129
PureTone_AUL_12000 130
PureTone_AUL_SpF01 191
PureTone_AUL_SpF02 192
PureTone_AUL_SpF03 193
PureTone_AUL_SpF04 194
PureTone_AUL_SpF05 195
PureTone_AUL_SpF06 196
PureTone_AUL_SpF07 197
PureTone_AUL_SpF08 198
PureTone_AUL_SpF09 199
PureTone_AUL_SpF10 200
PureTone_AUL_SpF11 201
PureTone_AUL_SpF12 202
PureTone_AUR_00125 23
PureTone_AUR_00250 24
PureTone_AUR_00500 25
PureTone_AUR_00750 26
PureTone_AUR_01000 27
PureTone_AUR_01500 28
PureTone_AUR_02000 29
PureTone_AUR_03000 30
PureTone_AUR_04000 31
PureTone_AUR_06000 32
PureTone_AUR_08000 33
PureTone_AUR_12000 34
PureTone_AUR_SpF01 95
PureTone_AUR_SpF02 96
PureTone_AUR_SpF03 97
PureTone_AUR_SpF04 98
PureTone_AUR_SpF05 99
PureTone_AUR_SpF06 100
PureTone_AUR_SpF07 101
PureTone_AUR_SpF08 102
PureTone_AUR_SpF09 103
PureTone_AUR_SpF10 104
PureTone_AUR_SpF11 105
PureTone_AUR_SpF12 106
PureTone_BML_00125 155
PureTone_BML_00250 156
PureTone_BML_00500 157
PureTone_BML_00750 158
PureTone_BML_01000 159
PureTone_BML_01500 160
PureTone_BML_02000 161
PureTone_BML_03000 162
PureTone_BML_04000 163
PureTone_BML_06000 164
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PureTone_BML_08000 165
PureTone_BML_12000 166
PureTone_BMR_00125 59
PureTone_BMR_00250 60
PureTone_BMR_00500 61
PureTone_BMR_00750 62
PureTone_BMR_01000 63
PureTone_BMR_01500 64
PureTone_BMR_02000 65
PureTone_BMR_03000 66
PureTone_BMR_04000 67
PureTone_BMR_06000 68
PureTone_BMR_08000 69
PureTone_BMR_12000 70
PureTone_BUL_00125 143
PureTone_BUL_00250 144
PureTone_BUL_00500 145
PureTone_BUL_00750 146
PureTone_BUL_01000 147
PureTone_BUL_01500 148
PureTone_BUL_02000 149
PureTone_BUL_03000 150
PureTone_BUL_04000 151
PureTone_BUL_06000 152
PureTone_BUL_08000 153
PureTone_BUL_12000 154
PureTone_BUR_00125 47
PureTone_BUR_00250 48
PureTone_BUR_00500 49
PureTone_BUR_00750 50
PureTone_BUR_01000 51
PureTone_BUR_01500 52
PureTone_BUR_02000 53
PureTone_BUR_03000 54
PureTone_BUR_04000 55
PureTone_BUR_06000 56
PureTone_BUR_08000 57
PureTone_BUR_12000 58
PureTone_MCL_00125 167
PureTone_MCL_00250 168
PureTone_MCL_00500 169
PureTone_MCL_00750 170
PureTone_MCL_01000 171
PureTone_MCL_01500 172
PureTone_MCL_02000 173
PureTone_MCL_03000 174
PureTone_MCL_04000 175
PureTone_MCL_06000 176
PureTone_MCL_08000 177
PureTone_MCL_12000 178
PureTone_MCR_00125 71
PureTone_MCR_00250 72
PureTone_MCR_00500 73
PureTone_MCR_00750 74
PureTone_MCR_01000 75
PureTone_MCR_01500 76
PureTone_MCR_02000 77
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PureTone_MCR_03000 78
PureTone_MCR_04000 79
PureTone_MCR_06000 80
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Appendix C: Data lists and their data field 
values
AudBase uses data lists in pop-up and hierarchical lists to present standardized form selec-
tions. The actual data value, which is stored in the data field when a selection is made, 
depends on the type of data field associated with the list (see: “Appendix B: Tables and 
Fields” on page 196). Data lists associated with alphanumeric (string and text) data fields 
place their text values in the data field. Data lists associated with integer fields place the 
list position of their text values in the data field. The list positions are in ascending order 
from top to bottom with the exception of the “Not Done/N.D.” value which is always at 
the bottom of a list. “Not Done/N.D.” values are stored as a <blank> alphanumeric value 
or the number “0” in a numeric field unless otherwise noted in Appendix B. 

Note: Some data lists only contain numbers. These lists are associated with numeric 
data fields and the actual value is the same as the displayed value.

Administrators and subadministrators can modify certain lists. Depending on how the data 
is stored, the list order is crucial. For more information, see “Modifiable Lists” on 
page 181.

When you add list items to data lists that are associated with alphanumeric fields, there are 
no restrictions on list item order since the list item value is simply stored in the data field. 
When dealing with an associated numeric value field, it is imperative to preserve the list 
order. Any change in the old list order would change the presumed meaning of the previ-
ously stored values. Therefore, list additions to integer field-associated lists can only be 
made at the end of the list. This is enforced by the list modification dialog. Since you a 
user can add list items to the modifiable lists, he or she can print out or create a text file 
copy of the most current version of these lists. To do so, from the Home Window choose 
Reports > Modifiable Lists. For more information, see “Modifiable Lists” on page 181.

The data lists are cross-referenced with their corresponding data fields. For more informa-
tion on these data fields, see “Appendix B: Tables and Fields” on page 196. Using these 
two appendices you can search for any data in the database. For example, the [Sub-
ject]Gender field uses the Gender list. The data field values corresponding with the Gen-
der list selections are: 1 = “Female”, 2 = “Male” and 0 = “N.D.”. A search for female 
subjects would include the query line: “[Subject]Gender” = 1.

Within each section the lists are divided into kernal lists, included with all versions of 
AudBase, followed by any custom lists specific to this version.  

Kernel Lists

C_Location
List Item Stored Field Value Notes
No No
*C* *C*
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N.D <blank>

ClinicalGroup_Type
List Item Stored Field Value Notes
Hospital Hospital
Institution Institution
School School
N.D. <blank>

Gender
List Item Stored Field Value Notes
Female 1
Male 2
N.D. 0

Location
List Item Stored Field Value Notes
R R
C C
L L
N.D. <blank>

L_Location
List Item Stored Field Value Notes
No No
**L **L
N.D. <blank>

Provider_Occupation [Modifiable]
List Item Stored Field Value Notes
Physician Physician
N.D. <blank>

Race [Modifiable]
List Item Stored Field Value Notes
Asian 1
Black 2
Caucasian 3
Hispanic 4
N.D. 0

RCL_Location
List Item Stored Field Value Notes
No No
R** R**
RC* RC*
RCL RCL
R*L R*L
*C* *C*
*CL *CL
**L **L
N.D. <blank>

Reminder_Type [Modifiable]
List Item Stored Field Value Notes
Triggers Triggers
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Chart is out to: Chart is out to:
Undefined Undefined
N.D. <blank>

RL_Location
List Item Stored Field Value Notes
No No
R** R**
R*L R*L
**L **L
N.D. <blank>

R_Location
List Item Stored Field Value Notes
No No
R** R**
N.D. <blank>

Salutation [Modifiable]
List Item Stored Field Value Notes
Mr. Mr.
Ms. Ms.
Mrs. Mrs.
Dr. Dr.
--- <blank>

Subject_ContactType
List Item Stored Field Value Notes
Clinic visit\Hospital admission 1
Chart review 2
Dept. of vital stats 3
Internet 4
Phone, care provider 5
Phone, subject 6
Phone, relative 7
Other 8
Unknown 9
N.D. 0

Subject_LivingStatus
List Item Stored Field Value Notes
Living 1
Death from disease 2
Death with disease 3
Death no disease 4
Death unknown status 5
N.D. 0

Telephone_Type [Modifiable]
List Item Stored Field Value Notes
Home 1
Work 2
Fax 3
Cell 4
N.D. 0
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Yes/No
List Item Stored Field Value Notes
No 1
Yes 2
N.D. 0

Yes/No/Indeterminant
List Item Stored Field Value Notes
No 1
Yes 2
Indeterminant 3
N.D. 0

Audiologram/Tympanogram/SAT_SRT_WordRecognition Lists

Audio_Audiologist [Modifiable]
List Item Stored Field Value Notes
Select Audiologist <blank>

Audio_AudiometerType [Modifiable]
List Item Stored Field Value Notes
Decibel Decibel
GSI 10 GSI 10
GSI 16 GSI 16
GSI 61 GSI 61
Other Other
N.D. <blank>

Audio_CommentsExtended [Modifiable]
This is a special hierarchical list with attached extended comments up to 32,000 characters

Audio_CommentsShort [Modifiable]
List Item Stored Field Value Notes
Dizziness/Vertigo Dizziness/Vertigo
Family hx of hearing loss Family hx of hearing loss
Head trauma Head trauma
Hearing complaints Hearing complaints
Hx of middle ear pathology Hx of middle ear pathology
Noise exposure Noise exposure
Tinnitus Tinnitus
Select Complaint <blank>

Audio_Other_Info_Data
List Item Stored Field Value Notes
Hearing Loss Profile N/A;H1;H2;H3;H4;Defer; Special parsed text field consisting of

 List item:pop-up selection;

Audio_Other_Info_Data_Modified[Modifiable]
List Item Stored Field Value Notes
MODIFIABLE ELEMENTS ADDED BY USER As for Audio_Other_Info_Data
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Audio_PTAFreq
List Item Stored Field Value Notes
2a freq - 500/1000 1
2b freq - 500/2000 2
2c freq - 1000/2000 3
3a freq - 500/1000/2000 0
3b freq - 500/1000/2000 6
4a freq - 500/1000/2000 4
4b freq - 500/1000/2000 5

Audio_Reliability
List Item Stored Field Value Notes
Good Good
Fair Fair
Poor Poor
N.D. <blank>

Audio_SoundfieldAidedTypes
List Item Stored Field Value Notes
AR 1
AL 2
AB 3
CR 4
CL 5
CB 6
HR 7
HL 8
HB 9
ARCL 10
ARHL 11
CRAL 12
CRHL 13
HRAL 14
HRCL 15

Audio_SoundfieldUnaidedTypes
List Item Stored Field Value Notes
S (=SfU) 1
SR 2
SL 3

Audio_SpondeeType [Modifiable]
List Item Stored Field Value Notes
Spondees/LV Spondees/LV
Spondess/REC Spondess/REC
Trium Trium
Other/LV Other/LV
Other/REC Other/REC
Other (see notes)
N.D. <blank>

Audio_TestingLocation [Modifiable]
List Item Stored Field Value Notes
Select Location <blank>
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Audio_TestingMethod [Modifiable]
List Item Stored Field Value Notes
CA CA
CPA CPA
VROCA VROCA
VRA VRA
Select Test Method <blank>

Audio_TestingSublocation [Modifiable]
List Item Stored Field Value Notes
Select Sublocation <blank>

Audio_Transducer [Modifiable]
List Item Stored Field Value Notes
ER-3-A ER-3-A
Other Other
TDH-49 TDH-49
N.D. <blank>

Audio_WordRecList [Modifiable]
List Item Stored Field Value Notes
W-22 / LV W-22 / LV
W-22 / REC W-22 / REC
NU-6 / LV NU-6 / LV
NU-6 / REC NU-6 / REC
Other (see notes)
N.D. <blank>

Tymp_Abnormal/Normal
List Item Stored Field Value Notes
Abnormal 1
Normal 2
N.D. 0

Tymp_TympCurveType
List Item Stored Field Value Notes
A A
Ad Ad
As As
B B
C C
N.D. <blank>
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Appendix D: Menu Bar Index
This appendix defines all the menu bars in AudBase. The audiology-specific menu bars 
are listed at the end of this section.

Administrator Menu Bar

Menu Menu Item Section Reference
File Home Window Menu Bar “Home Window” on page 10

Exit
Edit Undo

-
Cut
Copy
Paste
Clear 
Select All
-
Show Clipboard

Import\Export AdminOnly Search “Performing administrator-only searches” on 
page 141

AdminOnly Export “Performing administrator-only exports” on 
page 143

-
Import Raw Data “Import Raw Data menu item” on page 143
Import TRANSFER Doc “Importing TRANSFER documents” on page 144
-
Export a Grouped Export “Exporting a Grouped Export” on page 146
Import a Grouped Export “Importing a Grouped Export” on page 147
-
Encrypt TRANSFER Doc “Encrypting a TRANSFER document” on 

page 147
Decrypt TRANSFER Doc “Decrypting a TRANSFER document” on 

page 148
Decrypt a Grouped Export “Decrypting Grouped Exports” on page 148
-
Export Lists “Export Lists menu item” on page 149
Import Lists “Importing lists” on page 149
-
User Privileges Report “Creating a User Privileges Report” on page 151
-
Database Structure “Database Structure Menu item” on page 152

Clean Ups Delete [LargeObject] Recs “Deleting LargeObject records” on page 152
-
Update Subject Sets “Updating subject sets” on page 152
Update Searches\Exports “Updating searches and exports” on page 152
Clear Unconnected Recs “Clearing unconnected records” on page 153
Execute All Clean Ups “Execute All Clean Ups menu item” on page 153
-
Export for Upgrade “Exporting items before upgrading versions” on 

page 154
Import for New Version “Importing items for a new version” on page 154

Windows Window Menu
Help About AudBase
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Clinical Group Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

-
Page Setup...
-
Exit

Clinical Group Add Subjetcs to Group “Adding and removing a group of subjects,” on 
page 27

Remove Subjects from Group
-
Data Checklist “Creating Checklists” on page 131
-
Export Study Tools “Exporting study tools” on page 32
Import Study Tools “Importing study tools” on page 32
Erase Grouped Export Set “Exporting a Grouped Export” on page 146

Windows Window Menu
Help About AudBase
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Edit Saved Search/Sequential Search/Saved Export/Grouped 
Export

Menu Menu Item Section Reference
File Load from Disk “Preferences” on page 108

-
Save to Disk “Preferences” on page 108
-
Exit

Edit Undo
-
Cut
Copy
Paste
Clear 
Select All
-
Show Clipboard

Help About AudBase

Home Window Menu Bar

Menu Menu Item Section Reference
File Provider Info “Entering Provider data” on page 18

Clinical Group Info “Viewing Clinical Group records” on page 28
-
Internal Mail “Internal Mail” on page 14
-
Edit Documents “Editing documents” on page 97
Page Setup...
Preferences “Preferences” on page 108
-
Exit

Edit Undo
-
Cut
Copy
Paste
Clear 
Select All
-
Show Clipboard

Subjects Subject List “Subject List” on page 11
New Subject “Entering subject records” on page 41
-
Limited Field Search “Limited Field Search” on page 13
Search “Searching” on page 70
-
Review Reminders “Reviewing reminders” on page 48
-
Subject List Criteria “Setting Subject List criteria” on page 11

Reports Print Reminder Document “Printing reminders and related forms” on 
page 100
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Print Referral Document “Printing referrals” on page 102
Print Any Document “Printing documents” on page 99
-
Modifiable Lists “Modifiable Lists” on page 181
-
Export Data “Exporting and Reporting” on page 88
Graph Data “Graphing data” on page 96
Report Data “Creating reports” on page 96

Data Manager Check Missing Data “Checking for missing data” on page 103

-
Human Subjects Info AudBase
Tumor Statistics AudBase

-
Administrator Menu Bar

Windows
Help About AudBase

Provider Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

-
Page Setup...
-
Exit

Edit Undo
-
Cut
Copy
Paste
Clear 
Select All
-
Show Clipboard

Provider Add Subjects to Provider “Adding and removing a group of subjects” on 
page 27

-
Data Checklist “Creating Checklists” on page 131
-
Administrator Checklist “Assigning an Administrator Checklist” on 

page 19
Administrator E-mail “Setting up administrator e-mail” on page 20
Administrator Password “Changing administrator password” on page 20

Windows
Help About AudBase

Subject List Menu Bar

Menu Menu Item Section Reference
File Provider Info “Entering Provider data” on page 18

Clinical Group Info “Viewing Clinical Group records” on page 28
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-
Internal Mail “Internal Mail” on page 14
-
Edit Documents “Editing documents” on page 97
Page Setup...
Preferences “Preferences” on page 108
-
Exit

Edit Undo
-
Cut
Copy
Paste
Clear 
Select All
-
Show Clipboard

Subjects New Subject “Entering subject records” on page 41
Delete Subjects “Deleting records” on page 155

-
Review Reminders “Reviewing reminders” on page 48
Add Reminder “Adding reminders” on page 46
-
Limited Field Search “Limited Field Search” on page 13
Search “Searching” on page 70
-
Limit Subject List “Limit Subject List/Full Subject List” on page 13
Full Subject List
Subject List Criteria “Setting Subject List criteria” on page 11
-
Home Window “Home Window” on page 10

Reports Subject Information “Entering subject records” on page 41
-
Print Reminder Document “Printing Reminders” on page 100
Print Referral Document “Printing Referrals” on  page 100
Print Any Document
-
Export Data  “Exporting and Reporting” on page 88
Graph Data  “Graphing data” on page 96
Report Data  “Creating reports” on page 96

Windows
Help About AudBase

Subject Studies Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

-
Page Setup...
-
Exit

Edit Undo
-
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Audiologram/Tympanogram/SAT_SRT_WordRecognition Menu Bars

Audiogram Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

Serial Port Settings “Serial Port Settings” on page 135
Print Audiogram “Printing audiograms” on page 66
Print Preview
Page Setup “Printing audiograms” on page 66
Audiogram Print Forms “Printing audiograms” on page 66
Exit

Edit Undo
Cut
Copy
Paste
Clear 
Select All
Show Clipboard

Audiogram Open Serial Port “Working with an audiometer or tympanometer” 
on page 64

Display Serial Port Info “Display Comparison Audiogram” on page 66
Display Comparison Audiogram“Display Comparison Audiogram” on page 66
Display Word List “Display Word Lists” on page 66
Reset Audiogram “Resetting audiograms” on page 65
Change Hearing Level Std “Change Hearing Level Standard” on page 66
Data Checklist
Delete Audiogram “Deleting audiograms” on page 66

Windows Subject List
Drawing Line Drawing “Display options” on page 56

Masking Drawing “Display options” on page 56
Side “Display options” on page 56
Type “Display options” on page 56
Soundfield subtypes “Display options” on page 56
Modifiers “Display options” on page 56
Icon Style “Display options” on page 56
HTLA background “Display options” on page 56

Special Calculations “AMA Handicap” on page 64
Serial Port Device “Working with an audiometer or tympanometer” 

on page 64
Audiometer Options “Working with an audiometer or tympanometer” 

on page 64
Help About AudBase

SAT\SRT\WordRec Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

Serial Port Settings “Serial Port Settings” on page 135
Print SAT\SRT\WordRec “Printing audiograms” on page 66
Print Preview
Page Setup “Printing audiograms” on page 66
Audiogram Print Forms “Printing audiograms” on page 66
Exit
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Edit Undo
Cut
Copy
Paste
Clear 
Select All
Show Clipboard

SAT\SRT\WordRec Open Serial Port “Working with an audiometer or tympanometer” 
on page 64

Display Serial Port Info “Working with an audiometer or tympanometer” 
on page 64

Display Word List “Display Word Lists” on page 66
Reset SAT\SRT\WordRec
Data Checklist
Delete SAT\SRT\WordRec “Deleting audiograms” on page 66

Windows Subject List
Special Calculations  

Serial Port Device “Working with an audiometer or tympanometer” 
on page 64

Audiometer Options
Help About AudBase

Tympanogram Menu Bar

Menu Menu Item Section Reference
File Internal Mail “Internal Mail” on page 14

Serial Port Settings “Audiology (3)” on page 111
Print Tympanogram “Printing audiograms” on page 66
Print Preview
Page Setup “Printing audiograms” on page 66
Audiogram Print Forms “Printing audiograms” on page 66
Exit

Edit Undo
Cut
Copy
Paste
Clear 
Select All
Show Clipboard

Tympanogram Open Serial Port “Working with an audiometer or tympanometer” 
on page 64

Display Serial Port Info “Working with an audiometer or tympanometer” 
on page 64

Reset Tympanogram
Data Checklist
Delete Tympanogram “Deleting audiograms” on page 66

Windows Subject List
Special Calculations  

Serial Port Device “Working with an audiometer or tympanometer” 
on page 64

Audiometer Options
Help About AudBase
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A
about this manual iii
access

assigning read/write 125
privileges 7
reading records 10
Subject Studies 126
writing records 10

accessing subject information 102
administrator

AdminOnly Export 143
AdminOnly Search 141
checklist 19
e-mail 20
menu bar 140
password menu item 20
privileges 9
Provider menu items for 19

AND vs. OR in searching 75
assigning checklists

to administrator 19
to Clinical Group 30
to Provider 25

assigning participant ID 7
attachments, maximum size 36
AudBase 88
Audiogram 50–67

bone conduction tests 53
creating new 50
Pure Tone Averages 55
recording audiometric data 51
reflex tests 62
setting frequency range 55
SRT/SAT tests 57
word recognition tests 58

B
black lock icon 40
bone conduction, testing 53

C
cache system, using 165
caregivers, referring 44
Chart Wizard 96
checking for missing data 103
Checking study statistics 105
checking study statistics 105
checklists 131–134

administrator 19
assigning 133
assigning separate 134
assigning to Clinical Group 30
copying and pasting errors 104
creating 131
Master Checklist 134
Provider 25
using 134

checksums 183–187
Checksum export format 91
checksum reports 184
in imported records 186

Clean-ups Menu 152
Clear Unconnected Recs item 153
client machine, configuring

PC 163
Clinical Group 28–37

"is a study" checkbox 32
assigning 43
assigning checklist 30
e-mail address 36
identifier format 29
information form 28
viewing records 28

clinical study
assigning checklist, search and export 30
exporting study tools 32
importing study tools 32
study export 34–36
study import 36–37
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comments, in Audiogram 54
composing mail 14
connecting to an encrypted server

PC 164
controlling access privileges 7
corrupted files 189
Creating 96
creating data files 5
creating reports 96–100

D
data field values 231
data fields

generating list of 152
merging with documents 174
values 231

data files
changing 157
creating 5
dividing 156
fixing 190

data lists and their data field values 231
Database Access preferences item 112, 114
Database Structure menu item 152
decryption

Grouped Exports 148
setting up 35
TRANSFER documents 148

default Providers and Clinical Groups 43
deleting LargeObject Records 152
deleting records 155
delimiters for export 94
demographics, subject 46
designating primary Providers 44
documents

editing 97–99
merging with data fields 174

E
editing documents 97–99
e-mail

administrator 20
central data collection 36
composing 14
enclosures 36
entering Provider information 26
internal 14
login name 26

server 27
e-mail export, setting up 36
encryption

generating keys 36
modifying public key 37
saving public key to disk 36, 37
server connection 162
setting up 34
TRANSFER documents 147

entry formats 108
equivalent lists 183
Export Lists item 149
Export/Grouped Export 118–122
exporting data 88–95

administrator only export 143
checksum format 91
Export a Grouped Export 146
field or record delimiters 94
PICT format 92
required internal ID fields 174
Saved Exports 95
selecting data for export 88
selecting format 90
TRANSFER format 92
via e-mail 36

exporting study tools 32

F
field lengths for text exports 176
fields and tables, complete list 196
file maintenance 190
File not found error 157
file types for export 90
files, corrupted 189
Format 108
Format On/No Format

button 41
Provider form 25
setting global preference 108

formatting
Clinical Group identifier 29
entry formats 108
exports 90
lists for import 150
U.S. State List 42
Universal ID 118

forms
Clinical Group 28
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New Query 72
Provider Information 21
Provider List 19
Quick Report 96
Search 71
unlocking 40

frequency range, setting 55

G
graphing data 96
group access, Provider 30
group administrator

designating 30
privileges 9

Grouped Exports
creating 121
decrypting 148
exporting 146
importing 147
location of files 145

H
Home Window

changing logo 122
defined 10

Human Subjects info 105

I
ID numbers, internal 176
identifier, Clinical Group 43
Import a Grouped Export 147
Import for New Version menu item 154
Import Lists item 149
ImportExport Menu 141–152
importing study tools 32
initial password 4
installation files

list 194
installing Otobase 2
installing Otobase Server 160
internal ID number 176
internal mail 14
international "state" list 117
international data entry formats 116

L
LargeObject Records 152
launching Otobase 3
limiting Subject List 13

lists
alternate value 183
exporting 149
formatting for import 150
importing 149
importing for a new version 154
modifiable 181
Modify Lists 109
multiple version 182
Providers and Clinical Groups 43

Loading Saved Exports from disk 120
localization

modifying data entry formats 116
Non-USA State List 117

log file of record access 126
login name 26
logo, Home Window 122

M
marking complete records 155
Master Checklist 134
menu bar, administrator 140
menu bars, complete list of 237
menu structure 10
merging documents with data fields 174
missing data, checking for 103
modifiable lists 181
Modify Lists feature 109
multiple version lists 182

N
N.D. values, searching 180
new data file 5
new subject record, creating 41
Not Done values,searching 180
Not Done/N.D. field value 179

O
opening Otobase 3
Otobase Server

encrypted connection 162
installing 160
installing for Macintosh 164
installing for Windows 161
using 4D Write

Windows 163
using a cache system 165
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P
participant ID

assigning 7
study 34

passwords
administrator 20
assigning 156
expiration 116
if you forget 191
initial 4

personal Provider and Clinical Group lists 21
printing

documents 99
files 99
referrals 102
reminders 100

private encryption key, generating 36
privileges

administrator 9
group administrator 9
Provider 8
subadministrator 9

Provider
adding, removing group of subjects 27
All Subject Privileges button 22
assigning 43
checklist 25
creating new record 18
designating primary 44
e-mail address 27
entering data 18
Full Group Access Privileges List 22
login/e-mail 26–27
new 21
privileges 8
table record privileges 23
with group access 30

Provider Information form 21
Provider List form 19
Provider record

modifying 21
public encryption key

generating 36
modifying 37
saving to disk 36

Pure Tone Averages 55

Q
query

constructing 74
New Query form 72

R
Read Write and Deletion options 115
read/write access 10
Record Access

Log File 126
preferences item 125
setting for tables 23

record access, setting for tables 23
records

deleting 155
marking complete 155
saving 45

red lock icon 40
referrals, printing 102
referring caregivers 44
reflex tests, acoustic 62
refreshing the Subject List 12
relationships, database tables 173
reminders

adding 46
printing 100
reviewing 48
user privileges to modify 115

reports
checksums 184
creating 96
Quick Report form 96

required internal ID fields for export 174
requirements, system 2
RRP Clinical Course graphs, generating 97

S
Saved Exports

creating 95
editing 119
loading from database 95

Saved Searches
creating 80
editing 129

Saving exports to disk 120
saving records 45
searching

"Not Done/N.D." values 179
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administrator only search 141, 142
building query line 74
combine sets dialog 76
for "Not Done/N.D." values 180
importance of search order 75
New Query form 72
Saved Searches 80
Search form 71
set theory 177
Special Relation searches 82
Special Relation special operation query

85
selected identifier 43
sending e-mail 14
Sequential Searches

creating 130
executing 81

Serial Port Settings 135
server for e-mail 27
set theory, searching 177
setting up export 36
SRT/SAT tests 57
starting Otobase 3
State List

creating Non-USA State List 117
Provider form 26
setting global preference 108

State List button 42
static program elements, rebuilding 190
structure file

fixing 190
password 4

study
assigning checklist, search and export 30
designating group as 32
export setup items 34–36
exporting study tools 32
import setup items 36–37
importing study tools 32

study participant ID 34
subadministrator

privileges 9
status button 26

Subject Info/Navigation 136
subject information, accessing 102
Subject List 11

customizing for Providers 136
full 13

limiting 13
updating 12

subject records
adding group to Provider record 27
assigning en masse to Clinical Group 33
creating 41
viewing 46

subject related table list 172
Subject Studies

Access preferences item 126
Subject Studies form

using 45
Subject Studies form, using 45
system requirements 2

T
tab delimiters 94
table access privileges 23
table structure 168
tables

relationships 168, 173
subject-related 172

tables and fields, complete list 196
TRANSFER documents

decrypting 148
encrypting 147
exporting 92

troubleshooting 189

U
U.S. State List

modifying 183
U.S. State List, on Provider form 26
unconnected records, clearing 153
union, difference, intersection explained 76
Universal ID

entering 43
formatting 118

unlocking forms 40
setting global read-write privileges 115

Update Searches/Exports 152
Update Subject Sets item 152
updating searches and exports 152
updating the Subject List 12
upgrading to new Otobase version

Version 2.5 or newer 157, 158
user access 10
User Privileges Report 151
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User Privileges Report, creating 151
User Reminder Privileges 115

V
viewing unique ID fields 176

W
windows

Home Window 10
Subject List 11

word recognition tests 58
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